summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-04-17 17:26:26 +0000
committerStanislav Brabec <utx@gentoo.org>2003-04-17 17:26:26 +0000
commit83a710bde7c6e439faf51b6152d4aeb68466c412 (patch)
tree53ceb92b0d7fbe1391b654ecb527a82793835456 /dev-lang
parentAdding info about config file (diff)
downloadhistorical-83a710bde7c6e439faf51b6152d4aeb68466c412.tar.gz
historical-83a710bde7c6e439faf51b6152d4aeb68466c412.tar.bz2
historical-83a710bde7c6e439faf51b6152d4aeb68466c412.zip
New version
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/ChangeLog7
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.21
-rw-r--r--dev-lang/tcl/tcl-8.4.2.ebuild74
-rw-r--r--dev-lang/tk/ChangeLog8
-rw-r--r--dev-lang/tk/files/digest-tk-8.4.21
-rw-r--r--dev-lang/tk/files/remove-control-v-8.4.diff17
-rw-r--r--dev-lang/tk/tk-8.4.2.ebuild71
7 files changed, 177 insertions, 2 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index cebd31466186..96a8cf595308 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.12 2003/04/04 21:12:44 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.13 2003/04/17 17:22:44 utx Exp $
+
+*tcl-8.4.2 (17 Apr 2003)
+
+ 17 Apr 2003; Stanislav Brabec <utx@gentoo.org> tcl-8.4.2.ebuild:
+ Updated to version 8.4.2 (bug #18483).
*tcl-8.3.4 (18 Dec 2002)
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.2 b/dev-lang/tcl/files/digest-tcl-8.4.2
new file mode 100644
index 000000000000..4cc729cd7d81
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.2
@@ -0,0 +1 @@
+MD5 4be55d8ebfcc9773407537445edd2ae1 tcl8.4.2-src.tar.gz 3330617
diff --git a/dev-lang/tcl/tcl-8.4.2.ebuild b/dev-lang/tcl/tcl-8.4.2.ebuild
new file mode 100644
index 000000000000..5c2c425810d3
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.2.ebuild,v 1.1 2003/04/17 17:22:45 utx Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}-src.tar.gz"
+
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+IUSE=""
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index ca5bd70d272d..c054d8cc153f 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.14 2003/04/04 21:33:45 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.15 2003/04/17 17:26:26 utx Exp $
+
+*tk-8.4.2 (17 Apr 2003)
+
+ 17 Apr 2003; Stanislav Brabec <utx@gentoo.org> tk-8.4.2.ebuild,
+ files/remove-control-v-8.4.diff:
+ Updated to version 8.4.2 (bug #18483) and updated Control-V remove patch.
*tk-8.3.4-r1 (28 Mar 2003)
diff --git a/dev-lang/tk/files/digest-tk-8.4.2 b/dev-lang/tk/files/digest-tk-8.4.2
new file mode 100644
index 000000000000..5d625fd27335
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.4.2
@@ -0,0 +1 @@
+MD5 04812fcdf6b50bfe89b7d44db3f33f19 tk8.4.2-src.tar.gz 3155987
diff --git a/dev-lang/tk/files/remove-control-v-8.4.diff b/dev-lang/tk/files/remove-control-v-8.4.diff
new file mode 100644
index 000000000000..6aa7e2f9f9ea
--- /dev/null
+++ b/dev-lang/tk/files/remove-control-v-8.4.diff
@@ -0,0 +1,17 @@
+--- library/text.tcl 2002-09-02 19:39:20.000000000 +0200
++++ library/text.tcl 2003-02-26 15:08:02.000000000 +0100
+@@ -347,14 +347,6 @@
+ catch { %W edit redo }
+ }
+
+-if {[string compare $tcl_platform(platform) "windows"]} {
+-bind Text <Control-v> {
+- if {!$tk_strictMotif} {
+- tk::TextScrollPages %W 1
+- }
+-}
+-}
+-
+ bind Text <Meta-b> {
+ if {!$tk_strictMotif} {
+ tk::TextSetCursor %W [tk::TextPrevPos %W insert tcl_startOfPreviousWord]
diff --git a/dev-lang/tk/tk-8.4.2.ebuild b/dev-lang/tk/tk-8.4.2.ebuild
new file mode 100644
index 000000000000..887f45fae297
--- /dev/null
+++ b/dev-lang/tk/tk-8.4.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.2.ebuild,v 1.1 2003/04/17 17:26:26 utx Exp $
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}-src.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+DESCRIPTION="Tk Widget Set"
+IUSE=""
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-apps/portage-2.0.47-r10
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/library
+ epatch ${FILESDIR}/remove-control-v-8.4.diff
+}
+
+# hyper-optimizations untested...
+#
+src_compile() {
+ cd ${S}/unix
+ econf \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/lib/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+}