summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-18 00:51:10 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-18 00:51:10 +0000
commit753c46ec1d73492a7a89f27f2982ac3248c5a4ac (patch)
treed94a1555c939237afdfee1f119ae848300f08c1e /dev-lang
parentfixed an oops (diff)
downloadhistorical-753c46ec1d73492a7a89f27f2982ac3248c5a4ac.tar.gz
historical-753c46ec1d73492a7a89f27f2982ac3248c5a4ac.tar.bz2
historical-753c46ec1d73492a7a89f27f2982ac3248c5a4ac.zip
version update
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog10
-rw-r--r--dev-lang/R/R-1.4.1-r1.ebuild7
-rw-r--r--dev-lang/R/R-1.4.1.ebuild6
-rw-r--r--dev-lang/R/R-1.5.1.ebuild93
-rw-r--r--dev-lang/R/files/R-1.5.1-tcltk.diff12
-rw-r--r--dev-lang/R/files/digest-R-1.5.11
6 files changed, 125 insertions, 4 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 1121b9b52067..a189155905c6 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-lang/R
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.2 2002/04/12 21:22:28 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.3 2002/07/18 00:51:10 george Exp $
+
+*R-1.5.1-ebuild (11 July 2002)
+
+ 11 July 2002; George Shapovalov <george@gentoo.org>
+ upped version
+ new version submitted by Tristan Henderson <T.Henderson@cs.ucl.ac.uk>
*R-1.4.1-r1 (11 Apr 2002)
11 Apr 2002; Spider <spider@gentoo.org>
diff --git a/dev-lang/R/R-1.4.1-r1.ebuild b/dev-lang/R/R-1.4.1-r1.ebuild
index 0c9596e192de..8f3364dc476f 100644
--- a/dev-lang/R/R-1.4.1-r1.ebuild
+++ b/dev-lang/R/R-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1-r1.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1-r1.ebuild,v 1.3 2002/07/18 00:51:10 george Exp $
S=${WORKDIR}/${P}
@@ -23,6 +23,11 @@ DEPEND="virtual/glibc
X? ( virtual/x11 )
tcltk? ( dev-lang/tk )
gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+
src_compile() {
diff --git a/dev-lang/R/R-1.4.1.ebuild b/dev-lang/R/R-1.4.1.ebuild
index 54fff1a8a7ab..1637f79cc470 100644
--- a/dev-lang/R/R-1.4.1.ebuild
+++ b/dev-lang/R/R-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1.ebuild,v 1.3 2002/07/18 00:51:10 george Exp $
S=${WORKDIR}/${P}
@@ -23,6 +23,10 @@ DEPEND="virtual/glibc
X? ( virtual/x11 )
tcltk? ( dev-lang/tk )
gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
src_compile() {
diff --git a/dev-lang/R/R-1.5.1.ebuild b/dev-lang/R/R-1.5.1.ebuild
new file mode 100644
index 000000000000..77fddd85949b
--- /dev/null
+++ b/dev-lang/R/R-1.5.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.5.1.ebuild,v 1.1 2002/07/18 00:51:10 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.2.1
+ atlas? ( dev-libs/atlas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86"
+
+
+src_unpack() {
+ unpack ${A}
+ patch -d ${S} -p1 < ${FILESDIR}/R-1.5.1-tcltk.diff
+}
+
+src_compile() {
+
+ local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
+
+ #Eventually, we will want to take into account that a user may have
+ #an alternate or additional blas libraries,
+ #i.e. USE variable blas and and virtual/blas
+ use atlas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/bin/R
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/R-1.5.1-tcltk.diff b/dev-lang/R/files/R-1.5.1-tcltk.diff
new file mode 100644
index 000000000000..ddb68897113e
--- /dev/null
+++ b/dev-lang/R/files/R-1.5.1-tcltk.diff
@@ -0,0 +1,12 @@
+diff -urN R-1.5.1.orig/src/library/tcltk/src/tcltk.c R-1.5.1/src/library/tcltk/src/tcltk.c
+--- R-1.5.1.orig/src/library/tcltk/src/tcltk.c Fri Jun 7 17:37:35 2002
++++ R-1.5.1/src/library/tcltk/src/tcltk.c Mon Jun 17 16:09:04 2002
+@@ -239,7 +239,7 @@
+
+ PROTECT(ans = allocVector(STRSXP, count));
+ for (i = 0 ; i < count ; i++)
+- SET_STRING_ELT(ans, i, mkChar(Tcl_GetString(elem[i])));
++ SET_STRING_ELT(ans, i, mkChar(Tcl_GetStringFromObj(elem[i], NULL)));
+ UNPROTECT(1);
+ return ans;
+ }
diff --git a/dev-lang/R/files/digest-R-1.5.1 b/dev-lang/R/files/digest-R-1.5.1
new file mode 100644
index 000000000000..dead2d895589
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.5.1
@@ -0,0 +1 @@
+MD5 5be01408b5354e35f4c02aa124c9ed77 R-1.5.1.tgz 5452320