summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-04 00:53:07 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-04 00:53:07 +0000
commit7494808b2206f79579c7c3eb6f18d88af54a38fd (patch)
tree53373ff7fd810f0e85bca8babc0759ef994c2943 /dev-lang
parentThe tilde may break portage 1.8.8, but the asterisks break portage (diff)
downloadhistorical-7494808b2206f79579c7c3eb6f18d88af54a38fd.tar.gz
historical-7494808b2206f79579c7c3eb6f18d88af54a38fd.tar.bz2
historical-7494808b2206f79579c7c3eb6f18d88af54a38fd.zip
Fixes #2075.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mmix/ChangeLog23
-rw-r--r--dev-lang/mmix/files/digest-mmix-200202161
-rw-r--r--dev-lang/mmix/mmix-20020216.ebuild23
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-lang/mmix/ChangeLog b/dev-lang/mmix/ChangeLog
new file mode 100644
index 000000000000..6fe18d2703a5
--- /dev/null
+++ b/dev-lang/mmix/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for dev-lang/mmix
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/ChangeLog,v 1.1 2002/05/04 00:53:07 karltk Exp $
+
+*mmix-20020216 (04 May 2002)
+
+ 04 May 2002; Karl Trygve Kalleberg <karltk@gentoo.org> mmix-20020216.ebuild files/digest-mmix-20020216 :
+
+ From Knuth's page:
+
+ MMIX is a machine that operates primarily on 64-bit words. It has 256
+ general-purpose 64-bit registers that each can hold either fixed-point or
+ floating-point numbers. Most instructions have the 4-byte form `OP X Y Z',
+ where each of OP, X, Y, and Z is a single 8-bit byte. For example, if OP is
+ the code for ADD the meaning is ``X=Y+Z''; i.e., ``Set register X to the
+ contents of register Y plus the contents of register Z.'' The 256 possible
+ OP codes fall into a dozen or so easily remembered categories.
+
+ The designers of important real-world processor chips (e.g., MIPS and
+ ALPHA) have helped me with the design of MMIX. So I'm excited about the
+ prospects.
+
+ Ebuild provided by Hanno Boeck <hanno@gmx.de>.
diff --git a/dev-lang/mmix/files/digest-mmix-20020216 b/dev-lang/mmix/files/digest-mmix-20020216
new file mode 100644
index 000000000000..587bebde4ea0
--- /dev/null
+++ b/dev-lang/mmix/files/digest-mmix-20020216
@@ -0,0 +1 @@
+MD5 5dc16c120808337c4810596d02ed42c2 mmix.tar.gz 304564
diff --git a/dev-lang/mmix/mmix-20020216.ebuild b/dev-lang/mmix/mmix-20020216.ebuild
new file mode 100644
index 000000000000..13260b9acbe3
--- /dev/null
+++ b/dev-lang/mmix/mmix-20020216.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Hanno Boeck <hanno@gmx.de>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20020216.ebuild,v 1.1 2002/05/04 00:53:07 karltk Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
+SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/mmix.tar.gz"
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
+
+DEPEND="virtual/glibc
+ >=dev-util/cweb-3.63"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ make basic CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin mmix mmixal
+ doman mmix.1
+ dodoc README
+}