summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-04-12 02:57:20 +0000
committerJon Portnoy <avenj@gentoo.org>2003-04-12 02:57:20 +0000
commit5a1385ca67d5e1ec531f1f1b6b9e7b205f368581 (patch)
treef8cedebd09c9325b84b58aa5da5d3ea4406d4ad8 /dev-lang
parentICC version bump (diff)
downloadhistorical-5a1385ca67d5e1ec531f1f1b6b9e7b205f368581.tar.gz
historical-5a1385ca67d5e1ec531f1f1b6b9e7b205f368581.tar.bz2
historical-5a1385ca67d5e1ec531f1f1b6b9e7b205f368581.zip
ICC version bump
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/icc/Manifest4
-rw-r--r--dev-lang/icc/files/7.1.006/05icc-ifc7
-rw-r--r--dev-lang/icc/files/7.1.006/icc7
-rw-r--r--dev-lang/icc/files/digest-icc-7.1.0061
-rw-r--r--dev-lang/icc/icc-7.1.006.ebuild105
5 files changed, 122 insertions, 2 deletions
diff --git a/dev-lang/icc/Manifest b/dev-lang/icc/Manifest
index bedd00c1d67a..c102984c2193 100644
--- a/dev-lang/icc/Manifest
+++ b/dev-lang/icc/Manifest
@@ -1,10 +1,10 @@
-MD5 802afedaca782eaeb567771818bd0e11 ChangeLog 2839
+MD5 6842c590688870a298d7edd610784876 ChangeLog 2956
MD5 64b209941c0edd85ed14c8b6bd2e918b icc-6.0-r1.ebuild 3147
MD5 6ecfd5d92d233621f56321b5a1d049d9 icc-6.0.ebuild 2948
MD5 d09b7e959ed5791b6f42586d6e1efc19 icc-7.0.065.ebuild 3189
MD5 105a26675e3ca104059666d65556e681 icc-7.0.065-r1.ebuild 3242
MD5 77ebd3c2043ecb0b9654d44bd29606d1 icc-7.0.065-r2.ebuild 3242
-MD5 4b072d064c22cbedb254cfeeb8ab6362 icc-7.1.006.ebuild 3145
+MD5 1b9b57df21651a423ddaaa05174c2647 icc-7.1.006.ebuild 3238
MD5 001566b9beb91011352b3d58a1f20390 files/digest-icc-7.1.006 65
MD5 16cb4482e4303fd7d5308782b494463d files/digest-icc-6.0 65
MD5 16cb4482e4303fd7d5308782b494463d files/digest-icc-6.0-r1 65
diff --git a/dev-lang/icc/files/7.1.006/05icc-ifc b/dev-lang/icc/files/7.1.006/05icc-ifc
new file mode 100644
index 000000000000..20c18a04bf99
--- /dev/null
+++ b/dev-lang/icc/files/7.1.006/05icc-ifc
@@ -0,0 +1,7 @@
+IA32ROOT=/opt/intel/compiler70/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+INTEL_LICENSE_FILE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler70/ia32/lib
+MANPATH=/opt/intel/compiler70/man
+PATH=/opt/intel/compiler70/ia32/bin
+ROOTPATH=/opt/intel/compiler70/ia32/bin
diff --git a/dev-lang/icc/files/7.1.006/icc b/dev-lang/icc/files/7.1.006/icc
new file mode 100644
index 000000000000..6d53c6dc0c69
--- /dev/null
+++ b/dev-lang/icc/files/7.1.006/icc
@@ -0,0 +1,7 @@
+#!/bin/sh
+export INTEL_LICENSE_FILE="/opt/intel/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler70/ia32/lib"
+
+ICCARGS=`echo $* | sed -e s:pentium2:pentiumii:g | sed -e s:pentium3:pentiumiii:g`
+
+/opt/intel/compiler70/ia32/bin/iccbin $ICCARGS
diff --git a/dev-lang/icc/files/digest-icc-7.1.006 b/dev-lang/icc/files/digest-icc-7.1.006
new file mode 100644
index 000000000000..a847873aabce
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-7.1.006
@@ -0,0 +1 @@
+MD5 58551f24cbb28339157760c29465e507 l_cc_p_7.1.006.tar 63406080
diff --git a/dev-lang/icc/icc-7.1.006.ebuild b/dev-lang/icc/icc-7.1.006.ebuild
new file mode 100644
index 000000000000..3eee97f3e92f
--- /dev/null
+++ b/dev-lang/icc/icc-7.1.006.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.006.ebuild,v 1.1 2003/04/12 02:57:06 avenj Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel C++ Compiler - Intel's Pentium optimized compiler for Linux"
+
+SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_p_7.1.006.tar"
+SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_p_7.1.006.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+LICENSE="icc-7.0"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.5
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4"
+
+SLOT="7"
+KEYWORDS="-* x86"
+IUSE=""
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler*/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ for SUPPORTFILE in ${SD}/compiler*/docs/*support
+ do
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+ done
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ # icc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+ # fix the issue with the primary icc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ doexe ${FILESDIR}/${PVR}/icc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+
+ ewarn
+ ewarn "Packages compiled with versions of icc older than 7.0 will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ ewarn "BEFORE COMPILING IMPORTANT APPLICATIONS THAT YOUR"
+ ewarn "SYSTEM DEPENDS ON, READ THE WARNING ABOVE."
+ ewarn "THIS COULD RENDER YOUR SYSTEM UNUSABLE."
+ ewarn "THIS IS A PROBLEM WITH INTEL'S SOFTWARE, _NOT_"
+ ewarn "WITH GENTOO."
+
+ ewarn "If 'icc' breaks, use 'iccbin' instead and report a bug."
+ ewarn "Please use 'source /etc/profile' prior to merging any icc-enabled"
+ ewarn "ebuilds."
+}