summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-15 13:27:24 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-15 13:27:24 +0000
commit0e3bead8d417f4459e682e42b83280d271be19c5 (patch)
treefe7d12f861cea4a99b4c7b863d754e93a3f23a45 /dev-lang
parentadding new digest for ccc (diff)
downloadhistorical-0e3bead8d417f4459e682e42b83280d271be19c5.tar.gz
historical-0e3bead8d417f4459e682e42b83280d271be19c5.tar.bz2
historical-0e3bead8d417f4459e682e42b83280d271be19c5.zip
patch for errno #17744
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pm3/ChangeLog7
-rw-r--r--dev-lang/pm3/files/1.1.15-errno.patch245
-rw-r--r--dev-lang/pm3/files/digest-pm3-1.1.15-r13
-rw-r--r--dev-lang/pm3/pm3-1.1.15-r1.ebuild48
4 files changed, 302 insertions, 1 deletions
diff --git a/dev-lang/pm3/ChangeLog b/dev-lang/pm3/ChangeLog
index 7637fe38b05b..0cbc089011d7 100644
--- a/dev-lang/pm3/ChangeLog
+++ b/dev-lang/pm3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/pm3
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pm3/ChangeLog,v 1.3 2003/02/12 05:57:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pm3/ChangeLog,v 1.4 2003/04/15 13:27:24 vapier Exp $
+
+*pm3-1.1.15-r1 (15 Apr 2003)
+
+ 15 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch for errno issue (#16267) to fix #17744.
*pm3-1.1.15 (16 Dec 2002)
diff --git a/dev-lang/pm3/files/1.1.15-errno.patch b/dev-lang/pm3/files/1.1.15-errno.patch
new file mode 100644
index 000000000000..25c101d7d28e
--- /dev/null
+++ b/dev-lang/pm3/files/1.1.15-errno.patch
@@ -0,0 +1,245 @@
+--- graphics/displayps/dps/src/ccDisplayPS.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ graphics/displayps/dps/src/ccDisplayPS.c 2003-04-15 08:40:49.000000000 -0400
+@@ -19,8 +19,6 @@
+ #include "dpsfriends.h"
+ #include "wraps.h"
+
+-extern int errno;
+-
+ #define FullWidth 1024 /* Congruent to definition in DPS.i3 */
+ #define FullHeight 1024 /* Congruent to definition in DPS.i3 */
+
+--- language/modula3/m3compiler/m3cc/gcc/c-lex.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/c-lex.c 2003-04-15 08:40:57.000000000 -0400
+@@ -40,9 +40,6 @@
+ #include <locale.h>
+ #endif
+
+-#ifndef errno
+-extern int errno;
+-#endif
+
+ /* The elements of `ridpointers' are identifier nodes
+ for the reserved type names and storage classes.
+--- language/modula3/m3compiler/m3cc/gcc/c-parse.in.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/c-parse.in 2003-04-15 08:41:03.000000000 -0400
+@@ -89,10 +89,6 @@
+ char *language_string = "GNU C";
+ end ifc
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ void yyerror ();
+
+ /* Like YYERROR but do call yyerror. */
+--- language/modula3/m3compiler/m3cc/gcc/cccp.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/cccp.c 2003-04-15 08:41:19.000000000 -0400
+@@ -365,9 +365,6 @@
+ HOST_WIDE_INT parse_escape PROTO((char **, HOST_WIDE_INT));
+ HOST_WIDE_INT parse_c_expression PROTO((char *));
+
+-#ifndef errno
+-extern int errno;
+-#endif
+
+ /* Name under which this program was invoked. */
+
+--- language/modula3/m3compiler/m3cc/gcc/collect2.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/collect2.c 2003-04-15 08:41:24.000000000 -0400
+@@ -42,10 +42,6 @@
+ #include "obstack.h"
+ #include "gansidecl.h"
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ #ifndef HAVE_STRERROR
+ #if defined(bsd4_4)
+ extern const char *const sys_errlist[];
+--- language/modula3/m3compiler/m3cc/gcc/cpplib.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/cpplib.c 2003-04-15 08:45:20.000000000 -0400
+@@ -7437,9 +7437,6 @@
+
+ /* This defines "errno" properly for VMS, and gives us EACCES. */
+ #include <errno.h>
+-#ifndef errno
+-extern int errno;
+-#endif
+
+ #ifndef VMS
+ #ifndef HAVE_STRERROR
+--- language/modula3/m3compiler/m3cc/gcc/dbxout.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/dbxout.c 2003-04-15 08:41:46.000000000 -0400
+@@ -81,10 +81,6 @@
+ #include "defaults.h"
+ #include "output.h" /* ASM_OUTPUT_SOURCE_LINE may refer to sdb functions. */
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ #ifdef XCOFF_DEBUGGING_INFO
+ #include "xcoffout.h"
+ #endif
+--- language/modula3/m3compiler/m3cc/gcc/fix-header.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/fix-header.c 2003-04-15 08:42:20.000000000 -0400
+@@ -802,7 +802,7 @@
+ {
+ case errno_h:
+ if (!seen_errno)
+- fprintf (outf, "extern int errno;\n");
++ fprintf (outf, "#include <errno.h>\n");
+ break;
+ case stdlib_h:
+ if (!seen_EXIT_FAILURE)
+--- language/modula3/m3compiler/m3cc/gcc/gcc.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/gcc.c 2003-04-15 08:42:26.000000000 -0400
+@@ -143,10 +143,6 @@
+
+ extern char *choose_temp_base PROTO((void));
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ #ifndef HAVE_STRERROR
+ extern int sys_nerr;
+ #if defined(bsd4_4)
+--- language/modula3/m3compiler/m3cc/gcc/getpwd.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/getpwd.c 2003-04-15 08:42:31.000000000 -0400
+@@ -6,10 +6,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ /* Virtually every UN*X system now in common use (except for pre-4.3-tahoe
+ BSD systems) now provides getcwd as called for by POSIX. Allow for
+ the few exceptions to the general rule here. */
+--- language/modula3/m3compiler/m3cc/gcc/m3.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/m3.c 2003-04-15 08:42:36.000000000 -0400
+@@ -65,10 +65,6 @@
+ #define LONG_DOUBLE_TYPE_SIZE 64
+ #endif
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ /* #define NEST_NESTED 1 */
+ /* comment out NEST_NESTED if the front-end delivers nested procedure
+ bodies where they appear in the source */
+--- language/modula3/m3compiler/m3cc/gcc/mips-tfile.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/mips-tfile.c 2003-04-15 08:42:40.000000000 -0400
+@@ -744,10 +744,6 @@
+ #include <unistd.h>
+ #endif
+
+-#ifndef errno
+-extern int errno; /* MIPS errno.h doesn't declare this */
+-#endif
+-
+ #ifndef MALLOC_CHECK
+ #ifdef __SABER__
+ #define MALLOC_CHECK
+--- language/modula3/m3compiler/m3cc/gcc/protoize.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/protoize.c 2003-04-15 08:42:45.000000000 -0400
+@@ -83,10 +83,6 @@
+ #include "getopt.h"
+ #undef getopt
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ #ifndef HAVE_STRERROR
+ extern int sys_nerr;
+ #if defined(bsd4_4)
+--- language/modula3/m3compiler/m3cc/gcc/real.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/real.c 2003-04-15 08:42:49.000000000 -0400
+@@ -25,10 +25,6 @@
+ #include "config.h"
+ #include "tree.h"
+
+-#ifndef errno
+-extern int errno;
+-#endif
+-
+ /* To enable support of XFmode extended real floating point, define
+ LONG_DOUBLE_TYPE_SIZE 96 in the tm.h file (m68k.h or i386.h).
+
+--- language/modula3/m3compiler/m3cc/gcc/config/convex/fixinc.convex.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/config/convex/fixinc.convex 2003-04-15 08:45:00.000000000 -0400
+@@ -17,6 +17,7 @@
+
+ #include_next <limits.h>
+
++#include <errno.h>
+ /* Minimum and maximum values a `char' can hold. */
+ #ifdef __CHAR_UNSIGNED__
+ #undef CHAR_MIN
+@@ -263,7 +264,6 @@
+
+ static __inline__ double __inline_ldexp (double x, int n)
+ {
+- extern int errno;
+ union { double d; long long ll; unsigned sexp : 12; } u;
+ if ((u.d = x) != 0)
+ {
+@@ -288,7 +288,6 @@
+
+ static __inline__ float __inline_ldexpf (float x, int n)
+ {
+- extern int errno;
+ union { float f; int i; unsigned sexp : 9; } u;
+ if ((u.f = x) != 0)
+ {
+--- language/modula3/m3compiler/m3cc/gcc/config/pa/xm-pa.h.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/config/pa/xm-pa.h 2003-04-15 08:43:36.000000000 -0400
+@@ -19,7 +19,7 @@
+ the Free Software Foundation, 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA. */
+
+-extern int errno;
++#include <errno.h>
+
+ /* #defines that need visibility everywhere. */
+ #define FALSE 0
+--- language/modula3/m3compiler/m3cc/gcc/config/pa/xm-papro.h.orig 2003-04-15 08:40:37.000000000 -0400
++++ language/modula3/m3compiler/m3cc/gcc/config/pa/xm-papro.h 2003-04-15 08:43:43.000000000 -0400
+@@ -19,7 +19,7 @@
+ the Free Software Foundation, 59 Temple Place - Suite 330,
+ Boston, MA 02111-1307, USA. */
+
+-extern int errno;
++#include <errno.h>
+
+ /* #defines that need visibility everywhere. */
+ #define FALSE 0
+--- network/mail/llscan/src/err.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ network/mail/llscan/src/err.c 2003-04-15 08:43:50.000000000 -0400
+@@ -26,7 +26,7 @@
+ static char errfmt[MAXERRMSG];
+ static char errbuf[MAXERRMSG];
+
+-extern int sys_nerr, errno;
++extern int sys_nerr;
+
+ /***************************************************************/
+ /* Local function declarations */
+--- network/mail/llscan/src/llscan.c.orig 2003-04-15 08:40:37.000000000 -0400
++++ network/mail/llscan/src/llscan.c 2003-04-15 08:43:55.000000000 -0400
+@@ -39,8 +39,6 @@
+ #include <varrayptr.h>
+ #include <inttable.h>
+
+-extern int errno;
+-
+ extern int sys_nerr;
+
+ /***************************************************************/
diff --git a/dev-lang/pm3/files/digest-pm3-1.1.15-r1 b/dev-lang/pm3/files/digest-pm3-1.1.15-r1
new file mode 100644
index 000000000000..9ff413bcbefd
--- /dev/null
+++ b/dev-lang/pm3/files/digest-pm3-1.1.15-r1
@@ -0,0 +1,3 @@
+MD5 f574c1a3b6966e250adfbcc4ae692ffb pm3-1.1.15-LINUXLIBC6-boot.tgz 1926070
+MD5 4d683e6156c24777cd571bd3e037c922 pm3-src-1.1.15.tar.bz2 18684711
+MD5 78ae95be0cf2893863f90677721a1376 pm3_1.1.15-1.diff.gz 10959
diff --git a/dev-lang/pm3/pm3-1.1.15-r1.ebuild b/dev-lang/pm3/pm3-1.1.15-r1.ebuild
new file mode 100644
index 000000000000..58c128d245ed
--- /dev/null
+++ b/dev-lang/pm3/pm3-1.1.15-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pm3/pm3-1.1.15-r1.ebuild,v 1.1 2003/04/15 13:27:24 vapier Exp $
+
+inherit gcc eutils flag-o-matic
+
+M3_TARGET="LINUXLIBC6"
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Modula-3 compiler"
+HOMEPAGE="http://www.elegosoft.com/pm3/"
+SRC_URI="ftp://www.elegosoft.com/pub/pm3/${P}-${M3_TARGET}-boot.tgz
+ ftp://www.elegosoft.com/pub/pm3/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-util/byacc"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd ${S}
+ unpack ${P}-${M3_TARGET}-boot.tgz
+ epatch ${FILESDIR}/${P}.patch
+ epatch ${FILESDIR}/${PV}-errno.patch
+ cp ${FILESDIR}/PACKAGES ${S}/src/
+
+ echo 'RANLIB = ["ranlib"]' >> m3config/src/${M3_TARGET}
+ export LD_LIBRARY_PATH="${S}/EXPORTS/usr/lib/m3/${M3_TARGET}/:${LD_LIBRARY_PATH}"
+
+ mv ${PN}-${M3_TARGET}/* ${S}/
+}
+
+src_compile() {
+ [ `gcc-major-version` == 3 ] && replace-flags -O? -O1
+ make || die
+}
+
+src_install() {
+ mv EXPORTS/* ${D}/ || die
+ prepall
+
+ dodir /etc/env.d
+ echo "LDPATH=/usr/lib/m3/${M3_TARGET}" >> ${D}/etc/env.d/05pm3
+}