summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-10-11 09:33:10 +0000
committerMichael Imhof <tantive@gentoo.org>2003-10-11 09:33:10 +0000
commit4512bde1427435d6b2d70debffe146192b8cf780 (patch)
tree7075ee568984e393f9a7262a0ab21f49e69fe27a /dev-lang/squeak
parentCloses #27408 (diff)
downloadhistorical-4512bde1427435d6b2d70debffe146192b8cf780.tar.gz
historical-4512bde1427435d6b2d70debffe146192b8cf780.tar.bz2
historical-4512bde1427435d6b2d70debffe146192b8cf780.zip
Closes #27408
Diffstat (limited to 'dev-lang/squeak')
-rw-r--r--dev-lang/squeak/Manifest4
-rw-r--r--dev-lang/squeak/files/digest-squeak-3.4.1-r11
-rw-r--r--dev-lang/squeak/squeak-3.4.1-r1.ebuild117
3 files changed, 120 insertions, 2 deletions
diff --git a/dev-lang/squeak/Manifest b/dev-lang/squeak/Manifest
index 30fa57b12a84..2be04087d116 100644
--- a/dev-lang/squeak/Manifest
+++ b/dev-lang/squeak/Manifest
@@ -1,7 +1,7 @@
-MD5 dcfef86caae3c463919c944d16e6ef35 ChangeLog 699
+MD5 90bc08c762f9a80ab33c044ee19ef5ea ChangeLog 699
MD5 479f2d1c5b28ac403ce1e966caded2be squeak-3.2.5.ebuild 2903
MD5 c5ee64830a6abb8992d522b313a0ab02 squeak-3.4.1.ebuild 2988
-MD5 22bd60b0389a9942baa072a4ce5a5fd7 squeak-3.4.1-r1.ebuild 3236
+MD5 201dd19399828b80e07b70bb22d2918d squeak-3.4.1-r1.ebuild 3238
MD5 95975b038cad92087afe83055e6b2137 files/digest-squeak-3.2.5 69
MD5 e15651f69bf3b5c02f40bcffceefb53c files/digest-squeak-3.4.1 69
MD5 e15651f69bf3b5c02f40bcffceefb53c files/digest-squeak-3.4.1-r1 69
diff --git a/dev-lang/squeak/files/digest-squeak-3.4.1-r1 b/dev-lang/squeak/files/digest-squeak-3.4.1-r1
new file mode 100644
index 000000000000..bfbee3e7c2ec
--- /dev/null
+++ b/dev-lang/squeak/files/digest-squeak-3.4.1-r1
@@ -0,0 +1 @@
+MD5 780af1cf1cdc8d44c1ce30a527bdd508 Squeak-3.4-1.src.tar.gz 1890889
diff --git a/dev-lang/squeak/squeak-3.4.1-r1.ebuild b/dev-lang/squeak/squeak-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..9ed818248ae1
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.4.1-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1-r1.ebuild,v 1.1 2003/10/11 09:32:56 tantive Exp $
+
+inherit libtool flag-o-matic eutils
+strip-flags
+filter-mfpmath sse
+filter-flags "-fPIC" "-maltivec" "-mabi=altivec" "-fstack-protector" "-pipe" "-g" "-mtune" "-march" "-mcpu" "-O" "-O1" "-O2" "-Os" "-O3" "-freorder-blocks" "-fprefetch-loop-array"
+
+#Simply change these numbers for different versions
+MV=3.4
+NV=${MV}-1
+FV=${MV}.1
+
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="ftp://st.cs.uiuc.edu/Smalltalk/Squeak/${MV}/unix-linux/Squeak-${NV}.src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X oss mmx mozilla"
+# a ffi flag would be nice
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )"
+RDEPEND="dev-lang/squeak-vm
+ virtual/glibc
+ X? ( x11-base/xfree )"
+
+S="${WORKDIR}/Squeak-${NV}"
+
+src_compile() {
+ local myconf=""
+
+ use X || myconf="--without-x"
+ use oss && myconf="${myconf} --with-audio=oss"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+
+ cd ${S}
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "configure failed"
+ mv Makefile Makefile.tmp.$$
+ cat Makefile.tmp.$$|sed \
+ 's/$(prefix)\/doc\/squeak/$(prefix)\/share\/doc\/squeak-${FV}/g'\
+ > Makefile
+ rm -f Makefile.tmp.$$
+ emake || die
+ make npsqueak
+ # this is a bit paranoid, but we want to be sure it gets compiled now
+ cd nps
+ emake || die
+}
+
+src_install() {
+ cd ${S}/build
+
+ make DESTDIR=${D} ROOT=${D} install || die
+
+ exeinto /usr/bin
+ doexe inisqueak
+
+ ### the rest is all for the plugin
+
+ cd nps
+
+ # plugin sample, must be served to work, file:// doesnt work.
+
+ insinto /usr/share/doc/squeak-${FV}
+ doins test/plugintest.html
+ doins test/plugintest.sts
+
+ # fix the paths
+
+ SQ_DIR=/usr/lib/squeak
+ VM_VERSION=${NV}
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakrun.in > npsqueakrun.in.2
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakregister.in > npsqueakregister
+ sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
+
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
+ exeinto /usr/lib/squeak/${NV}
+ doexe npsqueakrun
+
+
+ # install in browsers (no opera use flags?)
+
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/${NV}/npsqueak.so /opt/netscape/plugins
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npsqueak.so \
+ /usr/lib/mozilla/plugins/npsqueak.so
+ fi
+
+ # maybe we should install the image here..
+
+ # dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/${NV}/SqueakV3.sources
+ # doins npsqueak.image
+ # doins npsqueak.changes
+}
+
+pkg_postinst() {
+ einfo 'Run "inisqueak" to get a private copy of the VM image.'
+ einfo ''
+ einfo 'To setup the browser plugin, create a working set named npsqueak.* in /usr/lib/squeak/<version>/'
+}