summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-03-19 14:48:58 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-03-19 14:48:58 +0000
commit72f0bc6bd72fd0af750e3483c0912ca54dc662e2 (patch)
tree972f403775e86fcd2099763280c18c6b70ae3c32 /dev-lang/sather/sather-1.3.ebuild
parentAdded net-mail/dot-forward to RDEPEND (diff)
downloadhistorical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.tar.gz
historical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.tar.bz2
historical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.zip
Initial releases of these packages.
Diffstat (limited to 'dev-lang/sather/sather-1.3.ebuild')
-rw-r--r--dev-lang/sather/sather-1.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-lang/sather/sather-1.3.ebuild b/dev-lang/sather/sather-1.3.ebuild
new file mode 100644
index 000000000000..57f6d92cb504
--- /dev/null
+++ b/dev-lang/sather/sather-1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@uwyn.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sather/sather-1.3.ebuild,v 1.1 2002/03/19 14:48:58 gbevin Exp $
+
+S="${WORKDIR}/Sather-1.3"
+DESCRIPTION="Sather is an object oriented language designed to be simple, efficient, safe, flexible and non-proprietary."
+SRC_URI="http://www.cs.waikato.ac.nz/sather/release/downloads/Sather-1.3.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-tutorial-000328.ps.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-tutorial-000328.html.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-specification-000328.html.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-specification-000328.ps.gz
+ http://www.icsi.berkeley.edu/~sather/Publications/satish-thatte.ps.gz
+ http://www.icsi.berkeley.edu/~sather/Documentation/LanguageDescription/Descript.ps.gz"
+HOMEPAGE="http://www.cs.waikato.ac.nz/sather/ http://www.icsi.berkeley.edu/~sather/"
+
+DEPEND=">=sys-devel/gcc-2.95.3-r5
+ >=dev-libs/boehm-gc-6.0"
+RDEPEND=">=sys-devel/gcc-2.95.3-r5"
+
+src_unpack() {
+ unpack Sather-1.3.tar.gz
+
+ mkdir doc
+ cd doc
+ unpack sather-tutorial-000328.html.tar.gz
+ unpack sather-specification-000328.html.tar.gz
+ cp ${DISTDIR}/sather-tutorial-000328.ps.gz .
+ cp ${DISTDIR}/sather-specification-000328.ps.gz .
+ cp ${DISTDIR}/satish-thatte.ps.gz .
+ cp ${DISTDIR}/Descript.ps.gz .
+}
+
+src_compile() {
+
+ export SATHER_HOME="$S"
+ export LOCALE="en_NZ"
+ export SATHER_ENV="$SATHER_HOME/resources/$LOCALE/bin/LIBCHARS-posix"
+ export SATHER_RESOURCES="$SATHER_HOME/resources/$LOCALE"
+ export PATH="$PATH:$SATHER_HOME/bin"
+
+ ./configure linux || die
+ make || die
+
+}
+
+src_install () {
+
+ dodir /usr
+ cp -a ${WORKDIR}/Sather-1.3 ${D}/usr/sather
+ rm -rf ${D}/usr/sather/bin/sacomp.code
+ rm -rf ${D}/usr/sather/bin/sacomp-boot.code
+ rm -rf ${D}/usr/sather/system
+
+ cd ${WORKDIR}
+ dodoc doc/sather-specification-000328.ps.gz doc/sather-tutorial-000328.ps.gz doc/satish-thatte.ps.gz doc/Descript.ps.gz
+ cp -a doc/specification.html ${D}/usr/share/doc/${P}
+ cp -a doc/tutorial.html ${D}/usr/share/doc/${P}
+
+ dodir /etc/env.d
+cat >> ${D}/etc/env.d/05sather <<EOF
+ export SATHER_HOME="/usr/sather"
+ export LOCALE="en_NZ"
+ export SATHER_ENV="/usr/sather/resources/en_NZ/bin/LIBCHARS-posix"
+ export SATHER_RESOURCES="/usr/sather/resources/en_NZ"
+ export PATH="/usr/sather/bin"
+EOF
+
+}