summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 12:02:54 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 12:02:54 +0000
commitec648934c697e04741bc14202d5c5e30aaca4e3d (patch)
tree59667f0cf492f747c1b63b492dbab228f91937c9 /dev-lang/nasm
parentNo more gzipped HTML documentation (diff)
downloadhistorical-ec648934c697e04741bc14202d5c5e30aaca4e3d.tar.gz
historical-ec648934c697e04741bc14202d5c5e30aaca4e3d.tar.bz2
historical-ec648934c697e04741bc14202d5c5e30aaca4e3d.zip
No more gzipped HTML documentation.
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/ChangeLog10
-rw-r--r--dev-lang/nasm/files/digest-nasm-0.98-r41
-rw-r--r--dev-lang/nasm/nasm-0.98-r4.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 318c01413974..34c0bfaceed9 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/nasm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.2 2002/03/21 12:02:54 seemant Exp $
+
+*nasm-0.98-r4 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> nasm-0.98-r4.ebuild :
+
+ HTML documentation will no longer be gzipped because it is being handled by
+ dohtml instead of dodoc. Thanks to stefan@mdy.univie.ac.at for pointing it
+ out.
*nasm-0.98-r3 (1 Feb 2002)
diff --git a/dev-lang/nasm/files/digest-nasm-0.98-r4 b/dev-lang/nasm/files/digest-nasm-0.98-r4
new file mode 100644
index 000000000000..7f0209b2226b
--- /dev/null
+++ b/dev-lang/nasm/files/digest-nasm-0.98-r4
@@ -0,0 +1 @@
+MD5 9b7b0cb51d6b777edcbed7e0447a5f4e nasm-0.98.tar.bz2 386071
diff --git a/dev-lang/nasm/nasm-0.98-r4.ebuild b/dev-lang/nasm/nasm-0.98-r4.ebuild
new file mode 100644
index 000000000000..1099b176ca8e
--- /dev/null
+++ b/dev-lang/nasm/nasm-0.98-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r4.ebuild,v 1.1 2002/03/21 12:02:54 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="groovy little assembler"
+SRC_URI="ftp://ftp.kernel.org/pub/software/devel/nasm/source/${P}.tar.bz2
+ ftp://ftp.de.kernel.org/pub/software/devel/nasm/source/${P}.tar.bz2
+ ftp://ftp.uk.kernel.org/pub/software/devel/nasm/source/${P}.tar.bz2"
+HOMEPAGE="http://nasm.sourceforge.net/"
+
+DEPEND="virtual/glibc sys-apps/texinfo"
+RDEPEND="virtual/glibc"
+
+if [ -z "`use build`" ]; then
+ DEPEND="${DEPEND} sys-devel/perl"
+fi
+
+src_compile() {
+ ./configure --prefix=/usr || die
+
+ if [ "`use build`" ]; then
+ make nasm
+ else
+ make || die
+ cd doc
+ make || die
+ fi
+}
+
+src_install() {
+ if [ "`use build`" ]; then
+ dobin nasm
+ else
+ dobin nasm ndisasm
+ dobin rdoff/ldrdf rdoff/rdf2bin rdoff/rdfdump rdoff/rdflib rdoff/rdx
+ doman nasm.1 ndisasm.1
+ dodoc COPYING Changes Licence MODIFIED Readme Wishlist
+ docinto txt
+ cd doc
+ dodoc nasmdoc.txt
+ dohtml html/*.html
+ docinto ps
+ dodoc nasmdoc.ps
+ docinto rtf
+ dodoc nasmdoc.rtf
+
+ doinfo info/*.info*
+ fi
+}