summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-11 23:24:16 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-11 23:24:16 +0000
commit8173a07fcc038fd00dd980d9fc575aeb2207e21f (patch)
treee4700bb4ed157ef066e234548833f929a557fbf1 /dev-lang/icc
parentnew version. x86 masked (diff)
downloadhistorical-8173a07fcc038fd00dd980d9fc575aeb2207e21f.tar.gz
historical-8173a07fcc038fd00dd980d9fc575aeb2207e21f.tar.bz2
historical-8173a07fcc038fd00dd980d9fc575aeb2207e21f.zip
Enhanced wrapper script.
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog11
-rw-r--r--dev-lang/icc/files/7.0.065-r1/05icc-ifc6
-rw-r--r--dev-lang/icc/files/7.0.065-r1/icc7
-rw-r--r--dev-lang/icc/files/digest-icc-7.0.065-r11
-rw-r--r--dev-lang/icc/icc-7.0.065-r1.ebuild103
-rw-r--r--dev-lang/icc/icc-7.0.065.ebuild2
6 files changed, 127 insertions, 3 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index a792d27c79c2..ee93cdb4fc1e 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for dev-lang/icc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.7 2002/12/10 20:08:16 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.8 2002/12/11 23:24:16 avenj Exp $
+
+*icc-7.0.065-r1 (11 Dec 2002)
+
+ 11 Dec 2002; Jon Portnoy <avenj@gentoo.org> icc-7.0.065-r1.ebuild
+
+ Changed the "icc" wrapper script to properly translate gcc CFLAGS into
+ icc CFLAGS.
*icc-7.0.065 (10 Dec 2002)
- 10 Dec 2002; Jon Portnoy <avenj@gentoo.org> icc-7.0.065-r1.ebuild:
+ 10 Dec 2002; Jon Portnoy <avenj@gentoo.org> icc-7.0.065.ebuild:
Changed the naming to more accurately reflect the current ICC
version number. Also fixed the primary executable and added a warning
diff --git a/dev-lang/icc/files/7.0.065-r1/05icc-ifc b/dev-lang/icc/files/7.0.065-r1/05icc-ifc
new file mode 100644
index 000000000000..7134ac814afd
--- /dev/null
+++ b/dev-lang/icc/files/7.0.065-r1/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler70/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler70/ia32/lib
+MANPATH=/opt/intel/compiler70/man
+PATH=/opt/intel/compiler70/ia32/bin
+ROOTPATH=/opt/intel/compiler70/ia32/bin
diff --git a/dev-lang/icc/files/7.0.065-r1/icc b/dev-lang/icc/files/7.0.065-r1/icc
new file mode 100644
index 000000000000..6d53c6dc0c69
--- /dev/null
+++ b/dev-lang/icc/files/7.0.065-r1/icc
@@ -0,0 +1,7 @@
+#!/bin/sh
+export INTEL_LICENSE_FILE="/opt/intel/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler70/ia32/lib"
+
+ICCARGS=`echo $* | sed -e s:pentium2:pentiumii:g | sed -e s:pentium3:pentiumiii:g`
+
+/opt/intel/compiler70/ia32/bin/iccbin $ICCARGS
diff --git a/dev-lang/icc/files/digest-icc-7.0.065-r1 b/dev-lang/icc/files/digest-icc-7.0.065-r1
new file mode 100644
index 000000000000..26c60237a081
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-7.0.065-r1
@@ -0,0 +1 @@
+MD5 e16414a571ac8cc9b69fad3a886049f1 l_cc_p_7.0.065.tar 64921600
diff --git a/dev-lang/icc/icc-7.0.065-r1.ebuild b/dev-lang/icc/icc-7.0.065-r1.ebuild
new file mode 100644
index 000000000000..8ec5f1de2288
--- /dev/null
+++ b/dev-lang/icc/icc-7.0.065-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.0.065-r1.ebuild,v 1.1 2002/12/11 23:24:16 avenj Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel C++ Compiler - The Pentium optimized compiler for Linux"
+
+SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_p_7.0.065.tar"
+SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_p_7.0.065.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+LICENSE="icc-7.0"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4"
+
+SLOT="7"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+IUSE=""
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler*/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ for SUPPORTFILE in ${SD}/compiler*/docs/*support
+ do
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+ done
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ # icc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+ # fix the issue with the primary icc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ doexe ${FILESDIR}/${PVR}/icc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+ if [ -d /opt/intel/compiler?0 ]
+ then
+ ewarn
+ ewarn "Packages compiled with older versions of icc will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ fi
+ ewarn "If 'icc' breaks, use 'iccbin' instead and report a bug."
+ ewarn "NOTE: Before compiling important applications that your system"
+ ewarn "depends on, read the warning above. This could potentially"
+ ewarn "render your system unusable. This is a problem with Intel's"
+ ewarn "software, _not_ with Gentoo."
+}
diff --git a/dev-lang/icc/icc-7.0.065.ebuild b/dev-lang/icc/icc-7.0.065.ebuild
index 1c7d1de07d16..b28e2fccffc2 100644
--- a/dev-lang/icc/icc-7.0.065.ebuild
+++ b/dev-lang/icc/icc-7.0.065.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.0.065.ebuild,v 1.1 2002/12/10 19:52:58 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.0.065.ebuild,v 1.2 2002/12/11 23:24:16 avenj Exp $
S=${WORKDIR}