summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:43:15 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:43:15 +0000
commit6d853b177845ade2e1bf0255ce6f82f65c16a71c (patch)
tree75b8dbc4b7a6720025820fdacc402bee523cb287 /dev-lang/hugs98
parentadding par to portage (diff)
downloadhistorical-6d853b177845ade2e1bf0255ce6f82f65c16a71c.tar.gz
historical-6d853b177845ade2e1bf0255ce6f82f65c16a71c.tar.bz2
historical-6d853b177845ade2e1bf0255ce6f82f65c16a71c.zip
Fixes #1926
Diffstat (limited to 'dev-lang/hugs98')
-rw-r--r--dev-lang/hugs98/ChangeLog29
-rw-r--r--dev-lang/hugs98/files/digest-hugs98-12.20001
-rw-r--r--dev-lang/hugs98/hugs98-12.2000.ebuild35
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-lang/hugs98/ChangeLog b/dev-lang/hugs98/ChangeLog
new file mode 100644
index 000000000000..3ff183b7f4ea
--- /dev/null
+++ b/dev-lang/hugs98/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for dev-lang/hugs98
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/ChangeLog,v 1.1 2002/04/24 19:43:15 karltk Exp $
+
+*hugs98-12.2000 (24 Apr 2002)
+
+ 24 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> hugs98-12.2000.ebuild files/digest-hugs98-12.2002 :
+
+ Hugs 98 is a functional programming system based on Haskell 98, the de facto
+ standard for non-strict functional programming languages. Hugs 98 provides
+ an almost complete implementation of Haskell 98, including:
+
+ * Lazy evaluation, higher order functions, and pattern matching.
+ * A wide range of built-in types, from characters to bignums, and lists to
+ functions, with comprehensive facilities for defining new datatypes and
+ type synonyms.
+ * An advanced polymorphic type system with type and constructor class
+ overloading.
+ * All of the features of the Haskell 98 expression and pattern syntax
+ including lambda, case, conditional and let expressions, list
+ comprehensions, do-notation, operator sections, and wildcard,
+ irrefutable and `as' patterns.
+ * An implementation of the main Haskell 98 primitives for monadic I/O,
+ with support for simple interactive programs, access to text files,
+ handle-based I/O, and exception handling.
+ * An almost complete implementation of the Haskell module system. Hugs 98
+ also supports a number of advanced and experimental extensions including
+ multi-parameter classes, extensible records, rank-2 polymorphism,
+ existentials, scoped type variables, and restricted type synonyms.
diff --git a/dev-lang/hugs98/files/digest-hugs98-12.2000 b/dev-lang/hugs98/files/digest-hugs98-12.2000
new file mode 100644
index 000000000000..6e6e7490c5ea
--- /dev/null
+++ b/dev-lang/hugs98/files/digest-hugs98-12.2000
@@ -0,0 +1 @@
+MD5 a7b30a909c5f1b5503733211e29671b2 hugs98-Dec2001.tar.gz 821812
diff --git a/dev-lang/hugs98/hugs98-12.2000.ebuild b/dev-lang/hugs98/hugs98-12.2000.ebuild
new file mode 100644
index 000000000000..1cef7dbebccc
--- /dev/null
+++ b/dev-lang/hugs98/hugs98-12.2000.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tom Bevan tom@regex.com.au
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-12.2000.ebuild,v 1.1 2002/04/24 19:43:15 karltk Exp $
+
+P="hugs98-Dec2001"
+S=${WORKDIR}/${P}
+DESCRIPTION="The HUGS98 Haskell interpreter"
+SRC_URI="http://cvs.haskell.org/Hugs/downloads/hugs98-Dec2001.tar.gz"
+HOMEPAGE="http://www.haskell.org/hugs"
+
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ cd ${S}/src/unix || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ cd ..
+ emake || die
+}
+
+src_install () {
+ cd ${S}/src || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc Credits License Readme Install
+}
+