summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-12-17 15:19:53 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-12-17 15:19:53 +0000
commit5f889af8a837d1d7da7c818fb54d2aa9b43c99fa (patch)
tree581daed4110cfd607dbf1ef0ea5895150371c985 /dev-lang/hugs98/hugs98-2003.11.ebuild
parentAdded a cfengine module to test for installed software using portage. Removed... (diff)
downloadhistorical-5f889af8a837d1d7da7c818fb54d2aa9b43c99fa.tar.gz
historical-5f889af8a837d1d7da7c818fb54d2aa9b43c99fa.tar.bz2
historical-5f889af8a837d1d7da7c818fb54d2aa9b43c99fa.zip
disabling pthreads for nvidia opengl users, #34858
Diffstat (limited to 'dev-lang/hugs98/hugs98-2003.11.ebuild')
-rw-r--r--dev-lang/hugs98/hugs98-2003.11.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/hugs98/hugs98-2003.11.ebuild b/dev-lang/hugs98/hugs98-2003.11.ebuild
index b2a360a941d3..d2aa75e254aa 100644
--- a/dev-lang/hugs98/hugs98-2003.11.ebuild
+++ b/dev-lang/hugs98/hugs98-2003.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2003.11.ebuild,v 1.1 2003/12/01 16:52:55 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2003.11.ebuild,v 1.2 2003/12/17 15:19:41 kosmikus Exp $
IUSE="opengl"
@@ -22,6 +22,12 @@ src_compile() {
local myconf
if [ `use opengl` ]; then
myconf="--enable-hopengl"
+ # the nvidia drivers *seem* not to work together
+ # with pthreads
+ [ ! -f /etc/env.d/09opengl ] \
+ || [ -z "`grep opengl/nvidia/lib /etc/env.d/09opengl`" ] \
+ && myconf="$myconf --with-pthreads" \
+ || myconf="--with-pthreads"
fi
# When timing is enabled, the build will fail at some