summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-13 23:43:46 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-13 23:43:46 +0000
commite71a14cc96545aec220c421af1980f6810291df7 (patch)
tree8dcb19c2f12a2aa2b87a0bc99459382466c78543 /dev-java
parentPull the version of gjdoc that uses gjl launcher to prevent insufficient heap... (diff)
downloadhistorical-e71a14cc96545aec220c421af1980f6810291df7.tar.gz
historical-e71a14cc96545aec220c421af1980f6810291df7.tar.bz2
historical-e71a14cc96545aec220c421af1980f6810291df7.zip
Version bump. Contains security fixes. The plugin is built for xulrunner-1.9.1-based browsers only.
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea6-bin/ChangeLog9
-rw-r--r--dev-java/icedtea6-bin/icedtea6-bin-1.6.2.ebuild105
2 files changed, 113 insertions, 1 deletions
diff --git a/dev-java/icedtea6-bin/ChangeLog b/dev-java/icedtea6-bin/ChangeLog
index a5eaede5bf5d..d20b4411be1b 100644
--- a/dev-java/icedtea6-bin/ChangeLog
+++ b/dev-java/icedtea6-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/icedtea6-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/ChangeLog,v 1.6 2009/11/05 18:15:53 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/ChangeLog,v 1.7 2009/11/13 23:43:46 caster Exp $
+
+*icedtea6-bin-1.6.2 (13 Nov 2009)
+
+ 13 Nov 2009; Vlastimil Babka <caster@gentoo.org>
+ +icedtea6-bin-1.6.2.ebuild:
+ Version bump. Contains security fixes. The plugin is built for
+ xulrunner-1.9.1-based browsers only.
05 Nov 2009; Vlastimil Babka <caster@gentoo.org>
-icedtea6-bin-1.3.1-r1.ebuild, -icedtea6-bin-1.4.ebuild,
diff --git a/dev-java/icedtea6-bin/icedtea6-bin-1.6.2.ebuild b/dev-java/icedtea6-bin/icedtea6-bin-1.6.2.ebuild
new file mode 100644
index 000000000000..d59a29ef0f2e
--- /dev/null
+++ b/dev-java/icedtea6-bin/icedtea6-bin-1.6.2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/icedtea6-bin-1.6.2.ebuild,v 1.1 2009/11/13 23:43:46 caster Exp $
+
+EAPI="1"
+
+inherit java-vm-2
+
+dist="mirror://gentoo/"
+DESCRIPTION="A Gentoo-made binary build of the icedtea6 JDK"
+SRC_URI="amd64? ( ${dist}/${PN}-core-${PVR}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-core-${PVR}-x86.tar.bz2 )
+ doc? ( ${dist}/${PN}-doc-${PVR}.tar.bz2 )
+ examples? (
+ amd64? ( ${dist}/${PN}-examples-${PVR}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-examples-${PVR}-x86.tar.bz2 )
+ )
+ nsplugin? (
+ amd64? ( ${dist}/${PN}-nsplugin-${PVR}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-nsplugin-${PVR}-x86.tar.bz2 )
+ )
+ source? ( ${dist}/${PN}-src-${PVR}.tar.bz2 )"
+HOMEPAGE="http://icedtea.classpath.org"
+
+IUSE="X alsa doc examples nsplugin source"
+RESTRICT="strip"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PF}"
+
+RDEPEND=">=sys-devel/gcc-4.3
+ >=sys-libs/glibc-2.9
+ >=media-libs/giflib-4.1.6-r1
+ >=media-libs/jpeg-7
+ >=media-libs/libpng-1.2.38
+ >=sys-libs/zlib-1.2.3-r1
+ alsa? ( >=media-libs/alsa-lib-1.0.20 )
+ X? (
+ >=media-libs/freetype-2.3.9:2
+ >=media-libs/fontconfig-2.6.0-r2:1.0
+ >=x11-libs/libXext-1.0.5
+ >=x11-libs/libXi-1.2.1
+ >=x11-libs/libXtst-1.0.3
+ >=x11-libs/libX11-1.2.2
+ )
+ nsplugin? (
+ >=dev-libs/atk-1.26.0
+ >=dev-libs/glib-2.20.5:2
+ >=dev-libs/nspr-4.8
+ >=x11-libs/cairo-1.8.8
+ >=x11-libs/gtk+-2.16.6:2
+ >=x11-libs/pango-1.24.5
+ )"
+DEPEND=""
+
+QA_EXECSTACK_amd64="opt/${P}/jre/lib/amd64/server/libjvm.so"
+QA_EXECSTACK_x86="opt/${P}/jre/lib/i386/server/libjvm.so
+ opt/${P}/jre/lib/i386/client/libjvm.so"
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${D}/${dest}"
+ dodir "${dest}" || die
+
+ local arch=${ARCH}
+
+ # doins can't handle symlinks.
+ cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
+
+ dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README} || die
+ if use doc ; then
+ dohtml -r ../doc/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ cp -pRP share/{demo,sample} "${ddest}" || die
+ fi
+
+ if use source ; then
+ cp src.zip "${ddest}" || die
+ fi
+
+ if use nsplugin ; then
+ use x86 && arch=i386
+ install_mozilla_plugin "${dest}/jre/lib/${arch}/IcedTeaPlugin.so"
+ fi
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use nsplugin; then
+ elog "The icedtea6-bin browser plugin can be enabled using eselect java-nsplugin"
+ elog "Note that the plugin works only in browsers based on xulrunner-1.9.1"
+ elog "such as Firefox 3.5, and not in older versions! The version for xulrunner-1.9.0"
+ elog "is not included anymore, as 1.9.1 is stable. If you still need it, fill a bug."
+ fi
+}