summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-03 11:30:26 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-03 11:30:26 +0000
commitce9ed19658320aa6ae1295271dae60f2c74bd194 (patch)
tree4374dcf09de7ac27007a315c38fd0a49a5d3f441 /dev-java
parentkeyword ~x86-fbsd (diff)
downloadhistorical-ce9ed19658320aa6ae1295271dae60f2c74bd194.tar.gz
historical-ce9ed19658320aa6ae1295271dae60f2c74bd194.tar.bz2
historical-ce9ed19658320aa6ae1295271dae60f2c74bd194.zip
Revbump to change the naming and default browser plugin on x86. The default variant (without suffix) is now the 'plugin2' which works with Firefox 3+ including 3.6. The old plugin has '-old_oji' suffix and doesn't work in FF 3.6. Users that had the old plugin set will be switched to the new default automatically.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/ChangeLog12
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild7
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.18-r1.ebuild160
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild5
-rw-r--r--dev-java/sun-jre-bin/ChangeLog12
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.18-r1.ebuild149
6 files changed, 334 insertions, 11 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 6382f158fab4..7825e4d2dc88 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.276 2010/01/23 22:06:31 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.277 2010/02/03 11:27:28 caster Exp $
+
+*sun-jdk-1.6.0.18-r1 (03 Feb 2010)
+
+ 03 Feb 2010; Vlastimil Babka <caster@gentoo.org> sun-jdk-1.6.0.17.ebuild,
+ sun-jdk-1.6.0.18.ebuild, +sun-jdk-1.6.0.18-r1.ebuild:
+ Revbump to change the naming and default browser plugin on x86. The
+ default variant (without suffix) is now the 'plugin2' which works with
+ Firefox 3+ including 3.6. The old plugin has '-old_oji' suffix and doesn't
+ work in FF 3.6. Users that had the old plugin set will be switched to the
+ new default automatically.
23 Jan 2010; Vlastimil Babka <caster@gentoo.org> sun-jdk-1.6.0.18.ebuild:
Add jce also to RDEPEND, as pointed out by Amit Dor-Shifer
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild
index ab4cddd90c5f..3e5aab46fad9 100644
--- a/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild,v 1.3 2009/11/05 21:27:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.17.ebuild,v 1.4 2010/02/03 11:27:28 caster Exp $
inherit versionator java-vm-2 eutils pax-utils
@@ -155,7 +155,4 @@ pkg_postinst() {
elog "For more info see https://jdk6.dev.java.net/plugin2/"
elog
fi
-
- elog "Please reinstall eclipse-sdk if you have it installed and want"
- elog "workaround for bug #215150."
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.18-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.18-r1.ebuild
new file mode 100644
index 000000000000..325237c4396a
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.18-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.18-r1.ebuild,v 1.1 2010/02/03 11:27:28 caster Exp $
+
+inherit versionator java-vm-2 eutils pax-utils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's Java SE Development Kit"
+HOMEPAGE="http://java.sun.com/javase/6/"
+URL_BASE="http://download.java.net/dlj/binaries"
+SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
+ amd64? ( ${URL_BASE}/${AMD64_AT} )"
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa derby doc examples jce nsplugin odbc"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so
+ opt/${P}/jre/lib/i386/libdeploy.so
+ opt/${P}/jre/lib/i386/client/libjvm.so
+ opt/${P}/jre/lib/i386/server/libjvm.so"
+QA_DT_HASH="opt/${P}/.*"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.6.0* )"
+RDEPEND="${DEPEND}
+ doc? ( =dev-java/java-sdk-docs-1.6.0* )
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
+
+src_unpack() {
+ sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This needs to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"{,/jre}/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ use derby && dirs="${dirs} db"
+
+ dodir /opt/${P}
+
+ cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
+ dodoc COPYRIGHT || die
+ dohtml README.html || die
+
+ cp -pP src.zip "${D}/opt/${P}/" || die
+
+ if use examples; then
+ cp -pPR demo sample "${D}/opt/${P}/" || die
+ fi
+
+ if use jce; then
+ cd "${D}/opt/${P}/jre/lib/security"
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}"/opt/${P}/jre/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/jre/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/lib/i386/libnpjp2.so
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so old_oji
+ else
+ install_mozilla_plugin /opt/${P}/jre/lib/amd64/libnpjp2.so
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ if [[ -f "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop ]]; then
+ # install control panel for Gnome/KDE
+ # The jre also installs these so make sure that they do not have the same
+ # Name
+ sed -e "s/\(Name=\)Java/\1 Java Control Panel for Sun JDK ${SLOT}/" \
+ -e "s#Exec=.*#Exec=/opt/${P}/jre/bin/ControlPanel#" \
+ -e "s#Icon=.*#Icon=/opt/${P}/jre/plugin/desktop/sun_java.png#" \
+ "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ "${T}"/sun_jdk-${SLOT}.desktop
+
+ domenu "${T}"/sun_jdk-${SLOT}.desktop
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use x86 && use nsplugin; then
+ elog
+ elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
+ elog "Note that starting with ${PN}-1.6.0.18-r1 their naming and the default changed,"
+ elog "users with the old plugin set are switched to the new default automatically."
+ elog "The default ${VMHANDLE} is the new 'plugin2' which works in Firefox 3 (xulrunner-1.9)"
+ elog "and newer, the ${VMHANDLE}-old_oji is the old plugin using the OJI API"
+ elog "that was removed in Firefox 3.6 (xulrunner-1.9.2)."
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+
+ if use amd64 && use nsplugin; then
+ elog
+ elog "The amd64 version ships the new 'plugin2' browser plugin which works"
+ elog "in Firefox 3+ and other recent browser versions."
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+}
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild
index fc38cc57267a..22bad7642824 100644
--- a/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild,v 1.2 2010/01/23 22:06:31 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.18.ebuild,v 1.3 2010/02/03 11:27:28 caster Exp $
inherit versionator java-vm-2 eutils pax-utils
@@ -156,7 +156,4 @@ pkg_postinst() {
elog "For more info see https://jdk6.dev.java.net/plugin2/"
elog
fi
-
- elog "Please reinstall eclipse-sdk if you have it installed and want"
- elog "workaround for bug #215150."
}
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 995ae02083fb..897b28d5fd83 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.167 2010/01/23 22:23:07 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.168 2010/02/03 11:30:26 caster Exp $
+
+*sun-jre-bin-1.6.0.18-r1 (03 Feb 2010)
+
+ 03 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ +sun-jre-bin-1.6.0.18-r1.ebuild:
+ Revbump to change the naming and default browser plugin on x86. The
+ default variant (without suffix) is now the 'plugin2' which works with
+ Firefox 3+ including 3.6. The old plugin has '-old_oji' suffix and doesn't
+ work in FF 3.6. Users that had the old plugin set will be switched to the
+ new default automatically.
23 Jan 2010; Vlastimil Babka <caster@gentoo.org>
sun-jre-bin-1.6.0.18.ebuild, metadata.xml:
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.18-r1.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.18-r1.ebuild
new file mode 100644
index 000000000000..cd64d50ea5f4
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.18-r1.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.18-r1.ebuild,v 1.1 2010/02/03 11:30:26 caster Exp $
+
+inherit versionator pax-utils eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+
+SUFFIX=".bin"
+X86_AT="jdk-${MY_PV}-dlj-linux-i586${SUFFIX}"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64${SUFFIX}"
+
+DESCRIPTION="Sun's Java SE Runtime Environment"
+HOMEPAGE="http://java.sun.com/javase/6/"
+URL_BASE="http://download.java.net/dlj/binaries"
+SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
+ amd64? ( ${URL_BASE}/${AMD64_AT} )"
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa jce nsplugin odbc"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.6.0* )"
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ x86? ( =virtual/libstdc++-3.3 )
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so
+ opt/${P}/lib/i386/server/libjvm.so"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}/construct-1.6.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin lib man"
+
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use jce; then
+ cd "${D}/opt/${P}/lib/security"
+ dodir /opt/${P}/lib/security/strong-jce
+ mv "${D}"/opt/${P}/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/lib/security/strong-jce || die
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/lib/security/
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so old_oji
+ else
+ install_mozilla_plugin /opt/${P}/lib/amd64/libnpjp2.so
+ fi
+ fi
+
+ # install control panel for Gnome/KDE
+ if [[ -e "${D}/opt/${P}/plugin/desktop/sun_java.desktop" ]]; then
+ sed -e "s/\(Name=Java\)/\1 Control Panel for Sun JRE ${SLOT}/" \
+ -e "s#Exec=.*#Exec=/opt/${P}/bin/ControlPanel#" \
+ -e "s#Icon=.*#Icon=/opt/${P}/plugin/desktop/sun_java.png#" \
+ "${D}/opt/${P}/plugin/desktop/sun_java.desktop" > \
+ "${T}/sun_jre-${SLOT}.desktop" || die
+ domenu "${T}/sun_jre-${SLOT}.desktop" || die
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use x86 && use nsplugin; then
+ elog
+ elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
+ elog "Note that starting with ${PN}-1.6.0.18-r1 their naming and the default changed,"
+ elog "users with the old plugin set are switched to the new default automatically."
+ elog "The default ${VMHANDLE} is the new 'plugin2' which works in Firefox 3 (xulrunner-1.9)"
+ elog "and newer, the ${VMHANDLE}-old_oji is the old plugin using the OJI API"
+ elog "that was removed in Firefox 3.6 (xulrunner-1.9.2)."
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+
+ if use amd64 && use nsplugin; then
+ elog
+ elog "The amd64 version ships the new 'plugin2' browser plugin which works"
+ elog "in Firefox 3+ and other recent browser versions."
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+}