summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-11-12 00:18:45 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-11-12 00:18:45 +0000
commita163df5e8b7bffc91eb68151fba0274fb6051a43 (patch)
treef9c1fdaeb352ba57975b0e5070a3f485630d5542 /dev-java
parentstable on amd64 (diff)
downloadhistorical-a163df5e8b7bffc91eb68151fba0274fb6051a43.tar.gz
historical-a163df5e8b7bffc91eb68151fba0274fb6051a43.tar.bz2
historical-a163df5e8b7bffc91eb68151fba0274fb6051a43.zip
Fixes #70326.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/blowfishj/ChangeLog11
-rw-r--r--dev-java/blowfishj/Manifest4
-rw-r--r--dev-java/blowfishj/blowfishj-2.13.ebuild45
-rw-r--r--dev-java/blowfishj/files/digest-blowfishj-2.131
-rw-r--r--dev-java/blowfishj/metadata.xml14
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/blowfishj/ChangeLog b/dev-java/blowfishj/ChangeLog
new file mode 100644
index 000000000000..be3540a87e9f
--- /dev/null
+++ b/dev-java/blowfishj/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/blowfishj
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/ChangeLog,v 1.1 2004/11/12 00:18:45 karltk Exp $
+
+*blowfishj-2.13 (12 Nov 2004)
+
+ 12 Nov 2004; Karl Trygve Kalleberg <karltk@gentoo.org> +metadata.xml,
+ +blowfishj-2.13.ebuild:
+ Initial import. Ebuild submitted by Saleem A. <compnerd@compnerd.org>, fixes
+ #70326.
+
diff --git a/dev-java/blowfishj/Manifest b/dev-java/blowfishj/Manifest
new file mode 100644
index 000000000000..93f236ec240b
--- /dev/null
+++ b/dev-java/blowfishj/Manifest
@@ -0,0 +1,4 @@
+MD5 8592662d52ff22dc6ae09c05bf2cfc29 blowfishj-2.13.ebuild 1038
+MD5 e279f56460d41a2e850af74ff374def5 ChangeLog 429
+MD5 3a5af712fee8c17aaa3329c26c88b57e metadata.xml 526
+MD5 7bfd2e480f4f1da43f4139cda40cd384 files/digest-blowfishj-2.13 54
diff --git a/dev-java/blowfishj/blowfishj-2.13.ebuild b/dev-java/blowfishj/blowfishj-2.13.ebuild
new file mode 100644
index 000000000000..2295a52314b4
--- /dev/null
+++ b/dev-java/blowfishj/blowfishj-2.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.13.ebuild,v 1.1 2004/11/12 00:18:45 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Blowfish implementation in Java"
+SRC_URI="http://www.hotpixel.net/bfj213.zip"
+HOMEPAGE="http://come.to/hahn"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+LICENSE="Apache-1.1"
+SLOT="0"
+IUSE="doc junit"
+DEPEND=">=virtual/jre-1.4
+ app-arch/zip"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ mv BlowfishJ blowfishj-2.13
+}
+
+src_compile() {
+ einfo "Compiling the library"
+
+ for i in BlowfishJ/*.java ; do
+ javac -source 1.3 -target 1.2 $i || die "Compile failed for $i"
+ done
+
+ if use doc ; then
+ javadoc -d doc BlowfishJ/*.java || die "Failed to create docs"
+ fi
+
+ einfo "Creating jar"
+ jar cvf blowfishj.jar BlowfishJ/*.class || die "Failed creating jar"
+}
+
+src_install() {
+ java-pkg_dojar blowfishj.jar
+ dodoc README.TXT
+
+ if use doc ; then
+ java-pkg_dohtml -r docs/html/*
+ fi
+}
diff --git a/dev-java/blowfishj/files/digest-blowfishj-2.13 b/dev-java/blowfishj/files/digest-blowfishj-2.13
new file mode 100644
index 000000000000..84b9017fae68
--- /dev/null
+++ b/dev-java/blowfishj/files/digest-blowfishj-2.13
@@ -0,0 +1 @@
+MD5 a80a830852a51e47f7a62d8860e1fbd5 bfj213.zip 37886
diff --git a/dev-java/blowfishj/metadata.xml b/dev-java/blowfishj/metadata.xml
new file mode 100644
index 000000000000..840efe3842ab
--- /dev/null
+++ b/dev-java/blowfishj/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+The Blowfish implementation in Java, provides very fast ECB and CBC encryption.
+Comes with the BlowfishEasy class for simple string encryption, plus a solution
+for streaming, both are binary compatible to Blowfish.NET. Additionally this
+package includes its own SHA-1 class, all sources, JUnit test cases, demos and
+JavaDocs.
+</longdescription>
+</pkgmetadata>