summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-01 15:45:37 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-01 15:45:37 +0000
commit75e64c309c730c7493d15fe92d6134605c98443d (patch)
tree09efdd4ec8578af91fa4962f8c090f56970b53e7 /dev-java
parentManifest recommit (diff)
downloadhistorical-75e64c309c730c7493d15fe92d6134605c98443d.tar.gz
historical-75e64c309c730c7493d15fe92d6134605c98443d.tar.bz2
historical-75e64c309c730c7493d15fe92d6134605c98443d.zip
Initial import. Fixes #46415.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jessie/ChangeLog8
-rw-r--r--dev-java/jessie/Manifest4
-rw-r--r--dev-java/jessie/files/digest-jessie-0.9.71
-rw-r--r--dev-java/jessie/jessie-0.9.7.ebuild44
-rw-r--r--dev-java/jessie/metadata.xml45
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-java/jessie/ChangeLog b/dev-java/jessie/ChangeLog
new file mode 100644
index 000000000000..b515ec904c79
--- /dev/null
+++ b/dev-java/jessie/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/jessie
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jessie/ChangeLog,v 1.1 2004/04/01 15:45:37 karltk Exp $
+
+*jessie-0.9.7 (01 Apr 2004)
+
+ 01 Apr 2004; Karl Trygve Kalleberg <karltk@gentoo.org> jessie-0.9.7.ebuild:
+ Initial import. Ebuild submitted by myself.
diff --git a/dev-java/jessie/Manifest b/dev-java/jessie/Manifest
new file mode 100644
index 000000000000..df6b75c6208b
--- /dev/null
+++ b/dev-java/jessie/Manifest
@@ -0,0 +1,4 @@
+MD5 611f8a3accb06282e08d3858105f9846 jessie-0.9.7.ebuild 1073
+MD5 10bbbbe3ef6dfc0284c8dca3f4393aa4 ChangeLog 364
+MD5 d7a22352b39820b369e6e067dcac7fff metadata.xml 2204
+MD5 59b4fef8154b01c51687fb80620b62f2 files/digest-jessie-0.9.7 64
diff --git a/dev-java/jessie/files/digest-jessie-0.9.7 b/dev-java/jessie/files/digest-jessie-0.9.7
new file mode 100644
index 000000000000..cc70adbefeff
--- /dev/null
+++ b/dev-java/jessie/files/digest-jessie-0.9.7
@@ -0,0 +1 @@
+MD5 f433dfacf37440e68a4c850a83c1ffb5 jessie-0.9.7.tar.gz 768614
diff --git a/dev-java/jessie/jessie-0.9.7.ebuild b/dev-java/jessie/jessie-0.9.7.ebuild
new file mode 100644
index 000000000000..324e415f67f7
--- /dev/null
+++ b/dev-java/jessie/jessie-0.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jessie/jessie-0.9.7.ebuild,v 1.1 2004/04/01 15:45:37 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Free JSSE implementation"
+HOMEPAGE="http://www.nongnu.org/jessie"
+SRC_URI="http://syzygy.metastatic.org/jessie/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes"
+RDEPEND=">=dev-java/gnu-classpath-0.08_rc1"
+
+DEPEND=">=virtual/jdk-1.3
+ jikes? ( >=dev-java/jikes-1.19 )
+ ${RDEPEND}
+ "
+
+src_compile() {
+
+ use jikes && export JAVAC=$(which jikes)
+
+ export CLASSPATH=${CLASSPATH}:$(java-config -p gnu-crypto)
+ export CLASSPATH=${CLASSPATH}:/usr/share/classpath/glibj.zip
+
+ # Must check later that this actually works
+ econf --with-java-target=1.4 || die
+ make || die
+ if use doc ; then
+ emake apidoc
+ fi
+}
+
+src_install() {
+ einstall || die
+ rm ${D}/usr/share/*.jar
+ java-pkg_dojar lib/javax-net.jar \
+ lib/javax-security-cert.jar \
+ lib/org-metastatic-jessie.jar
+ use doc && dohtml -r apidoc/*
+}
+
diff --git a/dev-java/jessie/metadata.xml b/dev-java/jessie/metadata.xml
new file mode 100644
index 000000000000..b3b1d7281609
--- /dev/null
+++ b/dev-java/jessie/metadata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Jessie is a free, clean-room implementation of the Java Secure Sockets
+Extension, the JSSE. It provides the core API for programming network
+sockets with the Secure Socket Layer (SSL), which creates an
+authenticated, unforgeable, and protected layer around network
+communications. Its goal is to be a drop-in package for free Java class
+libraries such as Classpath and its derivatives, and is being written to
+depend only on free software, and only with the API specification and
+the public protocol specifications.
+
+Included in this package are a clean-room implementation of the
+javax.net, javax.net.ssl, and javax.security.cert packages, and a JSSE
+provider that implements the SSL version 3 and TLS version 1 protocols.
+
+Jessie is distributed under the terms of the GNU Gereral Public License.
+The implementations of javax.net, javax.net.ssl, and javax.security.cert
+packages are additionally covered by the following exception:
+
+ "Linking this library statically or dynamically with other modules
+ is making a combined work based on this library. Thus, the terms and
+ conditions of the GNU General Public License cover the whole
+ combination.
+
+ "As a special exception, the copyright holders of this library
+ give you permission to link this library with independent
+ modules to produce an executable, regardless of the license
+ terms of these independent modules, and to copy and distribute
+ the resulting executable under terms of your choice, provided
+ that you also meet, for each linked independent module, the
+ terms and conditions of the license of that module. An
+ independent module is a module which is not derived from or
+ based on this library. If you modify this library, you may
+ extend this exception to your version of the library, but you
+ are not obligated to do so. If you do not wish to do so, delete
+ this exception statement from your version."
+
+"JESSIE" stands for "JESSIE Executes Secure Sockets In Excess".
+</longdescription>
+</pkgmetadata>