summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-16 20:08:01 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-16 20:08:01 +0000
commit3f75b346cdfb20c77d6d9938a26726eaac312638 (patch)
tree8ba9cb0c82ebc420d948158923ca720d609348a9 /dev-java/xalan/xalan-2.6.0.ebuild
parentVersion Bump (diff)
downloadhistorical-3f75b346cdfb20c77d6d9938a26726eaac312638.tar.gz
historical-3f75b346cdfb20c77d6d9938a26726eaac312638.tar.bz2
historical-3f75b346cdfb20c77d6d9938a26726eaac312638.zip
Version Bump
Diffstat (limited to 'dev-java/xalan/xalan-2.6.0.ebuild')
-rw-r--r--dev-java/xalan/xalan-2.6.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/xalan/xalan-2.6.0.ebuild b/dev-java/xalan/xalan-2.6.0.ebuild
new file mode 100644
index 000000000000..63f2a6e63c3a
--- /dev/null
+++ b/dev-java/xalan/xalan-2.6.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.6.0.ebuild,v 1.1 2004/07/16 20:08:01 axxo Exp $
+
+inherit java-pkg eutils
+
+IUSE="doc"
+
+MY_P=${PN}-j_${PV//./_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="XSLT processor"
+HOMEPAGE="http://xml.apache.org/xalan-j/index.html"
+SRC_URI="mirror://apache/xml/xalan-j/source/${MY_P}-src.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.5.2
+ >=dev-java/xerces-2.6.0"
+RDEPEND=">=virtual/jdk-1.3
+ >=dev-java/xerces-2.6.0"
+
+src_compile() {
+ CLASSPATH=$CLASSPATH:`pwd`/bin/xercesImpl.jar:`pwd`/bin/bsf.jar:`pwd`/src\
+ ant jar ${myc} || die "build failed"
+
+ if use doc ; then
+ if [ `java-config --java-version 2>&1 | grep "1\.4\." | wc -l` -lt 1 ] ; then
+ ant javadocs || die "Build Javadocs Failed"
+ else
+ USE=""
+ einfo " "
+ einfo " 1.4.x JDKs are unable to compile Javadocs at this time. "
+ einfo " "
+ fi
+ fi
+}
+
+src_install () {
+ java-pkg_dojar build/*.jar
+ dohtml readme.html
+
+ if use doc ; then
+ dodir /usr/share/doc/${P}
+ dodoc TODO STATUS README LICENSE ISSUES
+ dohtml -r build/docs/*
+ fi
+}
+
+pkg_postinst() {
+ if use doc ; then
+ einfo " "
+ einfo " API Documentation is in /usr/share/doc/${PN}-${PV}. "
+ einfo " "
+ einfo " Design documentation can be found online at: "
+ einfo " http://xml.apache.org/xalan-j/design/design2_0_0.html"
+ einfo " "
+ sleep 5
+ else
+ einfo " "
+ einfo " Online Documentation: "
+ einfo " http://xml.apache.org/xalan-j/design/design2_0_0.html"
+ einfo " http://xml.apache.org/xalan-j/apidocs/index.html "
+ einfo " "
+ sleep 5
+ fi
+}