summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-13 14:08:28 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-13 14:08:28 +0000
commitc338a0e65a78971a282ed693cb9bbfce9e9a032c (patch)
tree7ad823d9d0074aea7404c6e1d6918b2c983b1bed /dev-java/sun-jre-bin
parentSwitch from kde-functions.eclass to qt3.eclass. Also fixes bug #97956. (diff)
downloadhistorical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.tar.gz
historical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.tar.bz2
historical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.zip
QA: Use full atoms for best_version, has_version and built_with_use queries.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
index 6b447303290c..4cc3361cd449 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.1 2005/07/11 13:20:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.2 2005/07/13 14:00:54 swegener Exp $
inherit java eutils
@@ -87,7 +87,7 @@ src_install () {
if use browserplugin || use mozilla; then
local plugin_dir="ns610"
- if has_version '>=gcc-3.2*' ; then
+ if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
fi
install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
@@ -120,7 +120,7 @@ pkg_postinst () {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -131,7 +131,7 @@ pkg_postinst () {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
index 5a4b4d939f27..5defe8eae70e 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.3 2005/07/11 13:20:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.4 2005/07/13 14:00:54 swegener Exp $
inherit java eutils
@@ -80,7 +80,7 @@ src_install () {
if use browserplugin || use mozilla; then
local plugin_dir="ns610"
- if has_version '>=gcc-3.2*' ; then
+ if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
fi
install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
@@ -113,7 +113,7 @@ pkg_postinst () {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -124,7 +124,7 @@ pkg_postinst () {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
index 599d613b6397..1264709b4c1f 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild,v 1.3 2005/07/11 13:20:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild,v 1.4 2005/07/13 14:00:54 swegener Exp $
inherit java eutils
@@ -99,7 +99,7 @@ src_install() {
if use browserplugin || use mozilla; then
local plugin_dir="ns7-gcc29"
- if has_version '>=gcc-3*' ; then
+ if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
fi
@@ -141,7 +141,7 @@ pkg_postinst() {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -152,7 +152,7 @@ pkg_postinst() {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"