summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-06-19 09:55:55 +0000
committerVlastimil Babka <caster@gentoo.org>2009-06-19 09:55:55 +0000
commit34176f6d5db660e6d29734c3fae3093d39d8fd29 (patch)
tree76eacca7d97bb889a43435377591cc61ff6cb8f8 /dev-java/sun-jre-bin
parentstable x86, bug 274648 (diff)
downloadhistorical-34176f6d5db660e6d29734c3fae3093d39d8fd29.tar.gz
historical-34176f6d5db660e6d29734c3fae3093d39d8fd29.tar.bz2
historical-34176f6d5db660e6d29734c3fae3093d39d8fd29.zip
Version bump.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild114
2 files changed, 121 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 1cdaf4a325db..d6155bb9f459 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.149 2009/05/31 11:24:55 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.150 2009/06/19 09:55:55 caster Exp $
+
+*sun-jre-bin-1.5.0.19 (19 Jun 2009)
+
+ 19 Jun 2009; Vlastimil Babka <caster@gentoo.org>
+ +sun-jre-bin-1.5.0.19.ebuild:
+ Version bump.
*sun-jre-bin-1.6.0.14 (31 May 2009)
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild
new file mode 100644
index 000000000000..12312684454e
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild,v 1.1 2009/06/19 09:55:55 caster Exp $
+
+inherit pax-utils versionator eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's Java SE Runtime Environment"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa nsplugin odbc"
+
+RDEPEND="sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}/construct.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin lib man"
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties \
+ fontconfig.properties || die
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}