summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
commit4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239 (patch)
treef9714340fe3c102bb2e07cab72fc0f2dee0e760d /dev-java/sun-jdk
parentFixed compilation problem with missing inttypes.h. (diff)
downloadhistorical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.tar.gz
historical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.tar.bz2
historical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.zip
Respect the global USE=nsplugin instead of the local USE=browserplugin
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild6
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild6
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild10
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild10
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild10
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild10
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild10
8 files changed, 38 insertions, 32 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index fa745cb362d0..5f57cba86442 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.123 2005/10/13 09:50:49 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.124 2005/10/18 19:25:14 agriffis Exp $
+
+ 18 Oct 2005; Aron Griffis <agriffis@gentoo.org> sun-jdk-1.3.1.13.ebuild,
+ sun-jdk-1.3.1.16.ebuild, sun-jdk-1.4.2.08.ebuild,
+ sun-jdk-1.4.2.08-r1.ebuild, sun-jdk-1.4.2.09.ebuild,
+ sun-jdk-1.5.0.04.ebuild, sun-jdk-1.5.0.05.ebuild:
+ Respect the global USE=nsplugin instead of the local USE=browserplugin
*sun-jdk-1.3.1.16 (13 Oct 2005)
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
index 070c693232b2..ec7220d951f0 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.11 2005/09/10 18:18:02 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.12 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.3"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc browserplugin mozilla"
+IUSE="doc nsplugin mozilla"
# this is needed for proper operating under a PaX kernel without activated grsecurity acl
CHPAX_CONSERVATIVE_FLAGS="pemsv"
@@ -87,7 +87,7 @@ src_install() {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
install_mozilla_plugin /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so
fi
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
index c7661ea2cf1e..c46daaac07b7 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.1 2005/10/13 09:50:49 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.2 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.3"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc browserplugin mozilla"
+IUSE="doc nsplugin mozilla"
# this is needed for proper operating under a PaX kernel without activated grsecurity acl
CHPAX_CONSERVATIVE_FLAGS="pemsv"
@@ -87,7 +87,7 @@ src_install() {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
install_mozilla_plugin /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so
fi
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
index 875d2acf10b2..0b2950fab80c 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.6 2005/09/30 18:13:26 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.7 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -123,7 +123,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -196,9 +196,9 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
index da2231c4c00e..ee19fa620e56 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.9 2005/09/30 15:34:19 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.10 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -116,7 +116,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -189,9 +189,9 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
index 46cbd6748703..c74a8b838a35 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild,v 1.6 2005/09/30 18:13:26 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild,v 1.7 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -123,7 +123,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -196,9 +196,9 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
index 22e0ae4fe489..905fa7eab71f 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.5 2005/09/10 18:18:02 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.6 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -27,7 +27,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch nostrip"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#
DEPEND=">=dev-java/java-config-1.2
@@ -129,7 +129,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -218,9 +218,9 @@ pkg_postinst() {
einfo " are not valid identifiers any more in that mode,"
einfo " which can cause incompatibility with certain sources."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
index 480d6f1ff037..99f3f15edd9d 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild,v 1.2 2005/10/10 16:23:12 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild,v 1.3 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -27,7 +27,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch nostrip"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#
DEPEND=">=dev-java/java-config-1.2
@@ -137,7 +137,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -226,9 +226,9 @@ pkg_postinst() {
einfo " are not valid identifiers any more in that mode,"
einfo " which can cause incompatibility with certain sources."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE."
+ ewarn "has been renamed to 'nsplugin' please update your USE."
fi
}