summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-17 13:59:34 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-17 13:59:34 +0000
commitdc6dbb03a819e47537c65b0f651703d327e55412 (patch)
tree785e91921451be8322dd0c4b6a9f1e02e478c60c /dev-java/saxpath/saxpath-1.0.ebuild
parentgnome 2.8 commit, fix up older ebuilds (diff)
downloadhistorical-dc6dbb03a819e47537c65b0f651703d327e55412.tar.gz
historical-dc6dbb03a819e47537c65b0f651703d327e55412.tar.bz2
historical-dc6dbb03a819e47537c65b0f651703d327e55412.zip
initial import, ebuild created by me
Diffstat (limited to 'dev-java/saxpath/saxpath-1.0.ebuild')
-rw-r--r--dev-java/saxpath/saxpath-1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/saxpath/saxpath-1.0.ebuild b/dev-java/saxpath/saxpath-1.0.ebuild
new file mode 100644
index 000000000000..68a214b29c36
--- /dev/null
+++ b/dev-java/saxpath/saxpath-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxpath/saxpath-1.0.ebuild,v 1.1 2004/09/17 13:59:34 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A Simple API for XPath."
+HOMEPAGE="http://saxpath.sourceforge.net/"
+SRC_URI="mirror://sourceforge/saxpath/${P}.tar.gz"
+LICENSE="saxpath"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc junit"
+DEPEND="dev-java/ant
+ junit? ( dev-java/junit )
+ dev-java/xalan
+ >=dev-java/xerces-2.6.2-r1"
+#RDEPEND=""
+
+S=${WORKDIR}/${P}-FCS
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f *.jar
+ mkdir src/conf
+ cp ${FILESDIR}/MANIFEST.MF src/conf
+ cd lib
+ rm -f jakarta-ant-1.3-optional.jar ant-1.3.jar xerces.jar junit.jar
+ use junit && java-pkg_jar-from junit
+ java-pkg_jar-from xalan
+ java-pkg_jar-from xerces-2
+}
+
+src_compile() {
+ local antops="package"
+ use doc && antops="${antops} doc javadoc"
+ use junit && antops="${antops} test"
+ ant ${antops} || die "failed to compile"
+}
+
+src_install() {
+ java-pkg_dojar build/saxpath.jar
+
+ use doc && dohtml -r build/doc/*
+}