summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-05-14 06:15:18 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-05-14 06:15:18 +0000
commit9b95e6450d20df1eb29addbd1ae35abb19bc00ba (patch)
treeb1457c32e774701d28cf2490f4e28c829256f9ca /dev-java/saxon/saxon-7.5.ebuild
parentInitial import. Closes #15106. (diff)
downloadhistorical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.tar.gz
historical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.tar.bz2
historical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.zip
Initial import. Closes #15106.
Diffstat (limited to 'dev-java/saxon/saxon-7.5.ebuild')
-rw-r--r--dev-java/saxon/saxon-7.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/saxon/saxon-7.5.ebuild b/dev-java/saxon/saxon-7.5.ebuild
new file mode 100644
index 000000000000..e97ee4e6f8ae
--- /dev/null
+++ b/dev-java/saxon/saxon-7.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxon/saxon-7.5.ebuild,v 1.1 2003/05/14 06:15:13 absinthe Exp $
+
+inherit java-pkg
+
+S=${WORKDIR}
+DESCRIPTION="The SAXON package is a collection of tools for processing XML documents: XSLT processor, XSL library, parser."
+SRC_URI="mirror://sourceforge/saxon/saxon${PV//./-}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="doc"
+DEPEND=""
+RDEPEND="virtual/jdk"
+SLOT="0"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ use doc && dohtml -r doc/*
+ java-pkg_dojar *.jar
+}