summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-12-10 20:15:17 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-12-10 20:15:17 +0000
commit0c544a29c8fb2bb774ee9bfdb2d88a6032b77f9e (patch)
treedd03f66efafa28871a4b5bae0dbac71615952688 /dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild
parentRemove dev-python/fxpy, bug 153234. (diff)
downloadhistorical-0c544a29c8fb2bb774ee9bfdb2d88a6032b77f9e.tar.gz
historical-0c544a29c8fb2bb774ee9bfdb2d88a6032b77f9e.tar.bz2
historical-0c544a29c8fb2bb774ee9bfdb2d88a6032b77f9e.zip
Added jni use flag to 2.0.1 and 2.1.0 to control building of the native parts, the JDBC type 2 native part. Brought over 1.5.x from jdbc*-firebird, to prepare for that package removal/move.
Package-Manager: portage-2.1.2_rc3-r1
Diffstat (limited to 'dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild')
-rw-r--r--dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild b/dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild
new file mode 100644
index 000000000000..54e774663139
--- /dev/null
+++ b/dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/jdbc-jaybird-1.5.6.ebuild,v 1.1 2006/12/10 20:15:17 wltjr Exp $
+
+inherit java-pkg-2
+
+MY_P="FirebirdSQL-${PV}JDK_1.4"
+DESCRIPTION="JDBC Type 4 driver for Firebird SQL server"
+HOMEPAGE="http://jaybirdwiki.firebirdsql.org/"
+SRC_URI="mirror://sourceforge/firebird/${MY_P}.zip"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc"
+DEPEND="|| ( =virtual/jdk-1.4* =virtual/jdk-1.5* )
+ app-arch/unzip"
+RDEPEND="|| ( =virtual/jre-1.4* =virtual/jre-1.5* )"
+S=${WORKDIR}
+
+src_install() {
+ java-pkg_dojar *.jar
+
+ use doc && java-pkg_dohtml -r docs/
+ dodoc ChangeLog release_notes.html
+}