summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-16 23:59:04 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-16 23:59:04 +0000
commit31b09aac4a50a57ffc059edc4a45e7e8330b9728 (patch)
tree5b60a97048afafbc094e34f962cf603760e5d188 /dev-java/commons-collections
parent*** empty log message *** (diff)
downloadhistorical-31b09aac4a50a57ffc059edc4a45e7e8330b9728.tar.gz
historical-31b09aac4a50a57ffc059edc4a45e7e8330b9728.tar.bz2
historical-31b09aac4a50a57ffc059edc4a45e7e8330b9728.zip
Added 'doc' use flag.
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog8
-rw-r--r--dev-java/commons-collections/commons-collections-2.1-r2.ebuild44
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-2.1-r21
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index 266802ddf9dc..7971dbf78e6a 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.7 2003/02/12 05:50:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.8 2003/03/16 23:59:04 absinthe Exp $
+
+*commons-collections-2.1-r2 (16 Mar 2003)
+
+ 16 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-collections-2.1-r2.ebuild:
+ Added 'doc' use flag.
*commons-collections-2.1-r1 (02 Nov 2002)
diff --git a/dev-java/commons-collections/commons-collections-2.1-r2.ebuild b/dev-java/commons-collections/commons-collections-2.1-r2.ebuild
new file mode 100644
index 000000000000..9080a3319514
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-2.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1-r2.ebuild,v 1.1 2003/03/16 23:59:04 absinthe Exp $
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ local myc
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" > build.properties
+ ANT_OPTS=${myc} ant || die "Testing Classes Failed"
+ fi
+
+ ANT_OPTS=${myc} ant dist-jar || die "Compilation Failed"
+
+ if [ -n "`use doc`" ] ; then
+ ANT_OPTS=${myc} ant doc || die "Unable to create documents"
+ fi
+}
+
+src_install () {
+ dojar dist/${PN}*.jar || die "Unable to Install"
+
+ if [ -n "`use doc`" ] ; then
+ dohtml dist/*.html
+ dohtml -r dist/docs/*
+ fi
+}
diff --git a/dev-java/commons-collections/files/digest-commons-collections-2.1-r2 b/dev-java/commons-collections/files/digest-commons-collections-2.1-r2
new file mode 100644
index 000000000000..f2de34acfce0
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-2.1-r2
@@ -0,0 +1 @@
+MD5 ee30c02b1b57693f72cd86c899b925d9 commons-collections-2.1-src.tar.gz 229173