summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-12-09 23:29:00 +0000
committerVlastimil Babka <caster@gentoo.org>2008-12-09 23:29:00 +0000
commit16f9c327f74e196a96f8a2031bbfba02b8ab6048 (patch)
treed851f3473266e742f65daa7e2486b02cc5bbaf80 /dev-java/ant-apache-bsf
parentFix tmpfile patch. (diff)
downloadhistorical-16f9c327f74e196a96f8a2031bbfba02b8ab6048.tar.gz
historical-16f9c327f74e196a96f8a2031bbfba02b8ab6048.tar.bz2
historical-16f9c327f74e196a96f8a2031bbfba02b8ab6048.zip
Actually put -r0 back to EAPI=1.
Package-Manager: portage-2.2_rc17/cvs/Linux 2.6.27-gentoo-r1-perfctr x86_64 RepoMan-Options: --force
Diffstat (limited to 'dev-java/ant-apache-bsf')
-rw-r--r--dev-java/ant-apache-bsf/ChangeLog6
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild18
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-java/ant-apache-bsf/ChangeLog b/dev-java/ant-apache-bsf/ChangeLog
index b319a66f4ebc..329b2f84e8c9 100644
--- a/dev-java/ant-apache-bsf/ChangeLog
+++ b/dev-java/ant-apache-bsf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-apache-bsf
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.16 2008/12/09 23:15:07 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.17 2008/12/09 23:28:00 caster Exp $
+
+ 09 Dec 2008; Vlastimil Babka <caster@gentoo.org>
+ ant-apache-bsf-1.7.1.ebuild:
+ Actually put -r0 back to EAPI=1.
*ant-apache-bsf-1.7.1-r1 (09 Dec 2008)
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
index c6cbdd4b10f7..4600154a4819 100644
--- a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild,v 1.2 2008/09/27 11:48:47 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild,v 1.3 2008/12/09 23:28:00 caster Exp $
-EAPI=2
+EAPI=1
ANT_TASK_DEPNAME="bsf-2.3"
@@ -12,12 +12,10 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
# ant-nodeps contains <script> task which is needed for this
# although it's not a build dep through import
-DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3"
RDEPEND="${DEPEND}
~dev-java/ant-nodeps-${PV}"
-IUSE="python javascript tcl"
-
JAVA_PKG_FILTER_COMPILER="jikes"
src_install() {
@@ -25,7 +23,17 @@ src_install() {
java-pkg_register-dependency ant-nodeps
}
+built_with_use_warn() {
+ if ! built_with_use --missing false -o dev-java/bsf ${1}; then
+ elog "If you want to use ${2} in <script> tasks in build.xml files,"
+ elog "dev-java/bsf must be installed with \"${3-${1}}\" USE flag"
+ fi
+}
+
pkg_postinst() {
+ built_with_use_warn python Python
+ built_with_use_warn javascript JavaScript
+ built_with_use_warn tcl TCL
elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
elog "ruby and beanshell. See its postinst elog messages for instructions."
}