summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-08-23 13:15:43 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-08-23 13:15:43 +0000
commit48f97c93c9205221660fa444c20c9ee9022d599e (patch)
tree80657b542c50d05ee32f5dc4f7e0a31a4f1ed696 /dev-haskell/wxhaskell
parentpurge (diff)
downloadhistorical-48f97c93c9205221660fa444c20c9ee9022d599e.tar.gz
historical-48f97c93c9205221660fa444c20c9ee9022d599e.tar.bz2
historical-48f97c93c9205221660fa444c20c9ee9022d599e.zip
new version
Diffstat (limited to 'dev-haskell/wxhaskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog7
-rw-r--r--dev-haskell/wxhaskell/Manifest4
-rw-r--r--dev-haskell/wxhaskell/files/digest-wxhaskell-0.81
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.8.ebuild84
4 files changed, 94 insertions, 2 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index 0b27963bc705..a95b1ea5fc1c 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wxhaskell
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.6 2004/06/24 22:15:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.7 2004/08/23 13:15:43 kosmikus Exp $
+
+*wxhaskell-0.8 (23 Aug 2004)
+
+ 23 Aug 2004; Andres Loeh <kosmikus@gentoo.org> wxhaskell-0.8.ebuild:
+ New version.
13 Jun 2004; Andres Loeh <kosmikus@gentoo.org> wxhaskell-0.7.ebuild:
Marked stable for x86.
diff --git a/dev-haskell/wxhaskell/Manifest b/dev-haskell/wxhaskell/Manifest
index 179c4875534e..1f72a7d4967a 100644
--- a/dev-haskell/wxhaskell/Manifest
+++ b/dev-haskell/wxhaskell/Manifest
@@ -1,8 +1,10 @@
MD5 e22f934b9f040f325944ac24ac7478e5 wxhaskell-0.7.ebuild 2331
MD5 61868cbfbc9fef58146982ef2ad7c74e wxhaskell-0.6-r1.ebuild 2368
MD5 a07765cd08c1fd8eab7f40b2f18acf5b wxhaskell-0.6.ebuild 2238
-MD5 de013093caebf39b91b0ed6cfcbe97bc ChangeLog 920
+MD5 541c57ec11107ed79dd51e244f49ecab ChangeLog 1037
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
+MD5 7d2b03769dbad0e69be03dffcb209cad wxhaskell-0.8.ebuild 2332
MD5 3370d9be457b4e8fa9b80ec89b49f30b files/digest-wxhaskell-0.6 132
MD5 6f249be5b808ef834f9ea740d68b12c4 files/digest-wxhaskell-0.7 66
+MD5 08efb7ecd02832c5599b968bdc329dc9 files/digest-wxhaskell-0.8 66
MD5 2b3cf83262913705b98fae84eb4e5757 files/digest-wxhaskell-0.6-r1 66
diff --git a/dev-haskell/wxhaskell/files/digest-wxhaskell-0.8 b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.8
new file mode 100644
index 000000000000..e1024cadae05
--- /dev/null
+++ b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.8
@@ -0,0 +1 @@
+MD5 40e9765fbab3ace2cfdd1fe5571ceaec wxhaskell-src-0.8.zip 545291
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.8.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.8.ebuild
new file mode 100644
index 000000000000..d72ab176ab0d
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.8.ebuild,v 1.1 2004/08/23 13:15:43 kosmikus Exp $
+
+DESCRIPTION="a portable and native GUI library for Haskell"
+HOMEPAGE="http://wxhaskell.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxhaskell/${PN}-src-${PV}.zip"
+LICENSE="wxWinLL-3"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+DEPEND="${DEPEND}
+ >=virtual/ghc-6.2
+ >=x11-libs/wxGTK-2.4.1
+ doc? ( >=dev-haskell/haddock-0.6-r2 )"
+
+# the variable ghc_version is used to store the ghc version we are building against
+
+src_compile() {
+ # non-standard configure, so econf is not an option
+ mv configure configure.orig
+ # adapt to Gentoo path convention
+ sed -e 's:/doc/html:/share/doc/html:' \
+ configure.orig > configure
+ # sed -e 's:test "$wxwinlib\":test "":' configure.orig > configure
+ chmod u+x ./configure
+ # determine ghc library directory
+ # (so that it's possible to install the library for
+ # multiple versions of ghc)
+ local myopts
+ ghc_version=`best_version virtual/ghc | sed "s:.*/::"`
+ test -n ${ghc_version} && ghclibdir="/usr/lib/${ghc_version}"
+ test -n ${ghclibdir} || ghclibdir="/usr/lib"
+ test -n ${ghclibdir} && myopts="${myopts} --libdir=${D}/${ghclibdir}"
+ ./configure \
+ --prefix=${D}/usr \
+ --hcpkg=/bin/true \
+ --with-opengl \
+ ${myopts} \
+ || die "./configure failed"
+ # emake doesn't work
+ make || die "make failed"
+ # create documentation
+ if use doc; then
+ make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ local f
+ make install || die "make install failed"
+ for f in ${D}/usr/lib/${ghc_version}/libwxc-*.so; do
+ mv ${f} ${D}/usr/lib
+ done
+ if use doc; then
+ dohtml -A haddock -r out/doc/*
+ cp -r samples ${D}/usr/share/doc/${PF}
+ fi
+}
+
+pkg_postinst() {
+ einfo "Registering wxcore package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wxcore.pkg
+ einfo "Registering wx package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wx.pkg
+}
+
+pkg_postrm() {
+ # check if another version is still there
+ has_version "<${CATEGORY}/${PF}" \
+ || has_version ">${CATEGORY}/${PF}" \
+ || unregister_ghc_packages
+}
+
+unregister_ghc_packages() {
+ einfo "Unregistering wx package"
+ /usr/bin/ghc-pkg -r wx
+ einfo "Unregistering wxcore package"
+ /usr/bin/ghc-pkg -r wxcore
+}
+