summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 04:01:03 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 04:01:03 +0000
commitaacc8a14c8533d65715c9453681c7459c6569c7a (patch)
treea2c962c2b27a62d39451894aeead63cbfc8e0e01 /dev-haskell/texmath
parentBump highlighting-kate to 0.5.1 (diff)
downloadhistorical-aacc8a14c8533d65715c9453681c7459c6569c7a.tar.gz
historical-aacc8a14c8533d65715c9453681c7459c6569c7a.tar.bz2
historical-aacc8a14c8533d65715c9453681c7459c6569c7a.zip
Bump texmath to 0.6.0.6
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/texmath')
-rw-r--r--dev-haskell/texmath/ChangeLog7
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.6.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index 82129e3a6e76..adeaa6bdeb29 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.3 2012/04/07 05:23:08 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.4 2012/06/02 04:01:03 gienah Exp $
+
+*texmath-0.6.0.6 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +texmath-0.6.0.6.ebuild:
+ Bump texmath to 0.6.0.6
*texmath-0.6.0.4 (07 Apr 2012)
diff --git a/dev-haskell/texmath/texmath-0.6.0.6.ebuild b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
new file mode 100644
index 000000000000..103e143eeb0b
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.6.ebuild,v 1.1 2012/06/02 04:01:03 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-3[profile?]
+ dev-haskell/syb[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ >=dev-lang/ghc-6.8.2
+ cgi? ( dev-haskell/json[profile?]
+ dev-haskell/cgi[profile?]
+ dev-haskell/utf8-string[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}