summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-03 07:34:54 +0000
committerMark Wright <gienah@gentoo.org>2014-07-03 07:34:54 +0000
commiteac2dd82686490268ac0c9bd999dcac899d7db5f (patch)
tree5421100efa8dad178a329f447c52460e44b27ab6 /dev-haskell/lcs
parentAdded systemd USE flag to forward console query to systemd, #515982 (diff)
downloadhistorical-eac2dd82686490268ac0c9bd999dcac899d7db5f.tar.gz
historical-eac2dd82686490268ac0c9bd999dcac899d7db5f.tar.bz2
historical-eac2dd82686490268ac0c9bd999dcac899d7db5f.zip
Add lcs
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'dev-haskell/lcs')
-rw-r--r--dev-haskell/lcs/Manifest13
-rw-r--r--dev-haskell/lcs/lcs-0.2.ebuild23
-rw-r--r--dev-haskell/lcs/metadata.xml27
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-haskell/lcs/Manifest b/dev-haskell/lcs/Manifest
index c9ca84b2f6a3..4912d684a647 100644
--- a/dev-haskell/lcs/Manifest
+++ b/dev-haskell/lcs/Manifest
@@ -1,3 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
DIST lcs-0.2.tar.gz 11638 SHA256 b4db67ead4e2f58c4d462d4c1006d2158744ef3ca8597295a1dfa08537401ff1 SHA512 ac5ac6d9a151be46054f2f56a5927182fe6942e518a04a8c484b02c8caec0506ddaf846f51f5575f1f30d6f0fca9b7b26f16e32675b322d014f8b68db76d5f5e WHIRLPOOL 1b210507fe1298b2b67caa496cedbe549923302d74aab51fe4eb2dae5fc0d0867099b4dbcd73eb733ca359decfcacd2e84046f6dee10034e973c7209ce30bb8f
-EBUILD lcs-0.2.ebuild 562 SHA256 2e0acf28c1635e5818934f9e36b4da5ba084528a3ee5de3e2ff93f587146b287 SHA512 22aea0b72a7211e7df9a560e991273a5ee7c1d0d82ebe89c2a218a581344b78409b0f699e638bdcf63b50eff0dead011445f48267d96c78d209fc3a69621d653 WHIRLPOOL 6cf3463ceece6c71715c0800b8f1bc5c518799dc63daba7508cdac64e2a42165fe23140e88aa6291293cd8e4dd8291c65a73403470e2b80d811f9493aca36cbe
+EBUILD lcs-0.2.ebuild 654 SHA256 644016009dfa9933f433a43b2933631e7d4475f847362a7171684a17329f3cd2 SHA512 829c95172017d92830eacc05cb70e70ef4dbc28c6c8c919612bd8d6f4e687abf09a38ab04e0ed49b51a0ff20813e090a6855efad5c58389b8d2bea90149ca5a8 WHIRLPOOL e71dee0e0686b8e3c3d383ccdc296163f9bf338b7b596a06a9bfe491b9329fb93707f283f932cddb4acaf4a5dfc0f388a43805c562fa7b68e309becfeaa7999a
+MISC ChangeLog 316 SHA256 031dae07938dd2c3580d2486b70a12b4e9217214a7f3b88b448918bfa4dd6cb5 SHA512 5ce8cb50299fc5545113513edc2e187df06655bf3eb209ff1c797d58469d075583545998cc26858affd314a8edb421523a07df67697ea87b3af86ac313e7e06d WHIRLPOOL 024c7eeedcffe98c4cc2c62216dc0891f6888875bb159954823f76956e3373e6fbe4bf5e65f729c8501a0e272f16f0bc02da67ab243659bb379bebffda451207
MISC metadata.xml 1089 SHA256 f58ae8d1ec4b4ee50c03cff176cce6b762fa916830a107815c9a73cfa1d058f3 SHA512 1afa0748094414a44b389457466de7b658faa40eb2323b26be473421a180a09587bab2032b6a43d464709e010c66049d9b27824fdd5489c7c1af440ef3d4f437 WHIRLPOOL 30b566d6de23b6acc08c5baa1586ee4c9ffcc4bb309eb70b330501c52dfe4405a9e89b040fc3068aff0ec02439e68346a867a97e46614d77328ea0b493811682
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iF4EAREIAAYFAlO1B5wACgkQoBEVQmGOlx9NeAD+LTvFBeeoqlDGwkP+sYdm8/hq
+NWNI4wp4VwztvXRpWmoA/RKwC1wqxDgaW5BlP7qQOqhGe4GclyMUI4jLwv3CpPIj
+=g1R7
+-----END PGP SIGNATURE-----
diff --git a/dev-haskell/lcs/lcs-0.2.ebuild b/dev-haskell/lcs/lcs-0.2.ebuild
new file mode 100644
index 000000000000..0c071f08b579
--- /dev/null
+++ b/dev-haskell/lcs/lcs-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lcs/lcs-0.2.ebuild,v 1.1 2014/07/03 07:34:46 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Find longest common sublist of two lists"
+HOMEPAGE="http://urchin.earth.li/~ian/cabal/lcs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
diff --git a/dev-haskell/lcs/metadata.xml b/dev-haskell/lcs/metadata.xml
new file mode 100644
index 000000000000..d4394fed6859
--- /dev/null
+++ b/dev-haskell/lcs/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Provides a function lcs that takes two lists and returns a longest
+ common sublist. For example, lcs &quot;abcd&quot; &quot;acbd&quot; is either &quot;abd&quot; or
+ &quot;acd&quot;.
+
+ The package provides a simple, stupid and (most of all) slow
+ implementation that needs, for inputs of length m and n, O(m+n)
+ space and O((m+n)!) time in the worst case.
+
+ It also provides an implementation of the Hunt-Szymanski LCS
+ algorithm, based on that in &quot;String searching algorithms&quot; by
+ Graham A Stephen, ISBN 981021829X.
+
+ Given inputs xs and ys of length m and n respectively, where there
+ are r pairs (x, y) where x is in xs, y is in ys and x == y,
+ Hunt-Szymanski needs O(r+m+n) space and O((r+m+n)*log(m+n)) time.
+ Thus this is O((m+n)^2) space and O((m+n)^2*log(m+n)) time in the
+ worst case.
+ </longdescription>
+</pkgmetadata>