summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:32:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:32:07 +0000
commit0d97d58166be4f10b0684eb6931446bda83ed8c4 (patch)
tree4dc643d445afc0655ea2b5cb87ae62c76e740377 /dev-haskell/http
parentInitial version. Haskell cryptographic functions (dev-haskell/hs3 depend) (diff)
downloadhistorical-0d97d58166be4f10b0684eb6931446bda83ed8c4.tar.gz
historical-0d97d58166be4f10b0684eb6931446bda83ed8c4.tar.bz2
historical-0d97d58166be4f10b0684eb6931446bda83ed8c4.zip
Version bump.
Package-Manager: portage-2.2.0_alpha77_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog7
-rw-r--r--dev-haskell/http/http-4000.1.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index 0d07721ef519..a8269db3a138 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.18 2011/06/05 13:50:00 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.19 2011/12/04 17:26:32 slyfox Exp $
+
+*http-4000.1.2 (04 Dec 2011)
+
+ 04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> +http-4000.1.2.ebuild:
+ Version bump.
05 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org> -http-2006.7.7.ebuild,
-http-3001.0.0.ebuild, -http-4000.0.5.ebuild, -http-4000.0.6.ebuild,
diff --git a/dev-haskell/http/http-4000.1.2.ebuild b/dev-haskell/http/http-4000.1.2.ebuild
new file mode 100644
index 000000000000..68073d6722ff
--- /dev/null
+++ b/dev-haskell/http/http-4000.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.1.2.ebuild,v 1.1 2011/12/04 17:26:32 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://projects.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/parsec
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"