summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
commit85c89a6a1e184e931c2ea612675ecda59bb299d3 (patch)
tree1664d9add2584720f897a268ab95f2b26fc8faa3 /dev-haskell/hdbc/hdbc-1.0.0.ebuild
parentStable on ppc. (diff)
downloadhistorical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.gz
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.bz2
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.zip
New 1.0 version of HDBC and backends.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'dev-haskell/hdbc/hdbc-1.0.0.ebuild')
-rw-r--r--dev-haskell/hdbc/hdbc-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-haskell/hdbc/hdbc-1.0.0.ebuild b/dev-haskell/hdbc/hdbc-1.0.0.ebuild
new file mode 100644
index 000000000000..1eb6f47fccc4
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-1.0.0.ebuild,v 1.1 2006/07/02 19:08:39 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="odbc postgres sqlite"
+
+DEPEND=">=virtual/ghc-6.4.1"
+
+PDEPEND="odbc? ( =dev-haskell/hdbc-odbc-${PV}* )
+ postgres? ( =dev-haskell/hdbc-postgresql-${PV}* )
+ sqlite? ( =dev-haskell/hdbc-sqlite-${PV}* )"
+
+S="${WORKDIR}/${PN}"