summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:30:12 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:30:12 +0000
commit5202731a95bb3391e7b26ce4a954871bf285d750 (patch)
treea3bd7b5c05981965132e5151ba8a98a7e7678cc1 /dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild
parentremove old versions (diff)
downloadhistorical-5202731a95bb3391e7b26ce4a954871bf285d750.tar.gz
historical-5202731a95bb3391e7b26ce4a954871bf285d750.tar.bz2
historical-5202731a95bb3391e7b26ce4a954871bf285d750.zip
New version.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild
new file mode 100644
index 000000000000..a90a97c10e95
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild,v 1.1 2007/12/13 17:21:21 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+MY_PN=HDBC-postgresql
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="PostgreSQL database driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-postgresql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=dev-lang/ghc-6.4.1
+ dev-haskell/mtl
+ =dev-haskell/hdbc-${hdbc_PV}*
+ >=dev-db/libpq-8"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack "${A}"
+
+ cp "${FILESDIR}/hdbc-postgresql-helper.h" "${FILESDIR}/pgtypes.h" "${S}/"
+ sed -i -e 's/GHC-Options: -O2 -Wall/GHC-Options: -fvia-C/' \
+ -e '/include-dirs:/d' \
+ -e '/^Extensions:/a \
+ , ForeignFunctionInterface' \
+ "${S}/${MY_PN}.cabal"
+ echo "include-dirs: $(pg_config --includedir)," >> "${S}/${MY_PN}.cabal"
+ echo " $(pg_config --includedir-server), ." >> "${S}/${MY_PN}.cabal"
+
+ if version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e '/Build-Depends:/a \
+ , old-time' \
+ "${S}/${MY_PN}.cabal"
+ fi
+}