summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-08 17:41:57 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-08 17:41:57 +0000
commit1fbc18b903c06187be3f7d09e77da4b5474f220e (patch)
tree389f5100b47a94bcad54757e95381ed40879436d /dev-haskell/cgi/cgi-3001.1.1.ebuild
parentVersion bump (diff)
downloadhistorical-1fbc18b903c06187be3f7d09e77da4b5474f220e.tar.gz
historical-1fbc18b903c06187be3f7d09e77da4b5474f220e.tar.bz2
historical-1fbc18b903c06187be3f7d09e77da4b5474f220e.zip
New version from ghc-6.6.1 extralibs collection.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-haskell/cgi/cgi-3001.1.1.ebuild')
-rw-r--r--dev-haskell/cgi/cgi-3001.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/cgi/cgi-3001.1.1.ebuild b/dev-haskell/cgi/cgi-3001.1.1.ebuild
new file mode 100644
index 000000000000..ab9cf67afbdb
--- /dev/null
+++ b/dev-haskell/cgi/cgi-3001.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-3001.1.1.ebuild,v 1.1 2007/07/08 17:34:20 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+GHC_PV=6.6.1
+
+DESCRIPTION="A haskell library for writing CGI programs"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6
+ >=dev-haskell/mtl-1.0
+ >=dev-haskell/xhtml-3000.0.0
+ >=dev-haskell/network-2.0"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
+src_unpack() {
+ unpack "${A}"
+ sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" ${S}/Setup.hs
+}