summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-09-13 13:06:02 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-09-13 13:06:02 +0000
commit5c709d22b8dad7553fe766a23e80010b8e546b5a (patch)
tree883c4da5e56383bf7d3e714d96c5eaae1612e86e /dev-haskell/cabal
parentnew eclass for Haskell packages that make use of the Common Architecture for ... (diff)
downloadhistorical-5c709d22b8dad7553fe766a23e80010b8e546b5a.tar.gz
historical-5c709d22b8dad7553fe766a23e80010b8e546b5a.tar.bz2
historical-5c709d22b8dad7553fe766a23e80010b8e546b5a.zip
New cabal version. The ebuild now makes use of the new haskell-cabal.eclass.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog8
-rw-r--r--dev-haskell/cabal/Manifest16
-rw-r--r--dev-haskell/cabal/cabal-0.5.ebuild85
-rw-r--r--dev-haskell/cabal/cabal-1.1.3.ebuild66
-rw-r--r--dev-haskell/cabal/files/digest-cabal-0.51
-rw-r--r--dev-haskell/cabal/files/digest-cabal-1.1.31
6 files changed, 87 insertions, 90 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index 37104bd8e63b..80abf06b6c3e 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.3 2005/05/04 16:32:31 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.4 2005/09/13 13:06:02 kosmikus Exp $
+
+*cabal-1.1.3 (13 Sep 2005)
+
+ 13 Sep 2005; Andres Loeh <kosmikus@gentoo.org> -cabal-0.5.ebuild,
+ +cabal-1.1.3.ebuild:
+ New cabal version. The ebuild now makes use of the new haskell-cabal.eclass.
04 May 2005; David Holm <dholm@gentoo.org> cabal-0.5.ebuild:
Added to ~ppc.
diff --git a/dev-haskell/cabal/Manifest b/dev-haskell/cabal/Manifest
index 708ff3b6db48..01aecb9a6e54 100644
--- a/dev-haskell/cabal/Manifest
+++ b/dev-haskell/cabal/Manifest
@@ -1,4 +1,14 @@
-MD5 403966346bebb245c88688d60885eca5 ChangeLog 517
-MD5 65b39882bf4d56091907f65c82513d93 cabal-0.5.ebuild 2188
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 3c21b65e582574bd7a17d301b7cf6168 cabal-1.1.3.ebuild 1854
+MD5 92dff080fa93f23c87cc176e34969fb1 ChangeLog 719
MD5 0b2872d51fdf7a2694dab3d34b57667d metadata.xml 232
-MD5 9d318d0c3adc5992247ee3f54ff9c5b6 files/digest-cabal-0.5 58
+MD5 b34aabec3ab15c7b74d940437870e91b files/digest-cabal-1.1.3 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDJs84OKSBj1ObwosRAizgAJ9/oPHVu99t3R/F9D6+0Dnuyk5r3wCbBBpg
+RiP4CcDnRECRMKdmr549cxM=
+=HN2u
+-----END PGP SIGNATURE-----
diff --git a/dev-haskell/cabal/cabal-0.5.ebuild b/dev-haskell/cabal/cabal-0.5.ebuild
deleted file mode 100644
index 49189059256f..000000000000
--- a/dev-haskell/cabal/cabal-0.5.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-0.5.ebuild,v 1.3 2005/05/04 16:32:31 dholm Exp $
-
-inherit ghc-package
-
-DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
-HOMEPAGE="http://haskell.org/cabal"
-SRC_URI="http://haskell.org/cabal/release/${P}.tgz"
-LICENSE="as-is"
-SLOT="0"
-
-KEYWORDS="~x86 ~ppc"
-
-IUSE="doc"
-
-DEPEND="${DEPEND}
- >=virtual/ghc-6.2"
-
-S="${WORKDIR}/${PN}"
-
-# The following functions exist because they are likely to be extracted
-# to an eclass when other Cabal-based packages are added to Portage.
-
-cabal-configure() {
- ./setup configure \
- --ghc --prefix=/usr \
- --with-compiler="$(ghc-getghc)" \
- --with-hc-pkg="$(ghc-getghcpkg)" \
- "$@" || die "setup configure failed"
-}
-
-cabal-build() {
- ./setup build \
- || die "setup build failed"
-}
-
-cabal-copy() {
- ./setup copy \
- --copy-prefix="${D}/usr" \
- || die "setup copy failed"
-}
-
-cabal-pkg() {
- ./setup register \
- --gen-script \
- || die "setup register failed"
- if ghc-cabal; then
- # ghc supports Cabal; however, ghc-6.4 ships a slightly
- # broken version, which we fix here
- sed -i "s|update *$|update .installed-pkg-config|" register.sh
- fi
- # we want to manually build ghci-libs, so we remove the flag;
- # instead, we force the issue and write to the local config file
- # rather than the global one (which would cause an access violation
- # at this point anyway)
- sed -i "s|--auto-ghci-libs\(.*\)$|--force \1 -f\\\\|" \
- register.sh
- echo "${S}/$(ghc-localpkgconf)" >> register.sh
- ghc-setup-pkg
- ./register.sh
- ghc-install-pkg
-}
-
-src_compile() {
- # bootstrap: build setup
- make HC="$(ghc-getghc)" setup || die "make setup failed"
- # cabal-style configure and compile
- cabal-configure
- cabal-build
-}
-
-src_install() {
- cabal-copy
- ghc-makeghcilib ${D}/usr/lib/Cabal-${PV}/libHSCabal-${PV}.a
- cabal-pkg
- # documentation (install directly; generation seems broken to me atm)
- dohtml -r doc/users-guide
- if use doc; then
- dohtml -r doc/API
- dohtml -r doc/pkg-spec-html
- dodoc doc/pkg-spec.pdf
- fi
- dodoc changelog copyright README releaseNotes TODO
-}
diff --git a/dev-haskell/cabal/cabal-1.1.3.ebuild b/dev-haskell/cabal/cabal-1.1.3.ebuild
new file mode 100644
index 000000000000..b1609406c39d
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.3.ebuild,v 1.1 2005/09/13 13:06:02 kosmikus Exp $
+
+CABAL_FEATURES="bootstrap"
+inherit haskell-cabal eutils base
+
+DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
+HOMEPAGE="http://haskell.org/cabal"
+SRC_URI="http://haskell.org/cabal/release/rc/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="doc"
+
+DEPEND=">=virtual/ghc-6.2"
+
+MY_PV="${PV/_pre*/}"
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ base_src_unpack
+
+ # Grrr, Cabal build-depends on the util package which is one of the old
+ # hslibs packages. Exposing util breaks lots of things. Fortunately cabal
+ # doesn't actually use anything fro util so we can remove it. A patch has
+ # been sent upstream so remove this hack on the next cabal iteration.
+ # Update: Seems that solving this upstream causes problems on Windows, so
+ # this hack will remain for now.
+ if $(ghc-cabal); then
+ sed -i 's/Build-Depends: base, util/Build-Depends: base/' ${S}/Cabal.cabal
+ else
+ sed -i 's/Build-Depends: base, util/Build-Depends: base, unix/' ${S}/Cabal.cabal
+ fi
+}
+
+src_compile() {
+ make setup HC="$(ghc-getghc) -ignore-package Cabal"
+ cabal-configure
+ cabal-build
+}
+
+src_install() {
+ cabal_src_install
+
+ # documentation (install directly; generation seems broken to me atm)
+ dohtml -r doc/users-guide
+ if use doc; then
+ dohtml -r doc/API
+ dohtml -r doc/pkg-spec-html
+ dodoc doc/pkg-spec.pdf
+ fi
+ dodoc changelog copyright README releaseNotes TODO
+}
+
+pkg_postinst () {
+ if ghc-cabal && ghc-package-exists "Cabal-1.0"; then
+ ebegin "Unregistering ghc's built-in cabal "
+ $(ghc-getghcpkg) unregister "Cabal-1.0" > /dev/null
+ eend $?
+ fi
+ ghc-package_pkg_postinst
+}
+
diff --git a/dev-haskell/cabal/files/digest-cabal-0.5 b/dev-haskell/cabal/files/digest-cabal-0.5
deleted file mode 100644
index c3ea655579dd..000000000000
--- a/dev-haskell/cabal/files/digest-cabal-0.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 76be68429fe6034c28356d8c8205b7fc cabal-0.5.tgz 354557
diff --git a/dev-haskell/cabal/files/digest-cabal-1.1.3 b/dev-haskell/cabal/files/digest-cabal-1.1.3
new file mode 100644
index 000000000000..444d8b18b2f5
--- /dev/null
+++ b/dev-haskell/cabal/files/digest-cabal-1.1.3
@@ -0,0 +1 @@
+MD5 9cf10b6067a7cedf0559bf4a3dabef3c cabal-1.1.3.tar.gz 382024