summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-04 07:32:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-04 07:32:57 +0000
commite70e41225ace2c650c9e53df7c5505c4acab9b24 (patch)
tree9ae1e69326c4f22e72764cd679f3152a9c6a342e /dev-games/vamos/files
parentalphabetical order!. (diff)
downloadhistorical-e70e41225ace2c650c9e53df7c5505c4acab9b24.tar.gz
historical-e70e41225ace2c650c9e53df7c5505c4acab9b24.tar.bz2
historical-e70e41225ace2c650c9e53df7c5505c4acab9b24.zip
initial import
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-games/vamos/files')
-rw-r--r--dev-games/vamos/files/digest-vamos-0.5.41
-rw-r--r--dev-games/vamos/files/vamos-0.5.4-datadir.patch42
-rw-r--r--dev-games/vamos/files/vamos-0.5.4-gcc.patch21
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-games/vamos/files/digest-vamos-0.5.4 b/dev-games/vamos/files/digest-vamos-0.5.4
new file mode 100644
index 000000000000..477ba4e133ce
--- /dev/null
+++ b/dev-games/vamos/files/digest-vamos-0.5.4
@@ -0,0 +1 @@
+MD5 c6247a0b70583d021b6dbec10609c67d vamos-0.5.4.tar.gz 1465833
diff --git a/dev-games/vamos/files/vamos-0.5.4-datadir.patch b/dev-games/vamos/files/vamos-0.5.4-datadir.patch
new file mode 100644
index 000000000000..1acdf7b6d224
--- /dev/null
+++ b/dev-games/vamos/files/vamos-0.5.4-datadir.patch
@@ -0,0 +1,42 @@
+Don't hardcode the data paths, use the info from configure.
+
+--- vamos/vamos.cc
++++ vamos/vamos.cc
+@@ -143,7 +143,7 @@
+ if (check)
+ return path;
+ }
+- path = "/usr/local/share/vamos/" + section + "/" + file + ".xml";
++ path = DATADIR "/" + section + "/" + file + ".xml";
+ {
+ std::ifstream check (path.c_str ());
+ if (check)
+@@ -202,7 +202,7 @@
+
+ // How I can I get this automatically set to the configured data
+ // directory?
+- data_dir = "/usr/local/share/vamos/";
++ data_dir = DATADIR "/";
+ try
+ {
+ Texture_Image test_tex (data_dir + "textures/wall.png");
+@@ -210,7 +210,7 @@
+ catch (Missing_Texture_File)
+ {
+ std::cerr << "Couldn't find the data direcory ../data, or "
+- << "/usr/local/share/vamos/."
++ << DATADIR "/."
+ << std::endl;
+ std::exit (EXIT_FAILURE);
+ }
+--- vamos/Makefile.in
++++ vamos/Makefile.in
+@@ -154,7 +154,7 @@
+ `pkg-config --cflags sigc++-1.2`
+
+
+-AM_CXXFLAGS = -Wall -pedantic -O1 -g -gstabs+
++AM_CXXFLAGS = -Wall -pedantic -O1 -g -gstabs+ -DDATADIR=\"$(pkgdatadir)\"
+ subdir = vamos
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
diff --git a/dev-games/vamos/files/vamos-0.5.4-gcc.patch b/dev-games/vamos/files/vamos-0.5.4-gcc.patch
new file mode 100644
index 000000000000..dc9c97ae5c46
--- /dev/null
+++ b/dev-games/vamos/files/vamos-0.5.4-gcc.patch
@@ -0,0 +1,21 @@
+Compile with newer gcc versions
+
+--- track/Strip_Track.cc
++++ track/Strip_Track.cc
+@@ -181,14 +181,14 @@
+ fixed (false),
+ vertical_field_angle (10.0),
+ range (range_in)
+-{};
++{}
+
+ Camera::Camera ()
+ : segment_index (0),
+ fixed (false),
+ vertical_field_angle (10.0),
+ range (0.0)
+-{};
++{}
+
+ //* Class Strip_Track
+ Strip_Track::Strip_Track () :