summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-07-25 01:02:39 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-07-25 01:02:39 +0000
commitf98f685181449d59d78528e71d38720da0cd1c63 (patch)
tree6c6f8d05e8bef315ff4619bb8dc0bb4969a98c3a /dev-dotnet/pnet/pnet-0.5.8.ebuild
parentmove to dev-dotnet (diff)
downloadhistorical-f98f685181449d59d78528e71d38720da0cd1c63.tar.gz
historical-f98f685181449d59d78528e71d38720da0cd1c63.tar.bz2
historical-f98f685181449d59d78528e71d38720da0cd1c63.zip
move to dev-dotnet
Diffstat (limited to 'dev-dotnet/pnet/pnet-0.5.8.ebuild')
-rw-r--r--dev-dotnet/pnet/pnet-0.5.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-dotnet/pnet/pnet-0.5.8.ebuild b/dev-dotnet/pnet/pnet-0.5.8.ebuild
new file mode 100644
index 000000000000..3c46e74ee7de
--- /dev/null
+++ b/dev-dotnet/pnet/pnet-0.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/pnet-0.5.8.ebuild,v 1.1 2003/07/25 01:02:02 scandium Exp $
+
+DESCRIPTION="Portable .NET runtime, compiler, tools"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="mirror://gnu/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE=""
+
+DEPEND=">=dev-util/treecc-0.2.4"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README
+ dodoc doc/gtk-sharp.HOWTO
+ dohtml doc/*.html
+
+ # init script
+ exeinto /etc/init.d ; newexe ${PORTDIR}/dev-lang/mono/files/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${PORTDIR}/dev-lang/mono/files/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}