summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-25 14:22:25 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-25 14:22:25 +0000
commit456b9afd9513b58ff4139710ed62704c24cd50ef (patch)
tree94f83e52baae79e0e00ce73414a823d22b280b65 /dev-dotnet/notify-sharp
parentmonodoc is a build-time dep. (diff)
downloadhistorical-456b9afd9513b58ff4139710ed62704c24cd50ef.tar.gz
historical-456b9afd9513b58ff4139710ed62704c24cd50ef.tar.bz2
historical-456b9afd9513b58ff4139710ed62704c24cd50ef.zip
Initial import. Ebuild adapted from the one in ikelos' overlay. Bug 235111.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64
Diffstat (limited to 'dev-dotnet/notify-sharp')
-rw-r--r--dev-dotnet/notify-sharp/ChangeLog11
-rw-r--r--dev-dotnet/notify-sharp/Manifest4
-rw-r--r--dev-dotnet/notify-sharp/metadata.xml5
-rw-r--r--dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild38
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/ChangeLog b/dev-dotnet/notify-sharp/ChangeLog
new file mode 100644
index 000000000000..574d1b14dcf7
--- /dev/null
+++ b/dev-dotnet/notify-sharp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-dotnet/notify-sharp
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/notify-sharp/ChangeLog,v 1.1 2008/11/25 14:22:25 loki_val Exp $
+
+*notify-sharp-0.4.0_pre20080912 (25 Nov 2008)
+
+ 25 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> +metadata.xml,
+ +notify-sharp-0.4.0_pre20080912.ebuild:
+ Initial import. Ebuild adapted from the one in ikelos' overlay. Bug
+ 235111.
+
diff --git a/dev-dotnet/notify-sharp/Manifest b/dev-dotnet/notify-sharp/Manifest
new file mode 100644
index 000000000000..c15f589f2ee9
--- /dev/null
+++ b/dev-dotnet/notify-sharp/Manifest
@@ -0,0 +1,4 @@
+DIST notify-sharp-20080912.tar.bz2 14326 RMD160 2387412dcab0572fbde024fc6150c42c6fb25588 SHA1 9db76682f1971fe2b4989d783e1b3d408d8f7bb7 SHA256 72574e04e4c8e262da5f94fa086cf3578e97ad2b84d602959ac6e488710a1a9c
+EBUILD notify-sharp-0.4.0_pre20080912.ebuild 934 RMD160 1de7704bd5caad204a9b71668050762ed665cbce SHA1 5cd232bcd7326a67be18232b8c44b3ebdf1b363a SHA256 49666f6afa2dfd305f77ad6250a1aeb17c206b64564abaa74e8501b7fead57b4
+MISC ChangeLog 459 RMD160 249d6bfce4f972583afd51327c98e6720dded6d1 SHA1 a52354a5b997f2a13b2e6727284ae32827cfaeb9 SHA256 6a3d907ead2132f6b83bfb9e22fee001b98a289012590f42aa1379363406d450
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/dev-dotnet/notify-sharp/metadata.xml b/dev-dotnet/notify-sharp/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/notify-sharp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild
new file mode 100644
index 000000000000..a7c8fb4b271f
--- /dev/null
+++ b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20080912.ebuild,v 1.1 2008/11/25 14:22:25 loki_val Exp $
+
+EAPI=2
+
+inherit autotools mono
+
+MY_P=${PN}-${PV#*_pre}
+
+DESCRIPTION="notify-sharp is a C# client implementation for Desktop Notifications"
+HOMEPAGE="http://www.ndesk.org/NotifySharp"
+SRC_URI="http://cvs.fedora.redhat.com/repo/pkgs/${PN}/${MY_P}.tar.bz2/098f3cde158cf26d3efedbfcc19c70dd/${MY_P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-1.1.13
+ >=dev-dotnet/gtk-sharp-2.10.1
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-glib-sharp-0.4"
+DEPEND="${RDEPEND}
+ dev-util/monodoc"
+
+S=${WORKDIR}/${MY_P}
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+