summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 16:45:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 16:45:05 +0000
commite8ce9505a74221d0b635854176e971cb88502b50 (patch)
tree3e8e813810745a70d9e8fad77fcb9bc31f766eac /dev-db
parentUse EAPI="3". (diff)
downloadhistorical-e8ce9505a74221d0b635854176e971cb88502b50.tar.gz
historical-e8ce9505a74221d0b635854176e971cb88502b50.tar.bz2
historical-e8ce9505a74221d0b635854176e971cb88502b50.zip
Delete older ebuilds.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.22-interix-fixes.patch22
-rw-r--r--dev-db/sqlite/files/sqlite-3.7.3-icu_tests.patch284
-rw-r--r--dev-db/sqlite/files/sqlite-3.7.4-utimes.patch35
-rw-r--r--dev-db/sqlite/sqlite-3.7.2.ebuild158
-rw-r--r--dev-db/sqlite/sqlite-3.7.3.ebuild155
-rw-r--r--dev-db/sqlite/sqlite-3.7.4.ebuild155
6 files changed, 0 insertions, 809 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.6.22-interix-fixes.patch b/dev-db/sqlite/files/sqlite-3.6.22-interix-fixes.patch
deleted file mode 100644
index dae98fd653a0..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.22-interix-fixes.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ru sqlite-3.6.22.orig/src/os_unix.c sqlite-3.6.22/src/os_unix.c
---- sqlite-3.6.22.orig/src/os_unix.c 2010-01-15 09:00:06 +0100
-+++ sqlite-3.6.22/src/os_unix.c 2010-01-15 09:01:42 +0100
-@@ -436,7 +436,9 @@
- case ENODEV:
- case ENXIO:
- case ENOENT:
-+#ifdef ESTALE
- case ESTALE:
-+#endif
- case ENOSYS:
- /* these should force the client to close the file and reconnect */
-
-@@ -1862,7 +1864,7 @@
- pFile->locktype = locktype;
- #if !OS_VXWORKS
- /* Always update the timestamp on the old file */
-- utimes(zLockFile, NULL);
-+ utime(zLockFile, NULL);
- #endif
- return SQLITE_OK;
- }
diff --git a/dev-db/sqlite/files/sqlite-3.7.3-icu_tests.patch b/dev-db/sqlite/files/sqlite-3.7.3-icu_tests.patch
deleted file mode 100644
index 9e8b77a21efa..000000000000
--- a/dev-db/sqlite/files/sqlite-3.7.3-icu_tests.patch
+++ /dev/null
@@ -1,284 +0,0 @@
---- test/e_expr.test
-+++ test/e_expr.test
-@@ -937,8 +937,14 @@
- # 'a'&nbsp;LIKE&nbsp;'A' is TRUE but
- # '&aelig;'&nbsp;LIKE&nbsp;'&AElig;' is FALSE.
- #
-+# The restriction to ASCII characters does not apply if the ICU
-+# library is compiled in. When ICU is enabled SQLite does not act
-+# as it does "by default".
-+#
- do_execsql_test e_expr-14.5.1 { SELECT 'A' LIKE 'a' } 1
--do_execsql_test e_expr-14.5.2 "SELECT '\u00c6' LIKE '\u00e6'" 0
-+ifcapable !icu {
-+ do_execsql_test e_expr-14.5.2 "SELECT '\u00c6' LIKE '\u00e6'" 0
-+}
-
- # EVIDENCE-OF: R-56683-13731 If the optional ESCAPE clause is present,
- # then the expression following the ESCAPE keyword must evaluate to a
-@@ -985,7 +991,8 @@
- eval lappend ::likeargs $args
- return 1
- }
--db func like likefunc
-+db func like -argcount 2 likefunc
-+db func like -argcount 3 likefunc
- set ::likeargs [list]
- do_execsql_test e_expr-15.1.1 { SELECT 'abc' LIKE 'def' } 1
- do_test e_expr-15.1.2 { set likeargs } {def abc}
-@@ -1056,12 +1063,16 @@
- # default and so use of the REGEXP operator will normally result in an
- # error message.
- #
--do_catchsql_test e_expr-18.1.1 {
-- SELECT regexp('abc', 'def')
--} {1 {no such function: regexp}}
--do_catchsql_test e_expr-18.1.2 {
-- SELECT 'abc' REGEXP 'def'
--} {1 {no such function: REGEXP}}
-+# There is a regexp function if ICU is enabled though.
-+#
-+ifcapable !icu {
-+ do_catchsql_test e_expr-18.1.1 {
-+ SELECT regexp('abc', 'def')
-+ } {1 {no such function: regexp}}
-+ do_catchsql_test e_expr-18.1.2 {
-+ SELECT 'abc' REGEXP 'def'
-+ } {1 {no such function: REGEXP}}
-+}
-
- # EVIDENCE-OF: R-33693-50180 The REGEXP operator is a special syntax for
- # the regexp() user function.
---- test/like.test
-+++ test/like.test
-@@ -115,7 +115,7 @@
- proc test_regexp {a b} {
- return [regexp $a $b]
- }
-- db function regexp test_regexp
-+ db function regexp -argcount 2 test_regexp
- execsql {
- SELECT x FROM t1 WHERE x REGEXP 'abc' ORDER BY 1;
- }
-@@ -608,7 +608,7 @@
- } {1 abcdef 1 ghijkl 1 mnopqr 2 abcdef 2 ghijkl 2 mnopqr}
-
-
--ifcapable like_opt {
-+ifcapable like_opt&&!icu {
- # Evaluate SQL. Return the result set followed by the
- # and the number of full-scan steps.
- #
-@@ -673,110 +673,110 @@
- regexp {INDEX i2} $res
- } {1}
- }
--}
--
--# Do an SQL statement. Append the search count to the end of the result.
--#
--proc count sql {
-- set ::sqlite_search_count 0
-- set ::sqlite_like_count 0
-- return [concat [execsql $sql] scan $::sqlite_search_count \
-- like $::sqlite_like_count]
--}
-
--# The LIKE and GLOB optimizations do not work on columns with
--# affinity other than TEXT.
--# Ticket #3901
--#
--do_test like-10.1 {
-- db close
-- sqlite3 db test.db
-- execsql {
-- CREATE TABLE t10(
-- a INTEGER PRIMARY KEY,
-- b INTEGER COLLATE nocase UNIQUE,
-- c NUMBER COLLATE nocase UNIQUE,
-- d BLOB COLLATE nocase UNIQUE,
-- e COLLATE nocase UNIQUE,
-- f TEXT COLLATE nocase UNIQUE
-- );
-- INSERT INTO t10 VALUES(1,1,1,1,1,1);
-- INSERT INTO t10 VALUES(12,12,12,12,12,12);
-- INSERT INTO t10 VALUES(123,123,123,123,123,123);
-- INSERT INTO t10 VALUES(234,234,234,234,234,234);
-- INSERT INTO t10 VALUES(345,345,345,345,345,345);
-- INSERT INTO t10 VALUES(45,45,45,45,45,45);
-- }
-- count {
-- SELECT a FROM t10 WHERE b LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.2 {
-- count {
-- SELECT a FROM t10 WHERE c LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.3 {
-- count {
-- SELECT a FROM t10 WHERE d LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.4 {
-- count {
-- SELECT a FROM t10 WHERE e LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.5 {
-- count {
-- SELECT a FROM t10 WHERE f LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 3 like 0}
--do_test like-10.6 {
-- count {
-- SELECT a FROM t10 WHERE a LIKE '12%' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.10 {
-- execsql {
-- CREATE TABLE t10b(
-- a INTEGER PRIMARY KEY,
-- b INTEGER UNIQUE,
-- c NUMBER UNIQUE,
-- d BLOB UNIQUE,
-- e UNIQUE,
-- f TEXT UNIQUE
-- );
-- INSERT INTO t10b SELECT * FROM t10;
-- }
-- count {
-- SELECT a FROM t10b WHERE b GLOB '12*' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.11 {
-- count {
-- SELECT a FROM t10b WHERE c GLOB '12*' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.12 {
-- count {
-- SELECT a FROM t10b WHERE d GLOB '12*' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.13 {
-- count {
-- SELECT a FROM t10b WHERE e GLOB '12*' ORDER BY a;
-- }
--} {12 123 scan 5 like 6}
--do_test like-10.14 {
-- count {
-- SELECT a FROM t10b WHERE f GLOB '12*' ORDER BY a;
-- }
--} {12 123 scan 3 like 0}
--do_test like-10.15 {
-- count {
-- SELECT a FROM t10b WHERE a GLOB '12*' ORDER BY a;
-+ # Do an SQL statement. Append the search count to the end of the result.
-+ #
-+ proc count sql {
-+ set ::sqlite_search_count 0
-+ set ::sqlite_like_count 0
-+ return [concat [execsql $sql] scan $::sqlite_search_count \
-+ like $::sqlite_like_count]
- }
--} {12 123 scan 5 like 6}
-+
-+ # The LIKE and GLOB optimizations do not work on columns with
-+ # affinity other than TEXT.
-+ # Ticket #3901
-+ #
-+ do_test like-10.1 {
-+ db close
-+ sqlite3 db test.db
-+ execsql {
-+ CREATE TABLE t10(
-+ a INTEGER PRIMARY KEY,
-+ b INTEGER COLLATE nocase UNIQUE,
-+ c NUMBER COLLATE nocase UNIQUE,
-+ d BLOB COLLATE nocase UNIQUE,
-+ e COLLATE nocase UNIQUE,
-+ f TEXT COLLATE nocase UNIQUE
-+ );
-+ INSERT INTO t10 VALUES(1,1,1,1,1,1);
-+ INSERT INTO t10 VALUES(12,12,12,12,12,12);
-+ INSERT INTO t10 VALUES(123,123,123,123,123,123);
-+ INSERT INTO t10 VALUES(234,234,234,234,234,234);
-+ INSERT INTO t10 VALUES(345,345,345,345,345,345);
-+ INSERT INTO t10 VALUES(45,45,45,45,45,45);
-+ }
-+ count {
-+ SELECT a FROM t10 WHERE b LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.2 {
-+ count {
-+ SELECT a FROM t10 WHERE c LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.3 {
-+ count {
-+ SELECT a FROM t10 WHERE d LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.4 {
-+ count {
-+ SELECT a FROM t10 WHERE e LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.5 {
-+ count {
-+ SELECT a FROM t10 WHERE f LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 3 like 0}
-+ do_test like-10.6 {
-+ count {
-+ SELECT a FROM t10 WHERE a LIKE '12%' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.10 {
-+ execsql {
-+ CREATE TABLE t10b(
-+ a INTEGER PRIMARY KEY,
-+ b INTEGER UNIQUE,
-+ c NUMBER UNIQUE,
-+ d BLOB UNIQUE,
-+ e UNIQUE,
-+ f TEXT UNIQUE
-+ );
-+ INSERT INTO t10b SELECT * FROM t10;
-+ }
-+ count {
-+ SELECT a FROM t10b WHERE b GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.11 {
-+ count {
-+ SELECT a FROM t10b WHERE c GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.12 {
-+ count {
-+ SELECT a FROM t10b WHERE d GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.13 {
-+ count {
-+ SELECT a FROM t10b WHERE e GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+ do_test like-10.14 {
-+ count {
-+ SELECT a FROM t10b WHERE f GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 3 like 0}
-+ do_test like-10.15 {
-+ count {
-+ SELECT a FROM t10b WHERE a GLOB '12*' ORDER BY a;
-+ }
-+ } {12 123 scan 5 like 6}
-+}
-
- # LIKE and GLOB where the default collating sequence is not appropriate
- # but an index with the appropriate collating sequence exists.
diff --git a/dev-db/sqlite/files/sqlite-3.7.4-utimes.patch b/dev-db/sqlite/files/sqlite-3.7.4-utimes.patch
deleted file mode 100644
index ddfa0451326a..000000000000
--- a/dev-db/sqlite/files/sqlite-3.7.4-utimes.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.ac
-+++ configure.ac
-@@ -127,7 +127,7 @@
- #########
- # Figure out whether or not we have these functions
- #
--AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s])
-+AC_CHECK_FUNCS([usleep utimes fdatasync localtime_r gmtime_r localtime_s])
-
- #########
- # By default, we use the amalgamation (this may be changed below...)
---- src/os_unix.c
-+++ src/os_unix.c
-@@ -120,6 +120,9 @@
- #include <sys/time.h>
- #include <errno.h>
- #include <sys/mman.h>
-+#ifndef HAVE_UTIMES
-+#include <utime.h>
-+#endif
-
- #if SQLITE_ENABLE_LOCKING_STYLE
- # include <sys/ioctl.h>
-@@ -1608,7 +1611,11 @@
- pFile->eFileLock = eFileLock;
- #if !OS_VXWORKS
- /* Always update the timestamp on the old file */
-+#ifdef HAVE_UTIMES
- utimes(zLockFile, NULL);
-+#else
-+ utime(zLockFile, NULL);
-+#endif
- #endif
- return SQLITE_OK;
- }
diff --git a/dev-db/sqlite/sqlite-3.7.2.ebuild b/dev-db/sqlite/sqlite-3.7.2.ebuild
deleted file mode 100644
index fc70dd2c2b6a..000000000000
--- a/dev-db/sqlite/sqlite-3.7.2.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.2.ebuild,v 1.9 2010/11/14 12:41:45 armin76 Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- local amalgamation=false
- use !tcl && use !test && amalgamation=true
-
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if ${amalgamation}; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Enable unlock notification
- if use unlock-notify; then
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
- fi
-
- local extensions_option
- if ${amalgamation}; then
- extensions_option="dynamic-extensions"
- else
- extensions_option="load-extension"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(${amalgamation} || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(${amalgamation} || use_enable debug) \
- $(${amalgamation} || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.7.3.ebuild b/dev-db/sqlite/sqlite-3.7.3.ebuild
deleted file mode 100644
index 478710c9041b..000000000000
--- a/dev-db/sqlite/sqlite-3.7.3.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.3.ebuild,v 1.5 2011/02/27 12:01:59 klausman Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha ~amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- epatch "${FILESDIR}/${P}-icu_tests.patch"
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- local amalgamation=false
- use !tcl && use !test && amalgamation=true
-
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if ${amalgamation}; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Enable unlock notification
- if use unlock-notify; then
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
- fi
-
- local extensions_option
- if ${amalgamation}; then
- extensions_option="dynamic-extensions"
- else
- extensions_option="load-extension"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(${amalgamation} || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(${amalgamation} || use_enable debug) \
- $(${amalgamation} || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.7.4.ebuild b/dev-db/sqlite/sqlite-3.7.4.ebuild
deleted file mode 100644
index 2725483e4ad0..000000000000
--- a/dev-db/sqlite/sqlite-3.7.4.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.4.ebuild,v 1.1 2010/12/12 19:32:45 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-MY_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/${PN}-doc-${MY_PV}.zip )
- tcl? ( http://sqlite.org/${PN}-src-${MY_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/${PN}-src-${MY_PV}.zip )
- !test? ( http://sqlite.org/${PN}-autoconf-${MY_PV}.tar.gz )
- )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${MY_PV}"
- else
- S="${WORKDIR}/${PN}-src-${MY_PV}"
- fi
-}
-
-src_prepare() {
- if amalgamation; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- else
- epatch "${FILESDIR}/${P}-utimes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch"
- fi
-
- eautoreconf
- epunt_cxx
-}
-
-src_configure() {
- # `configure` from amalgamation tarball doesn't add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # Enable unlock notification
- if use unlock-notify; then
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
- fi
-
- local extensions_option
- if amalgamation; then
- extensions_option="dynamic-extensions"
- else
- extensions_option="load-extension"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -eq "0" ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install || die "emake install failed"
- doman sqlite3.1 || die "doman failed"
-
- if use doc; then
- dohtml -r "${WORKDIR}/${PN}-doc-${MY_PV}/"* || die "dohtml failed"
- fi
-}