summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMeir Kriheili <mksoft@gentoo.org>2004-04-03 22:54:57 +0000
committerMeir Kriheili <mksoft@gentoo.org>2004-04-03 22:54:57 +0000
commitd893934248c2f9b2d9b9d0dc38f845626b2763d0 (patch)
tree9639ceafbcf7f21223e3709e0d048f9b6688bb31 /dev-db
parentmodified dev-db/firebird classic to inetd as suggested by spider (diff)
downloadhistorical-d893934248c2f9b2d9b9d0dc38f845626b2763d0.tar.gz
historical-d893934248c2f9b2d9b9d0dc38f845626b2763d0.tar.bz2
historical-d893934248c2f9b2d9b9d0dc38f845626b2763d0.zip
Modified classic local USE flag, changed to inetd
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/firebird/ChangeLog6
-rw-r--r--dev-db/firebird/Manifest4
-rw-r--r--dev-db/firebird/firebird-1.5.0.ebuild22
3 files changed, 23 insertions, 9 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
index 7ac0ff71579e..e3fca71e9497 100644
--- a/dev-db/firebird/ChangeLog
+++ b/dev-db/firebird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/firebird
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.13 2004/03/31 00:35:47 mksoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.14 2004/04/03 22:54:57 mksoft Exp $
+
+ 04 Apr 2004; <mksoft@gentoo.org> firebird-1.5.0.ebuild:
+ Modified classic local USE flag, changed to inetd
+ Added a warning to disable older xinetd server (if SuperServer is used)
31 Mar 2004; <mksoft@gentoo.org> firebird-1.5.0.ebuild, files/firebird.conf.d,
files/firebird.init.d:
diff --git a/dev-db/firebird/Manifest b/dev-db/firebird/Manifest
index add030f219ce..a7ed492c9d6f 100644
--- a/dev-db/firebird/Manifest
+++ b/dev-db/firebird/Manifest
@@ -1,6 +1,6 @@
-MD5 b0fb8195452edcaafa081b3900390cde firebird-1.5.0.ebuild 5505
+MD5 d29d4c8c778caba4930066b36bce3017 firebird-1.5.0.ebuild 5882
MD5 2a414f60bbeb886ed74788d465c3e7e5 firebird-1.0-r1.ebuild 1384
-MD5 39d0b94dccbf57ded9e9783728d6f0a8 ChangeLog 2171
+MD5 2963fbe93247118e0b076be86fc605c2 ChangeLog 2356
MD5 b6d46d544ce131eb681e0d7e68a465cc metadata.xml 623
MD5 448427a1721b322e21af6781e8d0ec1e firebird-1.0.3.ebuild 2607
MD5 d795330e017a7f1afb99a0bbf69eaeb3 files/firebird-1.0.3-gentoo.patch 1661
diff --git a/dev-db/firebird/firebird-1.5.0.ebuild b/dev-db/firebird/firebird-1.5.0.ebuild
index 79192ce04a8d..b46b872b5cfe 100644
--- a/dev-db/firebird/firebird-1.5.0.ebuild
+++ b/dev-db/firebird/firebird-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.2 2004/03/31 00:35:47 mksoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.3 2004/04/03 22:54:57 mksoft Exp $
DESCRIPTION="A relational database offering many ANSI SQL-92 features"
extra_ver="4290"
@@ -10,9 +10,9 @@ HOMEPAGE="http://firebird.sourceforge.net/"
SLOT="0"
LICENSE="MPL-1.1"
KEYWORDS="~x86"
-IUSE="classic"
+IUSE="inetd"
DEPEND="virtual/glibc
- classic? ( virtual/inetd )"
+ inetd? ( virtual/inetd )"
RESTRICT="nouserpriv"
inherit flag-o-matic
@@ -24,7 +24,7 @@ src_compile() {
myconf="${myconf} --prefix=/opt/firebird"
myconf="${myconf} --with-editline"
- [ -z "`use classic`" ] && myconf="${myconf} --enable-superserver"
+ [ -z "`use inetd`" ] && myconf="${myconf} --enable-superserver"
./autogen.sh ${myconf} || die "couldn't run autogen.sh"
make || die "error during make"
}
@@ -49,7 +49,7 @@ src_install() {
rm -r ${D}/opt/firebird/{README,WhatsNew,doc,misc}
rm -r ${D}/opt/firebird/examples
- if [ -n "`use classic`" ]; then
+ if [ -n "`use inetd`" ]; then
insinto /etc/xinetd.d ; newins ${FILESDIR}/${P}.xinetd firebird
else
exeinto /etc/init.d ; newexe ${FILESDIR}/${PN}.init.d firebird
@@ -75,7 +75,7 @@ src_install() {
chmod a=rx isql
chmod a=rx qli
- [ -n "`use classic`" ] && chmod ug=rxs,o= ${D}/opt/firebird/bin/{fb_lock_mgr,gds_drop,fb_inet_server}
+ [ -n "`use inetd`" ] && chmod ug=rxs,o= ${D}/opt/firebird/bin/{fb_lock_mgr,gds_drop,fb_inet_server}
chmod u=rw,go=r ${D}/opt/firebird/{aliases.conf,firebird.conf}
chmod ug=rw,o= ${D}/opt/firebird/{security.fdb,help/help.fdb}
@@ -106,6 +106,16 @@ pkg_postinst() {
einfo " set permissions to firebird:firebird on databases you "
einfo " already have (if any)."
einfo
+
+ if [ -z "`use inetd`" ]
+ then
+ einfo "3. You've built the stand alone deamon version,"
+ einfo " SuperServer. If you were using pre 1.5.0 ebuilds"
+ einfo " you're probably have one installed via xinetd. please"
+ einfo " remember to disable it (usually in /etc/xinetd.d/firebird),"
+ einfo " since the current one has it's own init script under"
+ einfo " /etc/init.d"
+ fi
}
pkg_config() {