summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-12-02 01:33:48 +0000
committerPreston A. Elder <prez@gentoo.org>2002-12-02 01:33:48 +0000
commitac1fc60ab3cc9b9d7cde3192f829816e6f4f8d53 (patch)
tree67b5b6a2414504a712dec27c5d87f472ee63080c /dev-db
parentChanged SRC_URI (diff)
downloadhistorical-ac1fc60ab3cc9b9d7cde3192f829816e6f4f8d53.tar.gz
historical-ac1fc60ab3cc9b9d7cde3192f829816e6f4f8d53.tar.bz2
historical-ac1fc60ab3cc9b9d7cde3192f829816e6f4f8d53.zip
Added PostgreSQL 7.3.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog17
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.31
-rw-r--r--dev-db/postgresql/postgresql-7.3.ebuild170
3 files changed, 182 insertions, 6 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index e9093da510d8..792a6d7e656b 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,22 +1,27 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.42 2002/11/26 23:19:24 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.43 2002/12/02 01:33:48 prez Exp $
+
+*postgresql-7.3 (1 Dec 2002)
+
+ 01 Dec 2002: Preston A. Elder <prez@gentoo.org> postgresql-7.3.ebuild:
+ Added new version, also stopped forcing Java 1.3, 1.4 works fine now.
+
+*postgresql-7.2.3-r1 (27 Oct 2002)
26 Nov 2002; Mark Guertin <gerk@gentoo.org> postgresql-7.2.3-r1.ebuild:
forced CFLAGS="-pipe -fsigned-char", any more aggressive optimizations
cause failures on ppc
+ 26 Nov 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.2.3-r1.ebuild :
+ Notified the user to give the postgres user a /bin/bash or /bin/true account
+
25 Nov 2002; Mark Guertin <gerk@gentoo.org> portgresql-7.2.3.ebuild,
portgresql-7.2.3-r1.ebuild:
Set -ppc to all the 7.2.3 builds, none of them even compile on
ppc, please please check with devs before upgrading new pkgs
that are untested to stable ;)
-*postgresql-7.2.3-r1 (27 Oct 2002)
-
- 26 Nov 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.2.3-r1.ebuild :
- Notified the user to give the postgres user a /bin/bash or /bin/true account
-
14 Nov 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.2.3-r1.ebuild :
Fixed location that is printed out
diff --git a/dev-db/postgresql/files/digest-postgresql-7.3 b/dev-db/postgresql/files/digest-postgresql-7.3
new file mode 100644
index 000000000000..fa750243282b
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.3
@@ -0,0 +1 @@
+MD5 3981f3c5c8ebe9d1e1b2e66229f1803a postgresql-7.3.tar.gz 11059455
diff --git a/dev-db/postgresql/postgresql-7.3.ebuild b/dev-db/postgresql/postgresql-7.3.ebuild
new file mode 100644
index 000000000000..3540ed000e17
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.3.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.ebuild,v 1.1 2002/12/02 01:33:48 prez Exp $
+
+IUSE="ssl nls java python tcltk perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.postgresql.org"
+LICENSE="POSTGRESQL"
+KEYWORDS="x86 ppc"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ app-admin/sudo
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+# java dep workaround for portage bug
+# x86? ( java? ( =virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+SLOT="0"
+
+PG_DIR="/var/lib/postgresql"
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use java && myconf="$myconf --with-java"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-locale --enable-nls --enable-multibyte"
+ use libg++ && myconf="$myconf --with-CXX"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-pam \
+ --with-maxbackends=1024 \
+ $myconf || die
+
+
+ make || die
+ cd contrib
+ make || die
+}
+
+src_install () {
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ dodoc contrib/adddepend/*
+ cd ${S}/doc
+ dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
+ dodoc TODO internals.ps bug.template
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto sgml/graphics
+ dodoc src/graphics/*
+ rm -rf ${D}/usr/doc ${D}/mnt
+ exeinto /usr/bin
+
+ if [ `use java` ]; then
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ fi
+
+ dodir /usr/include/postgresql/pgsql
+ cp ${D}/usr/include/*.h ${D}/usr/include/postgresql/pgsql
+
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/${PV}/${PN}
+
+ exeinto /etc/conf.d/
+ doexe ${FILESDIR}/postgresql
+}
+
+pkg_postinst() {
+ einfo ">>> Execute the following command"
+ einfo ">>> ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo ">>> to setup the initial database environment."
+ einfo ">>> "
+ einfo ">>> Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell, or /bin/true"
+}
+
+
+pkg_config() {
+ einfo ">>> Creating data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres.postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo ">>> Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ else
+ einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
+ einfo "Read the documentation to check how to upgrade to version ${PV}."
+ fi
+ else
+ sudo -u postgres /usr/bin/initdb --pgdata ${PG_DIR}/data
+ einfo "If you are upgrading from a pre-7.3 version of PostgreSQL, please read"
+ einfo "the README.adddepend file for information on how to properly migrate"
+ einfo "all serial columns, unique keys and foreign keys to this version."
+ fi
+}