summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-02-11 05:18:57 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-02-11 05:18:57 +0000
commit1fc8e1fd44a946c79aef963c17eda7bc03a488d8 (patch)
tree5b2d78a90d15f86b1a76c8ab9d760a4504f2b939 /dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
parentupdate maintainer (diff)
downloadhistorical-1fc8e1fd44a946c79aef963c17eda7bc03a488d8.tar.gz
historical-1fc8e1fd44a946c79aef963c17eda7bc03a488d8.tar.bz2
historical-1fc8e1fd44a946c79aef963c17eda7bc03a488d8.zip
added X autoconf patch from bug #35570
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..6ea949529f3a
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild,v 1.1 2004/02/11 05:18:55 rphillips Exp $
+
+DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64 ~sparc"
+IUSE="qt gtk"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-3.0* )"
+
+# the configure.in patch is required for 'use qt'
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+# braindead check in configure fails - hack approach
+ epatch ${FILESDIR}/${P}-configure.in.patch
+
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
+
+ if [ "`use gtk`" ]
+ then
+ cd gODBCConfig
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ # not sure why these symlinks are needed. busted configure, i guess...
+ ln -s ../depcomp .
+ ln -s ../libtool .
+ make || die
+ cd ..
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ "`use gtk`" ]
+ then
+ cd gODBCConfig
+ make DESTDIR=${D} install || die
+ cd ..
+ fi
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
+ prepalldocs
+}