summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-11 23:32:48 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-11 23:32:48 +0000
commit009f187e913d8885e7396ef23a8f6911f338fce2 (patch)
treea0f89854f7a8ebd1f0b58f6650377ab26134f571 /dev-db/sqsh
parentPrompted per Bug #10070, version bump plus cleanup of ebuild. Not (diff)
downloadhistorical-009f187e913d8885e7396ef23a8f6911f338fce2.tar.gz
historical-009f187e913d8885e7396ef23a8f6911f338fce2.tar.bz2
historical-009f187e913d8885e7396ef23a8f6911f338fce2.zip
New package. x86 mask
Diffstat (limited to 'dev-db/sqsh')
-rw-r--r--dev-db/sqsh/ChangeLog10
-rw-r--r--dev-db/sqsh/files/config.patch22
-rw-r--r--dev-db/sqsh/files/digest-sqsh-2.11
-rw-r--r--dev-db/sqsh/sqsh-2.1.ebuild64
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-db/sqsh/ChangeLog b/dev-db/sqsh/ChangeLog
new file mode 100644
index 000000000000..4388eba6e9be
--- /dev/null
+++ b/dev-db/sqsh/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/sqsh
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/ChangeLog,v 1.1 2002/12/11 23:32:48 rphillips Exp $
+
+*sqsh-2.1 (11 Dec 2002)
+
+ 11 Dec 2002; Sean Summers <ebuild@generalprotectionfault.com> sqsh-2.1.ebuild :
+
+ Initial package
+ Had to patch src/config.h with a config.h from sqsh-1.7; configure is broken.
diff --git a/dev-db/sqsh/files/config.patch b/dev-db/sqsh/files/config.patch
new file mode 100644
index 000000000000..5127afda8686
--- /dev/null
+++ b/dev-db/sqsh/files/config.patch
@@ -0,0 +1,22 @@
+60c60
+< /* #undef HAVE_STRERROR */
+---
+> #define HAVE_STRERROR 1
+62,67c62,67
+< /* #undef HAVE_STRFTIME */
+< /* #undef HAVE_MEMCPY */
+< /* #undef HAVE_MEMMOVE */
+< /* #undef HAVE_LOCALTIME */
+< /* #undef HAVE_TIMELOCAL */
+< /* #undef HAVE_STRCHR */
+---
+> #define HAVE_STRFTIME 1
+> #define HAVE_MEMCPY 1
+> #define HAVE_MEMMOVE 1
+> #define HAVE_LOCALTIME 1
+> #define HAVE_TIMELOCAL 1
+> #define HAVE_STRCHR 1
+69c69
+< /* #undef HAVE_GETTIMEOFDAY */
+---
+> #define HAVE_GETTIMEOFDAY 1
diff --git a/dev-db/sqsh/files/digest-sqsh-2.1 b/dev-db/sqsh/files/digest-sqsh-2.1
new file mode 100644
index 000000000000..a1f69b1943e2
--- /dev/null
+++ b/dev-db/sqsh/files/digest-sqsh-2.1
@@ -0,0 +1 @@
+MD5 a9d75ae51eafd94f89640f99ee3a9918 sqsh-2.1-src.tar.gz 358874
diff --git a/dev-db/sqsh/sqsh-2.1.ebuild b/dev-db/sqsh/sqsh-2.1.ebuild
new file mode 100644
index 000000000000..9f6c438592b3
--- /dev/null
+++ b/dev-db/sqsh/sqsh-2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1.ebuild,v 1.1 2002/12/11 23:32:48 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Replacement for the venerable 'isql' program supplied by Sybase."
+HOMEPAGE="http://www.sqsh.org/"
+LICENSE="GPL"
+DEPEND="dev-db/freetds
+ readline? ( sys-libs/readline )
+ X? ( x11-base/xfree )
+ motif? ( x11-libs/openmotif )
+ sys-devel/ld.so
+ virtual/glibc"
+RDEPEND="dev-db/freetds
+ readline? ( sys-libs/readline )
+ X? ( x11-base/xfree )
+ motif? ( x11-libs/openmotif )
+ sys-devel/ld.so
+ virtual/glibc"
+SLOT="0"
+SRC_URI="http://www.sqsh.org/${P}-src.tar.gz"
+KEYWORDS="x86"
+
+src_compile() {
+ export SYBASE=/usr
+
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline"
+
+ use X \
+ && myconf="${myconf} --with-x"
+
+ use motif \
+ && myconf="${myconf} --with-motif"
+
+ ./configure \
+ ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ patch src/config.h ${FILESDIR}/config.patch
+
+ emake SQSHRC_GLOBAL=/etc/sqshrc || die
+}
+
+src_install () {
+ make \
+ DESTDIR=${D} \
+ RPM_BUILD_ROOT=${D} \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install install.man || die
+ # fix the silly placement of sqshrc
+ mkdir -p ${D}/etc
+ mv ${D}/usr/etc/sqshrc ${D}/etc/
+ rmdir ${D}/usr/etc
+ dodoc COPYING INSTALL README doc/*
+}