summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-03-29 16:22:23 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-03-29 16:22:23 +0000
commit904d6186ab0cdcab9fb2a9789b325b3cd7b20ced (patch)
treec752887713b7a65343498b472d250c9acd0a59b4 /dev-db/sqlite
parentIUSE fix (diff)
downloadhistorical-904d6186ab0cdcab9fb2a9789b325b3cd7b20ced.tar.gz
historical-904d6186ab0cdcab9fb2a9789b325b3cd7b20ced.tar.bz2
historical-904d6186ab0cdcab9fb2a9789b325b3cd7b20ced.zip
new version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/Manifest4
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.2.11
-rw-r--r--dev-db/sqlite/sqlite-3.2.1.ebuild62
4 files changed, 72 insertions, 2 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 5579f2354910..013872437a11 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.70 2005/03/24 15:55:23 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.71 2005/03/29 16:22:23 arj Exp $
+
+*sqlite-3.2.1 (29 Mar 2005)
+
+ 29 Mar 2005; Anders Rune Jensen <arj@gentoo.org> +sqlite-3.2.1.ebuild:
+ New version. Fixes #86858.
*sqlite-3.2.0 (24 Mar 2005)
diff --git a/dev-db/sqlite/Manifest b/dev-db/sqlite/Manifest
index a9c41f8f672d..37a7fb4898f1 100644
--- a/dev-db/sqlite/Manifest
+++ b/dev-db/sqlite/Manifest
@@ -2,17 +2,19 @@ MD5 4d4bfa913883e6229573e79b6f02aa3b metadata.xml 275
MD5 78d3fa35ae4558e4a5add1fd47fd814f sqlite-2.8.15.ebuild 969
MD5 fdbecebdb331496cd81f02ea4487e430 sqlite-2.8.13.ebuild 843
MD5 53101d0aba85e7f9f18c84aada8466cf sqlite-3.0.8.ebuild 1020
+MD5 7952f271c0a054604a64ddd21aa51d87 sqlite-3.2.1.ebuild 1889
MD5 529fd03eceab183a8c3dea72741c7266 sqlite-3.0.6.ebuild 1046
MD5 5cbea2bc70699b7a68bf442f4d6a2622 sqlite-3.1.3.ebuild 1890
MD5 c2c8c2607bf7e784464bf8b6c17f5972 sqlite-3.1.5.ebuild 1889
MD5 8cda692208b4f43344d30e5bfa2ee396 sqlite-2.8.16.ebuild 1402
-MD5 cd454d6cab30c47302f27046d7969a8b ChangeLog 9611
+MD5 5cf76e968d81934b743afaf41a9d1266 ChangeLog 9743
MD5 c0c61638e3f6d70263748a5db601414d sqlite-3.1.2.ebuild 1882
MD5 99bf2a671c91f7499255003439d5eac0 sqlite-2.8.14.ebuild 862
MD5 f29cd1d06dca071985256cb325d2b380 sqlite-3.0.7.ebuild 995
MD5 8c6d9f1b14b238affe69ab822d635cd8 sqlite-3.1.6.ebuild 1889
MD5 006d5e8c0eb41234ac90294b6fd93f2d sqlite-3.0.8-r1.ebuild 1817
MD5 1713c41127f7021bfab73771fa38e323 sqlite-3.2.0.ebuild 1889
+MD5 9dce926cc47853cb563ab467d1c5ba28 files/digest-sqlite-3.2.1 65
MD5 c9c200833c7c14eb4d750bb00455199e files/digest-sqlite-2.8.14 65
MD5 2a35fca391c8617c26b2934d02b8fcb5 files/digest-sqlite-3.1.3 65
MD5 c35f34620d18893001720951f8ea0c73 files/digest-sqlite-2.8.13 65
diff --git a/dev-db/sqlite/files/digest-sqlite-3.2.1 b/dev-db/sqlite/files/digest-sqlite-3.2.1
new file mode 100644
index 000000000000..8c837fc3ade7
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.2.1
@@ -0,0 +1 @@
+MD5 ccf3831c2f67452d444c5e5e2c7ca6f0 sqlite-3.2.1.tar.gz 1351842
diff --git a/dev-db/sqlite/sqlite-3.2.1.ebuild b/dev-db/sqlite/sqlite-3.2.1.ebuild
new file mode 100644
index 000000000000..3c51d1a04191
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1.ebuild,v 1.1 2005/03/29 16:22:23 arj Exp $
+
+inherit eutils
+
+IUSE="nls nothreadsafe"
+
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+HOMEPAGE="http://www.sqlite.org"
+
+# Adding glibc as dependency for USE !nothreadsafe until someone can tell me
+# if all virtual/libc's provide POSIX threads (pthread.h)
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+DEPEND="virtual/libc
+ !nothreadsafe? ( !ppc-macos? ( sys-libs/glibc ) )
+ dev-lang/tcl"
+SLOT="3"
+LICENSE="as-is"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+
+src_compile() {
+ # sqlite includes a doc directory making it impossible to generate docs,
+ # which are very important to people adding support for sqlite3 to their
+ # programs.
+ rm -rf doc/
+
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ # Yes, this is ridiculous, but I'm not the maintainer for this ebuild,
+ # and yet it's broken w/o thread support, so this has to do for now
+ # - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+ if ! use nothreadsafe; then
+ myconf="${myconf} --enable-threadsafe"
+ else
+ myconf="${myconf} --disable-threadsafe"
+ fi
+ myconf="${myconf} `use_with nls utf8`"
+ myconf="--with-tcl=/usr/$(get_libdir)/"
+ econf ${myconf} || die
+ emake all || die # doc is not working yet in 3.1.2
+}
+
+# In case we ever want testing support; note: this needs more work, as
+# as it causes some sandbox issues.
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+#src_test() {
+# cd ${S}
+# emake fulltest || die "some test failed"
+#}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}