summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-12-04 00:12:44 +0000
committerPreston A. Elder <prez@gentoo.org>2002-12-04 00:12:44 +0000
commitffcf7d49c9301c8ccd2cbaaa446e82e60405090a (patch)
tree7faede44333390340bb66c9030bc27f24ca6337f /dev-db/postgresql
parentMarked stable (diff)
downloadhistorical-ffcf7d49c9301c8ccd2cbaaa446e82e60405090a.tar.gz
historical-ffcf7d49c9301c8ccd2cbaaa446e82e60405090a.tar.bz2
historical-ffcf7d49c9301c8ccd2cbaaa446e82e60405090a.zip
Forgot to add the 7.3 directory with the init script.
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/ChangeLog5
-rw-r--r--dev-db/postgresql/files/7.3/postgresql27
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 792a6d7e656b..8e4eb8dc0a38 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.43 2002/12/02 01:33:48 prez Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.44 2002/12/04 00:12:38 prez Exp $
*postgresql-7.3 (1 Dec 2002)
+ 03 Dec 2002: Preston A. Elder <prez@gentoo.org> files/7.3/postgresql:
+ Forgot the init script, added now.
+
01 Dec 2002: Preston A. Elder <prez@gentoo.org> postgresql-7.3.ebuild:
Added new version, also stopped forcing Java 1.3, 1.4 works fine now.
diff --git a/dev-db/postgresql/files/7.3/postgresql b/dev-db/postgresql/files/7.3/postgresql
new file mode 100644
index 000000000000..e40f2fc37485
--- /dev/null
+++ b/dev-db/postgresql/files/7.3/postgresql
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.rc6,v 1.1 2002/01/06 00:53:24 woodchip Exp
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart () {
+ ebegin "Restarting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+