summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2006-07-23 11:12:37 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2006-07-23 11:12:37 +0000
commit2f9ea3f63e0b6dcc62f9866f825379d32e21a0ea (patch)
tree27ed45d4ca80e795daec092b8eac878e6dc9da39 /dev-db/oracle-instantclient-jdbc
parentppc stable, bug #140369 (diff)
downloadhistorical-2f9ea3f63e0b6dcc62f9866f825379d32e21a0ea.tar.gz
historical-2f9ea3f63e0b6dcc62f9866f825379d32e21a0ea.tar.bz2
historical-2f9ea3f63e0b6dcc62f9866f825379d32e21a0ea.zip
Version bump, bug #141269
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog8
-rw-r--r--dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.53
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.5.ebuild47
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index 62af06d20009..7a5ceea7cbe5 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.13 2006/06/06 20:33:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.14 2006/07/23 11:11:07 dertobi123 Exp $
+
+*oracle-instantclient-jdbc-10.1.0.5 (23 Jul 2006)
+
+ 23 Jul 2006; Tobias Scherbaum <dertobi123@gentoo.org>
+ +oracle-instantclient-jdbc-10.1.0.5.ebuild:
+ Version bump, bug #141269
06 Jun 2006; Markus Rothe <corsair@gentoo.org>
oracle-instantclient-jdbc-10.2.0.2.ebuild:
diff --git a/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.5 b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.5
new file mode 100644
index 000000000000..94bd826d90d1
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.5
@@ -0,0 +1,3 @@
+MD5 827d9cb471cdf7baf89fc8ad19800ef6 instantclient-jdbc-linux32-10.1.0.5-20060511.zip 4649614
+RMD160 70548a63b32c045278c38b04020c289d0eaf461b instantclient-jdbc-linux32-10.1.0.5-20060511.zip 4649614
+SHA256 02be60be9c4d0fa4a705537056a15444922472d7c65440a66b471439cba6f190 instantclient-jdbc-linux32-10.1.0.5-20060511.zip 4649614
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.5.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.5.ebuild
new file mode 100644
index 000000000000..51338f748860
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.5.ebuild,v 1.1 2006/07/23 11:11:07 dertobi123 Exp $
+
+inherit eutils
+
+MY_P="${PN/oracle-/}-linux32-${PV}-20060511"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="OTN"
+SLOT="${PV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip ${DISTDIR}/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/lib/oracle/${PV}/client/lib
+ cd ${S}/instantclient10_1
+ insinto /usr/lib/oracle/${PV}/client/lib
+ doins libheteroxa10.so ocrs12.jar orai18n.jar
+}
+
+pkg_postinst() {
+ einfo "The JDBC supplement package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-sqlplus (for "
+ einfo "running the SQL*Plus application) package as well."
+}