summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-28 00:49:13 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-28 00:49:13 +0000
commit57bb0523dc5ba61a65de315f7154b4d1ac485669 (patch)
tree9f63c723e1be60866bb46706e1037ea6d6876711 /dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild
parentBug #86514, fix DEPEND. Also add metadata. (diff)
downloadhistorical-57bb0523dc5ba61a65de315f7154b4d1ac485669.tar.gz
historical-57bb0523dc5ba61a65de315f7154b4d1ac485669.tar.bz2
historical-57bb0523dc5ba61a65de315f7154b4d1ac485669.zip
Bug #86514, fix DEPEND. Also add metadata.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild')
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..b8c1be08a781
--- /dev/null
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.7.1-r1.ebuild,v 1.1 2005/03/28 00:48:16 robbat2 Exp $
+
+DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+LICENSE="LGPL-2.1"
+DEPEND="dev-db/libdbi
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( <dev-db/sqlite-3 )"
+
+IUSE="mysql postgres sqlite oci8"
+KEYWORDS="~x86 ~ppc ~amd64"
+SLOT=0
+
+src_compile() {
+ local myconf=""
+ local drivers=""
+# WARNING: the configure script does NOT work correctly
+# --without-$driver does NOT work
+# so do NOT use `use_with...`
+ use mysql && drivers="${drivers} mysql" myconf="${myconf} --with-mysql"
+ use postgres && drivers="${drivers} pgsql" myconf="${myconf} --with-pgsql"
+ use sqlite && drivers="${drivers} sqlite" myconf="${myconf} --with-sqlite"
+ if use oci8; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ die "\$ORACLE_HOME is not set!"
+ fi
+ myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle" drivers="${drivers} oracle"
+ fi
+# safety check
+ if [ -z "${drivers}" ]; then
+ die "You have not specified any supported databases in your use flags (mysql, pgsql, sqlite, oracle)"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README README.osx TODO
+}