summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-12-07 03:26:21 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-12-07 03:26:21 +0000
commit1f08b775df2eac5f84b6c5b3c168aabd0f4d2022 (patch)
treec40e2e317c909a3e736f1fffe7fc1833c37c9e1f /dev-cpp
parentback out ia64 (diff)
downloadhistorical-1f08b775df2eac5f84b6c5b3c168aabd0f4d2022.tar.gz
historical-1f08b775df2eac5f84b6c5b3c168aabd0f4d2022.tar.bz2
historical-1f08b775df2eac5f84b6c5b3c168aabd0f4d2022.zip
Bump bump bumpety bump.
Package-Manager: portage-2.0.53 I can kill you with my brain edition
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libebt/ChangeLog7
-rw-r--r--dev-cpp/libebt/Manifest14
-rw-r--r--dev-cpp/libebt/files/digest-libebt-1.0.01
-rw-r--r--dev-cpp/libebt/libebt-1.0.0.ebuild28
4 files changed, 48 insertions, 2 deletions
diff --git a/dev-cpp/libebt/ChangeLog b/dev-cpp/libebt/ChangeLog
index eb11ed243fc7..b4480249d112 100644
--- a/dev-cpp/libebt/ChangeLog
+++ b/dev-cpp/libebt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libebt
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.2 2005/11/29 03:05:35 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.3 2005/12/07 03:26:21 ciaranm Exp $
+
+*libebt-1.0.0 (07 Dec 2005)
+
+ 07 Dec 2005; Ciaran McCreesh <ciaranm@gentoo.org> +libebt-1.0.0.ebuild:
+ Version bump.
29 Nov 2005; Jason Wever <weeve@gentoo.org> libebt-0.8.2.ebuild:
Added ~sparc keyword by popular request.
diff --git a/dev-cpp/libebt/Manifest b/dev-cpp/libebt/Manifest
index d8ff3b131078..d7f3237aa110 100644
--- a/dev-cpp/libebt/Manifest
+++ b/dev-cpp/libebt/Manifest
@@ -1,4 +1,16 @@
-MD5 b3bb33138651774ca75e6f158197deaa ChangeLog 447
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 612c7707b1528af023eb96a6ccf57b76 ChangeLog 569
MD5 4d2a12dae8034b77b03aeadb458749fb files/digest-libebt-0.8.2 65
+MD5 33ade160899e118891f9bf551561985b files/digest-libebt-1.0.0 65
MD5 183cd478ae666881e85b9db4f8192d8a libebt-0.8.2.ebuild 804
+MD5 828320126b0e5e2ea54e59c8dd745e53 libebt-1.0.0.ebuild 828
MD5 49b5ca6a324b8f95eba6721c1e5e7793 metadata.xml 582
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDllZsLLFUmVNQ7rkRAsIjAKCUnWZ8wltqR67KP/iGWjfa7sO10gCeOVru
+OeyXgZfKBTQJP0WHV4IlvlI=
+=YCjY
+-----END PGP SIGNATURE-----
diff --git a/dev-cpp/libebt/files/digest-libebt-1.0.0 b/dev-cpp/libebt/files/digest-libebt-1.0.0
new file mode 100644
index 000000000000..7f4cc6ace8ca
--- /dev/null
+++ b/dev-cpp/libebt/files/digest-libebt-1.0.0
@@ -0,0 +1 @@
+MD5 df44b8077765409483886a6e13cda52f libebt-1.0.0.tar.bz2 140104
diff --git a/dev-cpp/libebt/libebt-1.0.0.ebuild b/dev-cpp/libebt/libebt-1.0.0.ebuild
new file mode 100644
index 000000000000..b52f8187f2e7
--- /dev/null
+++ b/dev-cpp/libebt/libebt-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/libebt-1.0.0.ebuild,v 1.1 2005/12/07 03:26:21 ciaranm Exp $
+
+DESCRIPTION="A pure C++ template library that provides a clean way of getting human-readable backtrace messages."
+HOMEPAGE="http://libebt.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+RESTRICT="primaryuri"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ use doc && { emake doxygen || die "failed to build API docs" ; }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README
+ use doc && dohtml -r doc/html/*
+}