summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2009-03-26 11:55:54 +0000
committerGeorge Shapovalov <george@gentoo.org>2009-03-26 11:55:54 +0000
commit0ff7c76d3b8f674b7ea536e114fe42f4fce05888 (patch)
tree7492861878cc45a1385e74abb695b42208817052 /dev-ada/glade
parentMake the ebuild actualy work. I dont see how it could be marked stable since ... (diff)
downloadhistorical-0ff7c76d3b8f674b7ea536e114fe42f4fce05888.tar.gz
historical-0ff7c76d3b8f674b7ea536e114fe42f4fce05888.tar.bz2
historical-0ff7c76d3b8f674b7ea536e114fe42f4fce05888.zip
fixed collisions (#250064)
Package-Manager: portage-2.2_rc27/cvs/Linux x86_64
Diffstat (limited to 'dev-ada/glade')
-rw-r--r--dev-ada/glade/ChangeLog5
-rw-r--r--dev-ada/glade/Manifest4
-rw-r--r--dev-ada/glade/glade-2006.0.ebuild14
3 files changed, 18 insertions, 5 deletions
diff --git a/dev-ada/glade/ChangeLog b/dev-ada/glade/ChangeLog
index 5a097dd9f548..4c535fc85e92 100644
--- a/dev-ada/glade/ChangeLog
+++ b/dev-ada/glade/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ada/glade
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/ChangeLog,v 1.4 2009/03/26 10:05:49 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/ChangeLog,v 1.5 2009/03/26 11:55:54 george Exp $
+
+ 26 Mar 2009; George Shapovalov <george@gentoo.org> glade-2006.0.ebuild:
+ fixed collisions (#250064)
26 Mar 2009; George Shapovalov <george@gentoo.org> glade-2006.0.ebuild:
limited DEPEND to Ada-95 compilers (#250064)
diff --git a/dev-ada/glade/Manifest b/dev-ada/glade/Manifest
index f4109c4268f2..1c6e2d4713c0 100644
--- a/dev-ada/glade/Manifest
+++ b/dev-ada/glade/Manifest
@@ -1,4 +1,4 @@
DIST glade-2006.0.tar.bz2 393969 RMD160 478e8082febce36d0997e76c793d534b3789ee65 SHA1 378c97b2db45de633b0bc462f48ae73fad4b89c7 SHA256 0a0ef4b7aeb426b4b298b38fcdb9d7236b56a9c5aa6d16c24745450587b6ef85
-EBUILD glade-2006.0.ebuild 2408 RMD160 c1728e422d18b9d433c5c79bc6270819fe293e4f SHA1 bdf7b4d42991917bdc492bd43c4a00c15d26f5ca SHA256 35f0fbed62282c3239560c0261af2f1656cadedbae06288dc49e218fc834e0ee
-MISC ChangeLog 742 RMD160 8ffafe79a9e7e0b56397bd998eca7ec3871df671 SHA1 64ed8d1e8a29223da14f75efdc10b18e855437a9 SHA256 f5bb33c940433a6f7b5d29a1ab77d443c1d23b100e9ec139455b8ac528434d90
+EBUILD glade-2006.0.ebuild 2652 RMD160 7e2d36ba51ab4932f2d0fbcf68695ede09671be3 SHA1 26ea42097452f0f84f3178ef472054722f2a0866 SHA256 bce23e9ccf672b352db1be7b2ec559051cf29b9dba623d39df46cf6e4b3ef52a
+MISC ChangeLog 846 RMD160 1aa864ec0b332eb927fbbbbffba0d90a9cb29d06 SHA1 c8f0f621c0ce339cd4a44403982d9a528c018687 SHA256 e2fe7fcdd23ed6c98778854914e1419d36a29c8bd8b5bcf397ea05551c835ade
MISC metadata.xml 156 RMD160 176ce2ddfa15a21eb2b752633f3514cc3640749e SHA1 de9b70211ac77fb8e22706d4e968b04a634f65f2 SHA256 34f8bec858b5da24b0fc4d703932bf225d4ee545f13cc253e42d8bc84956dbec
diff --git a/dev-ada/glade/glade-2006.0.ebuild b/dev-ada/glade/glade-2006.0.ebuild
index bcc9aba4b7af..15e1acb01986 100644
--- a/dev-ada/glade/glade-2006.0.ebuild
+++ b/dev-ada/glade/glade-2006.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/glade-2006.0.ebuild,v 1.5 2009/03/26 10:05:49 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/glade-2006.0.ebuild,v 1.6 2009/03/26 11:55:54 george Exp $
inherit gnat
@@ -39,7 +39,7 @@ lib_compile()
# NOTE: we are using $1 - the passed gnat profile name
lib_install()
{
- # This package expands the libs and sources rovided by compiler. Therefore
+ # This package expands the libs and sources provided by compiler. Therefore
# we install in yet another local location, to bypass gnat's automation.
# The compiler specific stuf is then moved to ${D} directly. Not ideal, as
# this hook is called from within src_compile, but alternatives are more
@@ -58,6 +58,16 @@ lib_install()
mkdir -p "${DN}/${Gnat_Incdir}"
mv "${DN}/lib/garlic"/*.ad? "${DN}/${Gnat_Incdir}"
rm -rf "${DN}/lib"
+
+ # remove files already provided by compiler
+ pushd "${DN}"
+ for fn in "${Gnat_Libdir:1}"/*.ali "${Gnat_Incdir:1}"/*.ad?; do
+ # Gnat_Lib/Incdir are global, need to remove leading /
+ if [[ -e /${fn} ]]; then
+ rm -f ${fn}
+ fi
+ done
+ popd
}
src_install ()