summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-20 08:10:15 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-20 08:10:15 +0000
commit22f1e96a6c6e368ad7c24405cb251ce7ed505376 (patch)
treed325deaf240fb26da09080d5ff7f06d57aef6d35 /app-vim
parentpkg-config is still needed for USE=test, and USE=test will trigger circular d... (diff)
downloadhistorical-22f1e96a6c6e368ad7c24405cb251ce7ed505376.tar.gz
historical-22f1e96a6c6e368ad7c24405cb251ce7ed505376.tar.bz2
historical-22f1e96a6c6e368ad7c24405cb251ce7ed505376.zip
Initial import.
Package-Manager: portage-2.2.0_alpha33/cvs/Linux x86_64
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gist/ChangeLog10
-rw-r--r--app-vim/gist/Manifest18
-rw-r--r--app-vim/gist/gist-4.9.ebuild29
-rw-r--r--app-vim/gist/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/gist/ChangeLog b/app-vim/gist/ChangeLog
new file mode 100644
index 000000000000..67aa14bcc0a0
--- /dev/null
+++ b/app-vim/gist/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/gist
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gist/ChangeLog,v 1.1 2011/05/20 08:10:15 radhermit Exp $
+
+*gist-4.9 (20 May 2011)
+
+ 20 May 2011; Tim Harder <radhermit@gentoo.org> +gist-4.9.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/gist/Manifest b/app-vim/gist/Manifest
new file mode 100644
index 000000000000..a63e51d20bb9
--- /dev/null
+++ b/app-vim/gist/Manifest
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST gist-4.9.tar.bz2 6285 RMD160 00387718667a808e6c7fd8a54839ab62bf575e90 SHA1 7565ececadbebe64e17212680269e09b88799682 SHA256 304ea8237ab11e733aa723631d510e705049e8e8d2ee9403eb5ee86550dec5cb
+EBUILD gist-4.9.ebuild 877 RMD160 740721510abe03947b5f5e75918b2345610d497e SHA1 98e98c74e9cf38a07d2987a1ec2c8b9c81011e23 SHA256 2595f1a131a46ed108b3dffe10cdf870b5bf399c42ac342c98aa7d873393e487
+MISC ChangeLog 328 RMD160 8cac0f8a656b2bd4e4d5822c4783f40bf97ee428 SHA1 0b38716228b7bd2072ce79462e1dcd1302c790f6 SHA256 961a9317646d9246cdc287631fac21d33e215ebfca966bf5152292461b781e9b
+MISC metadata.xml 157 RMD160 adcd6494e1e562ab5e0bd090e114622782ac753a SHA1 22983b8e9ba3045d8ccbc2b14393423f7f05d2ee SHA256 106c8618581360c66c2b535fcb7a6cb9ff318f1bd8e6c8f40f2f2f2d54e6787a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iQEcBAEBAgAGBQJN1iHtAAoJEEqz6FtPBkyjoM8H/0DPQwtyE8YRbo8CLos/QQpr
+j9My9kPhkmMHeYvlc5ZF2gCsuDsZ2fv9653wU9PWghk7Wc11rznPCT9U3U5xoK4S
+bopywF9ZGoR3Vuwcw0MSZpLtj4wFYydwe/wzsijUDmyLm8FG1CSYOQhMeDUxSIji
+c4vuAzZaiJbIIJIfSSh4VvSGwbQ9kDVg8ZnKekB+8mVN+Y+jWi6autKNEQG+a/hw
+TxjRhkC4NtM4cTSux27YUArn9CkRnulKIA4dgH9aYFxhxQd3daJP/P28m1sm0xrN
+jowJXyHb0+7S2o+dQns/qVRBTK+/MaNGeANvexYxvI1pZKBJ+lY7guxHaBiIBFI=
+=uqzB
+-----END PGP SIGNATURE-----
diff --git a/app-vim/gist/gist-4.9.ebuild b/app-vim/gist/gist-4.9.ebuild
new file mode 100644
index 000000000000..04e4c6d4b5ee
--- /dev/null
+++ b/app-vim/gist/gist-4.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gist/gist-4.9.ebuild,v 1.1 2011/05/20 08:10:15 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/curl
+ dev-vcs/git"
+
+VIM_PLUGIN_HELPFILES="gist.txt"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/"=\+$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/gist.vim \
+ > doc/gist.txt
+}
diff --git a/app-vim/gist/metadata.xml b/app-vim/gist/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/gist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>