summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2004-04-27 12:03:45 +0000
committerWout Mertens <wmertens@gentoo.org>2004-04-27 12:03:45 +0000
commit0961eab0a705015bf351f0e0edecf3650513b78c (patch)
tree7f3278ac9105786d40dd8e74488707364ff23d87 /app-vim
parentStable on sparc wrt bug #41800. (diff)
downloadhistorical-0961eab0a705015bf351f0e0edecf3650513b78c.tar.gz
historical-0961eab0a705015bf351f0e0edecf3650513b78c.tar.bz2
historical-0961eab0a705015bf351f0e0edecf3650513b78c.zip
version bump & stablify
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/cream/ChangeLog11
-rw-r--r--app-vim/cream/Manifest5
-rw-r--r--app-vim/cream/cream-0.29.ebuild32
-rw-r--r--app-vim/cream/files/digest-cream-0.291
-rw-r--r--app-vim/cream/files/gentoo-cream-0.29-mkdir.patch135
5 files changed, 182 insertions, 2 deletions
diff --git a/app-vim/cream/ChangeLog b/app-vim/cream/ChangeLog
index 469b8c2a1bf4..f5af83e87709 100644
--- a/app-vim/cream/ChangeLog
+++ b/app-vim/cream/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-vim/cream
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.3 2004/03/16 00:34:36 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.4 2004/04/27 12:03:45 wmertens Exp $
+
+ 25 Apr 2004; Wout Mertens <wmertens@gentoo.org> cream-0.29.ebuild:
+ Version Bump.
+ Changed the ebuild to use the install script, for upwards maintainability.
+ Note that the cream.sh executable was missing in CVS for 0.28, but it's
+ not necessary any more.
+ Patched creamrc so mkdirs also work under Unix.
+ Marking stable because the previous one didn't work for me and this one
+ does, and no stable version is available.
16 Mar 2004; David Holm <dholm@gentoo.org> cream-0.28.ebuild:
Added to ~ppc.
diff --git a/app-vim/cream/Manifest b/app-vim/cream/Manifest
index bf356e75fbe9..4c1373d8f280 100644
--- a/app-vim/cream/Manifest
+++ b/app-vim/cream/Manifest
@@ -1,4 +1,7 @@
-MD5 a12e8d937422db809def0465c2c44dcb ChangeLog 580
+MD5 49e422ece93461d68173e2b07c164fa0 ChangeLog 1014
MD5 a7cd02afa5a388b8fa5f207855a7645e cream-0.28.ebuild 862
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 d03edaca966b34f810ae169ee8f7c291 cream-0.29.ebuild 901
MD5 b805bdc2fd56028f6182d4fe44cfb033 files/digest-cream-0.28 62
+MD5 80e16a323fe29f813a5f6eba26aacfb3 files/digest-cream-0.29 62
+MD5 84d1ffabb8cfe8079a46971510a5505e files/gentoo-cream-0.29-mkdir.patch 3245
diff --git a/app-vim/cream/cream-0.29.ebuild b/app-vim/cream/cream-0.29.ebuild
new file mode 100644
index 000000000000..bdc55dbce5eb
--- /dev/null
+++ b/app-vim/cream/cream-0.29.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.29.ebuild,v 1.1 2004/04/27 12:03:45 wmertens Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="Cream is an easy-to-use configuration of the GVim text editor"
+HOMEPAGE="http://cream.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc ~mips ppc"
+IUSE=""
+DEPEND=""
+RDEPEND=">=app-editors/gvim-6.2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gentoo-${P}-mkdir.patch
+ cd $S
+ # Make the install script handle it. Point it to the destination dir.
+ # We handle docs ourselves.
+ sed -i~ -e s:/usr/:${D}usr/:g -e /docs/d INSTALL.sh
+}
+src_install() {
+ cd $S
+ dodir /usr/bin /usr/share/icons /usr/share/applications
+ ./INSTALL.sh
+ dodoc docs/*
+ dohtml docs-html/*
+}
diff --git a/app-vim/cream/files/digest-cream-0.29 b/app-vim/cream/files/digest-cream-0.29
new file mode 100644
index 000000000000..f26d600febbb
--- /dev/null
+++ b/app-vim/cream/files/digest-cream-0.29
@@ -0,0 +1 @@
+MD5 8eadeb59f0cee34a3877a730cd048366 cream-0.29.tar.gz 846237
diff --git a/app-vim/cream/files/gentoo-cream-0.29-mkdir.patch b/app-vim/cream/files/gentoo-cream-0.29-mkdir.patch
new file mode 100644
index 000000000000..513ed0fe2973
--- /dev/null
+++ b/app-vim/cream/files/gentoo-cream-0.29-mkdir.patch
@@ -0,0 +1,135 @@
+--- cream-0.29-orig/creamrc 2004-04-15 02:11:15.000000000 +0200
++++ cream-0.29/creamrc 2004-04-27 12:39:45.000000000 +0200
+@@ -36,6 +36,31 @@
+ " paths determined manually (not by Vim) need to be reversed.
+ set shellslash
+
++function! Cream_checkdir(dir)
++
++ " if directory doesn't exist, try to make it
++ if isdirectory(a:dir) != 1
++
++ " system call prep
++ if has("win32")
++ " remove trailing slash (Win95)
++ let tmp = substitute(a:dir, '\(\\\|/\)$', '', 'g')
++
++ " convert slashes to backslashes
++ let tmp = substitute(tmp, '/', '\', 'g')
++ else
++ let tmp = a:dir
++ endif
++
++ " mkdir (quote, regardless of spaces)
++ set noshellslash
++ call system("mkdir " . '"' . tmp . '"')
++ set shellslash
++
++ endif
++
++endfunction
++
+ " path initializations
+ " Cream_init() ($CREAM) $VIMRUNTIME/cream {{{1
+ function! Cream_init()
+@@ -151,21 +176,7 @@
+ let mydir = mydir . '/.cream/'
+
+ " if directory doesn't exist, try to make it
+- if isdirectory(mydir) != 1
+-
+- " system call prep
+- " remove trailing slash (Win95)
+- let tmp = substitute(mydir, '\(\\\|/\)$', '', 'g')
+-
+- " convert slashes to backslashes
+- let tmp = substitute(tmp, '/', '\', 'g')
+-
+- " mkdir (quote, regardless of spaces)
+- set noshellslash
+- call system("mkdir " . '"' . tmp . '"')
+- set shellslash
+-
+- endif
++ call Cream_checkdir(mydir)
+
+ " use if directory, writable
+ if filewritable(mydir) == 2
+@@ -184,9 +195,7 @@
+ let mydir = $HOME . "/.cream/"
+
+ " if doesn't exist, try to make it
+- if isdirectory(mydir) != 1
+- call system("mkdir " . mydir)
+- endif
++ call Cream_checkdir(mydir)
+
+ " use if directory, writable
+ if filewritable(mydir) == 2
+@@ -217,21 +226,7 @@
+ " (remember, g:cream_user is simplified and escaped)
+ let mydir = g:cream_user . "views"
+
+- " if doesn't exist, attempt to make it
+- if isdirectory(mydir) != 1
+-
+- if has("win32")
+- let quote = '"'
+- else
+- let quote = ''
+- endif
+- set noshellslash
+- " change slashes to backslashes for system call
+- let tmpdir = substitute(mydir, '/', '\', 'g')
+- call system("mkdir " . quote . tmpdir . quote)
+- set shellslash
+-
+- endif
++ call Cream_checkdir(mydir)
+
+ if filewritable(mydir) == 2
+ " we set a script global, only so viminfo (following) can
+@@ -280,20 +275,7 @@
+ let mydir = g:cream_user . "spelldicts"
+
+ " if doesn't exist, attempt to make it
+- if isdirectory(mydir) != 1
+-
+- if has("win32")
+- let quote = '"'
+- else
+- let quote = ''
+- endif
+- set noshellslash
+- " change slashes to backslashes for system call
+- let tmpdir = substitute(mydir, '/', '\', 'g')
+- call system("mkdir " . quote . tmpdir . quote)
+- set shellslash
+-
+- endif
++ call Cream_checkdir(mydir)
+
+ if filewritable(mydir) != 2
+ return -1
+@@ -320,20 +302,7 @@
+ let mydir = g:cream_user . "tmp"
+
+ " if doesn't exist, attempt to make it
+- if isdirectory(mydir) != 1
+-
+- if has("win32")
+- let quote = '"'
+- else
+- let quote = ''
+- endif
+- set noshellslash
+- " change slashes to backslashes for system call
+- let tmpdir = substitute(mydir, '/', '\', 'g')
+- call system("mkdir " . quote . tmpdir . quote)
+- set shellslash
+-
+- endif
++ call Cream_checkdir(mydir)
+
+ if filewritable(mydir) != 2
+ return -1