summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2003-12-06 03:17:32 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2003-12-06 03:17:32 +0000
commitce827db1666e0904f59ba325c979106523d1b331 (patch)
tree3824fe2dfe6e7ef3ec049657a5de1c2b4afd1fa1 /app-vim/vimpython/vimpython-1.7.ebuild
parentinitial version (diff)
downloadhistorical-ce827db1666e0904f59ba325c979106523d1b331.tar.gz
historical-ce827db1666e0904f59ba325c979106523d1b331.tar.bz2
historical-ce827db1666e0904f59ba325c979106523d1b331.zip
initial version
Diffstat (limited to 'app-vim/vimpython/vimpython-1.7.ebuild')
-rw-r--r--app-vim/vimpython/vimpython-1.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/vimpython/vimpython-1.7.ebuild b/app-vim/vimpython/vimpython-1.7.ebuild
new file mode 100644
index 000000000000..361711367ee8
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpython/vimpython-1.7.ebuild,v 1.1 2003/12/06 03:17:28 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: improvements for editing python scripts"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=30"
+
+LICENSE="vim"
+KEYWORDS="~sparc ~x86 ~ppc amd64"
+
+DEPEND="${DEPEND} >=sys-apps/sed-4"
+
+function src_unpack() {
+ unpack ${A}
+ # We know that we've got *vim >= 6.2, so we can safely enable the
+ # function which needs try/catch support.
+ sed -i \
+ -e '/" function! s:JumpToAndUnfoldWithExceptions/,/^$/s/" \?//' \
+ ${S}/plugin/python.vim || die "Sed magic failed"
+}
+