summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-25 11:38:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-25 11:38:54 +0000
commit87fe7720cba31d3f759a90898eaafe80acc824c0 (patch)
treea029beeff8c56bd14cc908a5e3eed1f9345becfa /app-text
parentVersion bump to fix #35919. (diff)
downloadhistorical-87fe7720cba31d3f759a90898eaafe80acc824c0.tar.gz
historical-87fe7720cba31d3f759a90898eaafe80acc824c0.tar.bz2
historical-87fe7720cba31d3f759a90898eaafe80acc824c0.zip
Just rip out the useful chunks from the Debian patchset so we dont have to screw around with autotools.
Package-Manager: portage-2.0.52-r1 http://www.bash.org/?136501
Diffstat (limited to 'app-text')
-rw-r--r--app-text/recode/ChangeLog7
-rw-r--r--app-text/recode/Manifest13
-rw-r--r--app-text/recode/files/digest-recode-3.6-r21
-rw-r--r--app-text/recode/files/recode-3.6-debian-11.patch63
-rw-r--r--app-text/recode/recode-3.6-r2.ebuild7
5 files changed, 79 insertions, 12 deletions
diff --git a/app-text/recode/ChangeLog b/app-text/recode/ChangeLog
index 4d373a9bd78d..f0f559135bf3 100644
--- a/app-text/recode/ChangeLog
+++ b/app-text/recode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/recode
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.32 2005/09/25 03:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.33 2005/09/25 11:38:54 vapier Exp $
+
+ 25 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/recode-3.6-debian-11.patch, recode-3.6-r2.ebuild:
+ Just rip out the useful chunks from the Debian patchset so we dont have to
+ screw around with autotools.
*recode-3.6-r2 (25 Sep 2005)
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index b7974cff0c78..52d774ebc136 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -3,15 +3,16 @@ Hash: SHA1
MD5 393ea3f45c6b6973ef4b07bca793207f recode-3.6-r1.ebuild 1327
MD5 0c131a7201c4670302767f93643876fa metadata.xml 165
-MD5 8176d65b557030dd6bac81b7045fd3cd recode-3.6-r2.ebuild 1184
-MD5 ebafccf25518de81fad3f4045d90bb50 ChangeLog 3654
+MD5 36f82b8ee6865877adb4bf522f5c8d17 recode-3.6-r2.ebuild 1117
+MD5 da7be315e0b1978cf00e94820d5378ca ChangeLog 3872
MD5 6d0ba2283055f0ad0f91ff4dfd0acfd9 files/digest-recode-3.6-r1 133
-MD5 64b054ed6e79a8fa22b72a3bd4b17ed1 files/digest-recode-3.6-r2 129
+MD5 61a763868b5509bfe1950db94b6ab1d7 files/recode-3.6-debian-11.patch 1913
+MD5 e442e84aa8cba1c847368c7fd1cefda1 files/digest-recode-3.6-r2 63
MD5 452b104654d5c6461c741ba20b6b19c4 files/recode-3.6-ppc-macos.diff 649
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDNkVTgIKl8Uu19MoRAj2xAJ9SEjjff8lcbe3szSWcBQMC+Xj4qwCdH9+g
-OGCTwAl7sr+R+2dM0AhxJR4=
-=rB7b
+iD8DBQFDNoyGgIKl8Uu19MoRArcAAJ9NVGG6YQ/Ou5J40MRIVR4ZcNtcowCeLmz2
+kt0lwcw+DbFXw1qcm7X2TpU=
+=S+42
-----END PGP SIGNATURE-----
diff --git a/app-text/recode/files/digest-recode-3.6-r2 b/app-text/recode/files/digest-recode-3.6-r2
index 5116a646b78e..06fe5e4c39ed 100644
--- a/app-text/recode/files/digest-recode-3.6-r2
+++ b/app-text/recode/files/digest-recode-3.6-r2
@@ -1,2 +1 @@
MD5 be3f40ad2e93dae5cd5f628264bf1877 recode-3.6.tar.gz 1751886
-MD5 222967f4647e3f9a636d97ffa769e2f3 recode_3.6-11.diff.gz 263880
diff --git a/app-text/recode/files/recode-3.6-debian-11.patch b/app-text/recode/files/recode-3.6-debian-11.patch
new file mode 100644
index 000000000000..d13c2206ae7b
--- /dev/null
+++ b/app-text/recode/files/recode-3.6-debian-11.patch
@@ -0,0 +1,63 @@
+Ripped from Debian patchset 3.6-11
+
+--- recode-3.6.orig/src/libiconv.c
++++ recode-3.6/src/libiconv.c
+@@ -195,12 +195,17 @@
+ memcpy() doesn't do here, because the regions might overlap.
+ memmove() isn't worth it, because we rarely have to move more
+ than 12 bytes. */
+- if (input > input_buffer && input_left > 0)
++ cursor = input_buffer;
++ if (input_left > 0)
+ {
+- cursor = input_buffer;
+- do
+- *cursor++ = *input++;
+- while (--input_left > 0);
++ if (input > input_buffer)
++ {
++ do
++ *cursor++ = *input++;
++ while (--input_left > 0);
++ }
++ else
++ cursor += input_left;
+ }
+ }
+
+--- recode-3.6.orig/src/request.c
++++ recode-3.6/src/request.c
+@@ -1073,7 +1073,7 @@
+ if (task->output.cursor + 4 >= task->output.limit)
+ {
+ RECODE_OUTER outer = task->request->outer;
+- size_t old_size = task->output.limit - task->output.buffer;
++ size_t old_size = task->output.cursor - task->output.buffer;
+ size_t new_size = task->output.cursor + 4 - task->output.buffer;
+
+ /* FIXME: Rethink about how the error should be reported. */
+--- recode-3.6.orig/src/task.c
++++ recode-3.6/src/task.c
+@@ -1198,6 +1198,8 @@
+ else
+ success = transform_mere_copy (subtask);
+
++ task->output = subtask->output;
++
+ if (subtask->input.name && *subtask->input.name)
+ fclose (subtask->input.file);
+ if (subtask->output.name && *subtask->output.name)
+--- recode-3.6.orig/src/hash.h
++++ recode-3.6/src/hash.h
+@@ -21,6 +21,11 @@
+ /* Make sure USE_OBSTACK is defined to 1 if you want the allocator to use
+ obstacks instead of malloc, and recompile `hash.c' with same setting. */
+
++#define hash_lookup recode_hash_lookup
++#define hash_delete recode_hash_delete
++#define hash_free recode_hash_free
++#define hash_insert recode_hash_insert
++
+ #ifndef PARAMS
+ # if PROTOTYPES || __STDC__
+ # define PARAMS(Args) Args
diff --git a/app-text/recode/recode-3.6-r2.ebuild b/app-text/recode/recode-3.6-r2.ebuild
index 2544eb664691..c05a078d83a6 100644
--- a/app-text/recode/recode-3.6-r2.ebuild
+++ b/app-text/recode/recode-3.6-r2.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r2.ebuild,v 1.2 2005/09/25 06:35:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r2.ebuild,v 1.3 2005/09/25 11:38:54 vapier Exp $
inherit flag-o-matic eutils libtool
DEB_VER=11
DESCRIPTION="Convert files between various character sets"
HOMEPAGE="http://recode.progiciels-bpi.ca/"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz
- mirror://debian/pool/main/r/recode/recode_${PV}-${DEB_VER}.diff.gz"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,7 +19,7 @@ DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${WORKDIR}"/recode_${PV}-${DEB_VER}.diff
+ epatch "${FILESDIR}"/${P}-debian-${DEB_VER}.patch
if use ppc-macos; then
epatch "${FILESDIR}"/${P}-ppc-macos.diff